VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. Salutations yíall itís been quite a while.

    Iíve been doing video editing a bit more frequently of late, using Avidemux
    as honestly itís the best option Iíve found so far that doesnít
    have usually a draw back save for the time it takes but thatís
    every program so far and I have a lot of time to wait. And yet
    Iíve come across something I cannot explain but Iíll try my best:

    I started converting MKVs to MP4, managing to sync the audio of
    a dual audio file that was running slightly ahead with the audio,
    it works perfectly in avidemux and even VLC
    player oddly enough. But hereís where it gets confusing. I started
    having issues, the audio wouldnít sync as it usually has every time
    I use WMP (Windows Media Player).

    Now when I cut a small few seconds or even a minute section from
    the converted MP4s, run them through again and add say 300
    milliseconds+ shift to it, the syncing is perfection. But the
    moment I do the same with the entire MP4 video, the sync is out
    by a few seconds again.

    I canít figure out what the issue is. Itís probably WMP but Iíve used
    it for years and it still beats most others Iíve tried.

    I donít get why the sync works on a small cut portion even in WMP
    but the complete file from start to finish goes those few seconds out
    of sync. Iíve been trying to convert these episodes for almost 2 or 3
    years+ and finally got around to it, but this is somewhat stopping
    me after I have literally spent hours searching for the perfect copies.

    Any ideas how to solve this? Or even how to fix WMP?

    Funny fact: if I have Bluetooth headphones attached the audio sync
    is almost if not dead on point even with WMP. But without them, it
    fails once again.

    Iíve tried updating codecs, restarting, re-converting, disabling and
    re-enabling different audio drivers and everything Iíve come across
    that was suggested. The shift refuses to work when I try to run it.
    I even disabled the WMP option to drop frames to keep it all
    in sync. It doesnít do a thing to help

    Any assistance or anything would be appreciated..
    Last edited by Greyback23; 26th Jun 2020 at 16:52.
    Quote Quote  
  2. Can you upload a sample MKV and MP4? I assume it'd be better to upload samples without removing/cutting anything from the beginning, as that's a factor in the audio-sync problem, but just 10 or 20 seconds or something of each from there.

    For the original MKVs, try opening some with gMKVExtractGUI to check for a delay. Both the video and audio stream can have a delay, and if a video delay isn't being applied when converting to MP4 that can mess with the sync. The streams should show 2 delay values. One is the actual delay, and for the video the other is the delay relative to any audio delay, and for the audio stream it's audio delay relative to the video, or something....

    If you see zero ms twice for each stream, there's no delay.

    Quote Quote  



Similar Threads