VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 31 to 41 of 41
Thread
  1. AC3 can be converted by tmpgenc, but its sketchy at best. I've had some files w/ .ac3 work and others that wont. Your best bet is to convert the .ac3 file w/ BeSweet to a .wav file. To do this:

    Extract the audio w/ Virtual Dub using "Direct Stream Copy" in the Audio section. Then go to Save as WAV, except in the file type box select "All Files" and give your file an .ac3 extension.

    Download BeSweet and all the .dll files (Azid, Lame, etc...) With this program and plug ins you should be able to encode the .ac3 audio to .Wav Audio and use it in tmpgenc.

    This is just a basic instruction for this, there are also various guides on this site using essentially the same process. They are a bit more detailed then my hamfisted typing directions.

    Hope this helps
    Quote Quote  
  2. arrowhead: At the risk of asking a stupid question, you don't have any problems playing the original file do you? (i.e., the audio works fine when watching an xvid file) The reason I ask is because if that's the case TMPGEnc won't work because it doesn't recognize the ac3 audio as a valid format.

    All I do (besides changing the "directshow" filter priority per my previous post) is select the xvid file as the video source and TMPGEnc automatically uses it for the audio source as well. Then I encode. Never had a problem with it.
    Quote Quote  
  3. Member
    Join Date
    Jan 2003
    Location
    Portland, OR
    Search Comp PM
    That is problem actually. When plays there is no sound. So I worked so hard to get it back
    Quote Quote  
  4. Member
    Join Date
    Jan 2003
    Location
    Amsterdam; the Netherlands
    Search Comp PM
    Instead of using Headac3ge & Besweet....... try Ac3tool; very easy to use.
    https://www.videohelp.com/forum/viewtopic.php?p=457446#457446

    D.C.
    " Check him for weapons..... no; he doesn't need 'm...... he IS a weapon. " -- Return of the Dragon.
    Quote Quote  
  5. arrowhead: the reason you have no sound when you play and the reason you're having so much trouble with TMPGEnc is because you don't have the ac3 codec installed on your system. Get the Nimo Codec Pack and install it. Do a 'custom' install if you have to and make sure 'ac3' is checked. You probably should also make sure 'ffdshow' is NOT checked... it caused me much trouble before I realized what the problem was.
    Quote Quote  
  6. Member
    Join Date
    Jan 2003
    Location
    Portland, OR
    Search Comp PM
    Sludgehead:

    Thanks for the advice.

    After install ac3 codec, I am now able to play the original avi movie with sound.

    But still it can only be input by TMPGEnc as video, audio input is not auto set. If set audio mamualy, it will complain can't open or not supported.

    I have another avi movie which is mpeg-3 audio encoded, not ac3. This one can be put as both video and audio input by TMPGEnc.

    Seems ac3 audio is still a problem to convert avi to mpg using TMPGEnc.

    -arrow
    Quote Quote  
  7. arrowhead: see my previous post in this thread. In order for TMPGEnc to work properly with ac3 you need to go to the environmental settings and give the "directshow" filter top priority.
    Quote Quote  
  8. Hi there,

    So I followed the guide and converted the xvid .avi movie into an mpeg by converting it first to a .m1v file. Just about 15 minutes into the movie the screen goes blank and I have no idea why? The first fifteen minutes are fine. I managed to convert them to a VCD and watched it on my DVD player. Why is the picture giving out after the first 15 minutes? Can anyone suggest anything?
    Quote Quote  
  9. This guide is bunk!!! I tried it this way and all I got was sync problems when I played my VCD. Do it the normal way you would handle a movie with AC3 use whatever program you want ( I use AC3DECODE) to convert the AC3 file to wav go to the guide on XVID for the settings you need to change on Tmpgenc and proceed normally.
    Quote Quote  
  10. HI,

    The guide was great however now after tmpgenc multiplexing it came up with and 447 s or something. Saying something along the lines of error could occurr when playing back.

    Anyhow closed tmgenc as it had finished multiplexing and played the movie. 1st 20mins no worries of crashing etc. (havent gone past there but it all seems fine). However audio is out of sync by about 1 - 2secs from the very beginning. Is there a way to find out the exact time its out of sync and how do you resolve the problem???

    Any info would be great cheers
    Quote Quote  
  11. Sync problems, yeah. I remember around a yeah ago I was trying to do thisl. Converting XviDs to DVDr, a timecomsuming project which didnt pay back...

    My problem was the accuall playback. Whenever there was any action in the image, playback would "stumble", whats the word. Think of it this way, PAL is 24 frames pr / sec, but in action scenes it became kinda obvious it looked like 6 frames pr second. Not good at all.

    I even used TempGenc with maximum quality in everything, it encoded for days to complete one movie. And the result was just the same, faulty playback.

    This resultet in that movies, drama, was OK to convert since you didnt "see" the errors. But an action film was no use in converting.

    It might have been my codecs, i honestly dont know. I only know I spend like 14 days on this and I never was satisfied...

    However, all other formats works just fine... Just the XviD -> something

    Now that I wrote this, I might want to try another go. Since I rememebered that I have formatted the machine since my last go, which would mean I have new settings of codecs. Since no other has complained of the "6 frames lookalike" it might just be my computer. That was the days of the "green" xvids,
    Quote Quote  



Similar Threads