VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Hi! I have a problem with FfmpegX and I don't find a way to fix it, I've seached the forum but I didn't find any answers...
    I'm trying to make a standart VCD from an AVI film that's in 16:9 format (the size of the avi file is 720x432), I select the VCD quick preset on FfmpegX and the process goes fine but the VCD that I obtain have a distorted image, I would like to have the image in letterbox format, with the 2 black bars on top and bottom, but I obtain a distorted image after encodding the film... I've tried the UNCONSTRAIN, 4:3 and 19:9 AUTOSIZE options but I get the same result.
    Can you help me?
    Thank you very much!
    Andreu
    Quote Quote  
  2. Put the avi in a .mov wrapper, ie open it up in QuickTime, Select All, New Player, Paste, Save, with dependancies.

    This will give you a small .mov file the references the avi.

    ffmpegX will then use movtowav and movtoy4m and feed the video into yuvscaler; this is where the automagic black bars computation comes from.

    So in summary...if you want the nifty black bars magic, you need to use QuickTime movies.

    -K[/quote]
    Quote Quote  
  3. Member
    Join Date
    Nov 2001
    Location
    squeed
    Search Comp PM
    I am not positive about this but there is a "VOB Letterbox" check box in the options of ffMpeg. I think that if you select that option you will get the black bars you are looking for.

    -Squeed
    VCD & SVCD Support For MAC
    http://www.squeeds.com
    Quote Quote  
  4. VOB Letterbox doesn't work on avi's. AVI content is processed thru ffmpeg only, which doesn't have the black bar capability.

    -K
    Quote Quote  
  5. Hi KaiCherry thanks for your info but it doesn't work... i create the small .mov file that references the AVI as you said but then , I get this message in the terminal window:

    Last login: Tue Oct 22 16:33:27 on ttyp1
    pbpaste | sh
    Welcome to Darwin!
    [PA1-1A-u-0285:~] andreu% pbpaste | sh
    header not found !!!
    header not found !!!
    -2 is not a valid mpeg file
    (Super) VideoCD xml description created successfully as `/Users/andreu/Desktop/testfilm.1.xml'
    ++ WARN: initializing libvcd 0.7.12 [darwin5.2/powerpc]
    ++ WARN:
    ++ WARN: this is the UNSTABLE development branch!
    ++ WARN: use only if you know what you are doing
    ++ WARN: see http://www.hvrlab.org/~hvr/vcdimager/ for more information
    ++ WARN:
    **ERROR: could not stat() file `/Users/andreu/Desktop/testfilm-1.mpg': No such file or directory
    (Super) VideoCD xml description created successfully as `/Users/andreu/Desktop/testfilm.2.xml'
    ++ WARN: initializing libvcd 0.7.12 [darwin5.2/powerpc]
    ++ WARN:
    ++ WARN: this is the UNSTABLE development branch!
    ++ WARN: use only if you know what you are doing
    ++ WARN: see http://www.hvrlab.org/~hvr/vcdimager/ for more information
    ++ WARN:
    **ERROR: could not stat() file `/Users/andreu/Desktop/testfilm-2.mpg': No such file or directory
    Encoding complete!
    [PA1-1A-u-0285:~] andreu%

    I use the VOB or DVIX to VCD (PAL) Quick Preset... Do you know if I'm doing something wrong? I've tried the MOV to SVCD Preset too but it doesn't work and I want a standart VCD... can you tell me if is it possible to encode it setting the pressets manually?
    Thanks again!
    Quote Quote  
  6. sorry

    You are correct; the way ffmpegX is set up currently it seems to only work with the mpeg2 stuff
    .
    *ffmpeg* could actually do this, but major would have to add the functionality into the gui wrapper,

    -K
    Quote Quote  



Similar Threads