VideoHelp Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. First off, I have an OLD running an OLD version of Windows, which limits me to using OLD software.

    I have been using MPC-HC v1.7.13 for many years and it's always worked great. I recently bought a small USB remote to use for when I watch movies. Although it has all the main features of a media remote, it didn't have four functions that I wanted;

    Subs on/off
    Next Sub
    Frame Step Forward
    Frame Step Backward

    However it does have four keys that send control combinations, Ctrl-Alt-A to Ctrl-Alt-D. They also send Ctrl-Alt-1 to 4 and Ctrl-Alt-F1 to F4 at the same time. I'm not sure how you're supposed to differentiate them, but whatever, it has four keys that I can use.

    So I changed the keys for those functions in MPC-HC to those combinations, and it works perfectly. Unfortunately, those keys are rather awkward to use when I'm not using the remote. So I figured I'd export two lists of the keys, one for normal usage and one for use with the remote, which are saved as .REG files. Then I made a small script that would import the remote specific keys, launch MPC-HC with my chosen video, then import the normal keys when the player closes.

    Unfortunately, that doesn't work. While it does import the remote keys, importing the normal keys reg file, only changes the keys for frame step back to normal. The keys for the subs stay changed. Testing by manually importing the reg files shows something strange. Importing the remote keys always works 100%, however importing the normal keys only resets the frame step keys. I have to then close MPC-HC, import the normal keys again, and THEN, the sub keys are reset. I've tried importing them multiple times in a row, but they still won't take effect until after MPC-HC has been run.

    I even tried exporting the entire MPC-HC registry key, but got the same results. No matter how many times the normal keys reg file is imported, the keys for the subs won't reset until after MPC-HC has been loaded, closed, and then the reg file imported again.

    Is there something I'm missing here? How can I literally put the registry key back to what it was, but the keys don't change until after it's been run, closed and then run again?
    Quote Quote  
  2. Never mind, I figured it out.

    I didn't realize that when you import a registry file, it only adds the information in it to the existing key. Thinking about it now, it should have been obvious, but I was thinking that the information in the reg file would replace what was there, rewriting the entire key.

    So the solution is to delete the key first, then import the file with the normal keys.
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!