VideoHelp Forum
+ Reply to Thread
Results 1 to 3 of 3
  1. Dear all,
    When I reduce the speed of an mp3 file using ffmpeg it is excellently working. but when i try to reduce the speed of amr file it is not working.

    ffmpeg -i a1.mp3 -filter:a "atempo=0.6" b1.mp3
    the command works very well with mp3 files.

    but is not working with amr files.

    ffmpeg -i a1.amr -filter:a "atempo=0.6" b1.amr

    Duration: 00:00:32.34, bitrate: 6 kb/s
    Stream #0:0: Audio: amr_nb (samr / 0x726D6173), 8000 Hz, mono, flt
    Automatic encoder selection failed for output stream #0:0. Default encoder for f
    ormat amr (codec amr_nb) is probably disabled. Please choose an encoder manually

    Error selecting an encoder for stream 0:0

    amr file it is not accepting so i zipped it and uploaded it

    Kindly help me in giving the right code.
    Image Attached Files
    Last edited by kamalakar108; 13th Jun 2024 at 23:28. Reason: amr file format not recognized.
    Quote Quote  
  2. Sounds like ffmpeg normally would use amr_nb, but since it's not present in your ffmpeg build, ffmpeg requests that you set another encoder.
    You will need an ffmpeg version which supports amr encoding, see:
    ffmpeg -encoders
    lists the encoders supported by a ffmpeg version.
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  3. Selur Sir, updated ffmpeg and it is working fine. Thanks a lot for your Reply.
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!