VideoHelp Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. I have LAV splitter enabled in MPC-BE and the language selection is "jpn,eng". There's also some advanced subtitle selection, but the specifics probably don't matter.
    When I open a video file for the first time, it plays the first audio track regardless of language. If that's jpn, it plays the first subtitle, regardless of language. If the first audio track is not jpn, it plays no subtitle. EDIT: apparently it depends on something, I tried another video file and on that one it picks no subtitle if the first audio track is jpn.
    If I close and reopen the video, this time it correctly selects the jpn audio track even if it isn't the first track, but still only selects whatever the first subtitle track is. If I change the audio myself, I have the option enabled to automatically switch subtitles, and then it finally uses the subtitle language preferences to select the correct stream.
    I made a new Windows profile and I have this problem on it. The previous Windows profile has the same MPC+LAV work completely fine. I don't even know where to begin with this. Does anyone have any idea what the heck is going on?
    Last edited by LordoftheBleak; 30th Mar 2024 at 15:15.
    Quote Quote  
  2. Seem to have fixed it myself. Didn't notice the language preferences option in MPC that was left checked but empty. For whatever reason, that seems to have been the issue. Unchecking it seems to be making language selection work properly the first time.
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!