VideoHelp Forum
+ Reply to Thread
Results 1 to 17 of 17
  1. As an experiment, trying to join three video clips using clever FFmpeg-GUI. But get error message when trying to load source video encoded using VP09 and video clip fails to load.

    I suspected the video encoding might be the issue, so I ran ffmpeg to re-encode the three video clips from VP09 to x265 encoding. The re-encoded clips now load fine in clever FFmpeg-GUI.

    So it seems the clever FFmpeg-GUI doesn't like videos encoded with VP09. Is that a known limitation of clever FFmpeg-GUI or a "bug" ?

    Screenshot of error message -

    [Attachment 77791 - Click to enlarge]
    Quote Quote  
  2. clever Ffmpeg-GUI can handle vp9 videos.
    The error message says, that it can't access the video.
    Do you have the necessary rights to access the file?
    Move it to another location and retry.
    If this doesn't work, cut 30 seconds from your vp9 video with avidemux and post it here.
    So i can take a look.
    Quote Quote  
  3. Still having problems with the original video clip encoded in VP09 even after copying this file to the system/boot drive (C:\).

    Problem video clips (total of three clips) encoded in VP09 are located in D:\Downloads directory.

    First I re-encoded all three video clips using ffmpeg and using x265 codec and saved these re-encoded clips within the same directory as the originals (D:\Downloads).

    clever FFmpeg-GUI successfully opens these re-encoded clips from the same directory as the original VP09 encoded clips.

    As a test, I copied part 1 of the VP09 encoded clips to my boot/system drive (C:\). But clever FFmpeg-GUI stills fails to open this clip with the same error message appearing as in my first post.

    First 30 seconds or so of the first VP09 encoded clip enclosed for study.
    Quote Quote  
  4. No problem to load your file here, as you can see:

    [Attachment 77799 - Click to enlarge]

    Try this:
    Delete this folder (it will be created again automatically):
    C:\Users\xxx\AppData\Local\clever_FFmpeg_GUI (where xxx=your user name on windows).

    Then restart clever FFmpeg-GUI and retry with your vp9 file.
    Quote Quote  
  5. Deleted the folder as instructed and re-ran clever FFmpeg-GUI. Unfortunately it still fails to load the VP09 encoded clips from both D:\Downloads directory and from the C:\ directory!?
    Quote Quote  
  6. Rightclick clever FFmpeg-GUI and run it as administrator.
    Then retry to load the file.
    Quote Quote  
  7. That worked! Thank you!

    I could open the clip from both the D:\Downloads and C:\ directory!

    However, I can open the re-encoded (using x265) clips without having to run clever FFmpeg-GUI as Administrator!

    Why does clever FFmpeg-GUI require to be run as Administrator when opening VP09 encoded clips, but is not required to be run as Administrator when opening x265 encoded video clips?
    Quote Quote  
  8. side note: clip is an MKV not an mp4,....
    Complete name : c:\Users\Selur\Desktop\Did_Woman_Break_Ex’s_Guit ar_in_a_Fight_over_$200_Part_1.mp4
    Format : Matroska
    Format version : Version 4
    File size : 10.4 MiB
    Duration : 30 s 28 ms
    Overall bit rate : 2 913 kb/s
    Frame rate : 29.970 FPS
    Writing application : Lavf58.76.100
    Writing library : Lavf58.76.100
    ErrorDetectionType : Per level 1
    FileExtension_Invalid : mkv mk3d mka mks

    ID : 1
    Format : VP9
    Format profile : 0
    Codec ID : V_VP9
    Duration : 30 s 28 ms
    Bit rate : 2 855 kb/s
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 29.970 (29970/1000) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Bits/(Pixel*Frame) : 0.046
    Stream size : 10.2 MiB (98%)
    Default : Yes
    Forced : No
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  9. This has nothing to do with the clever FFmpeg-GUI, but with the necessary rights to access the hard disk.
    Right-click on partition D: (in Windows Explorer, on the left side), set Properties, Security and post the picture here.
    Quote Quote  
  10. So, general users have no rights on the drive (unless they are in one of the other groups)
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  11. Here you can't see what access rights you have.
    But let's try something else.
    If you have access to the recoded files, then it is the vp9 file itself.
    Right click on it, properties, security, post the picture.
    Quote Quote  
  12. Give users full control.
    Quote Quote  
  13. Finally figured out how to change permissions to enable Users Full Control.

    clever FFmpeg-GUI now loads the VP09 encoded clips without issue and without having to run it as Administrator!

    Thank you very much for your time!

    EDIT: I just now checked the User permissions for the re-encoded (x265) clips, and Users do NOT have Full Control, and yet I can open these clips without issue in clever FFmpeg-GUI!?

    Why do the VP09 encoded clips need to have Users Full Control permissions, and yet the x265 encoded clips do not require these permissions in order to load them into clever FFmpeg_GUI?
    Last edited by meeshu; 18th Mar 2024 at 05:17.
    Quote Quote  
  14. I think that the access rights were compromised.
    You can reset the rights to those of the other videos as a test and see if it still works.
    Quote Quote  
  15. Yes! I reset permissions for the VP09 encoded clips back to how they were originally, and all of these clips now successfully load into clever FFmpeg-GUI without having to run clever FFmpeg-GUI as an Administrator!

    So it seems you were correct in that these original video clips were compromised/corrupted in some fashion somewhere along the line.

    Thanks again!
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!