VideoHelp Forum
+ Reply to Thread
Results 1 to 8 of 8
  1. As an experiment, I was trying to get the software "vmaf" working to calculate the overall quality of a processed video with respect to the original video.

    The original video is in avi format, with the processed video based on the original video is now in mp4 format using h265 codec.

    I tried to follow the "tutorial" here - vmaf_ffmpeg_windows_tutorial.

    Downloaded and installed the modified ffmpeg and the associated "models" as described within the tutorial, and installed them in the default locations (C:\ffmpeg and C:\ffmpeg\model). But every time I run the ffmpeg command within an elevated command window, I get error messages about unable to find/use some option? Possibly a file path issue as described within the tutorial, so I tried forward slashes and back slashes in various combinations for the model file path but I continue to receive the same (or similar) error message about unable to find/use the option!?

    [Attachment 76819 - Click to enlarge]

    What is wrong here?

    Any ideas?
    Quote Quote  
  2. escape for colon , change to forward slashes

    -lavfi "libvmaf=model_path='C\:/ffmpeg/model/vmaf_v0.6.1.json'"

    You will get the wrong results for AVI and MP4 if they use different timebase

    There is an example of the syntax used for different container timebases. But it should be 1/AVTB
    Quote Quote  
  3. Thanks for the reply!

    Unfortunately I still get the error message appearing?

    Syntax used is basically the same as yours -

     -lavfi "libvmaf=model_path='\:/ffmpeg/model/vmaf_v0.6.1.json'" -f null -
    The linked tutorial author did note that they had some difficulty in finding the correct syntax to use for the model path. Maybe some other combination of forward and back slashes is required? I did try some other combinations of slashes but it still didn't work.

    Further ideas?
    Quote Quote  
  4. They keep on changing the syntax every few months.

    EDIT: sorry not working, just a sec
    Last edited by poisondeathray; 6th Feb 2024 at 21:18.
    Quote Quote  
  5. That article was from 2020. It probably changed a few times in between

    This last month should look like this for windows:
    -lavfi "libvmaf=model='path=C\\\:/ffmpeg/model/vmaf_v0.6.1.json'"
    They will probably change it again
    Quote Quote  
  6. Many thanks for taking the time to find the (current) correct syntax!!

    Yes, the latest syntax works!

    Why on earth do they keep changing the syntax!? It makes things unnecessarily difficult for users!
    Quote Quote  
  7. Some of the blame due to changes in the vmaf library (each major release is probably going to change the syntax and options); some of the blame can be put squarely on ffmpeg land; but the character escaping "\\\:/" is all windows .
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!