VideoHelp Forum
+ Reply to Thread
Results 1 to 1 of 1
  1. Member
    Join Date
    Dec 2023
    Search Comp PM
    Searching the forum as a new member, I couldn't find anything about TAW 7. Of course, this new version was first released in June this year, which is where I stepped in, primarily to create BD. I do have experience with DVD Styler, but I wanted to step up and create higher quality videos, so I replaced my DVD burner with a BD burner.

    According to the website, TAW 7 requires Windows 10/11 x64, whereas TAW 6 also supported Windows 7. As I am very much a Windows 7 user, I tried to find anything on the internet about TAW 7 successfully running on Windows 7, but couldn't find it. So I downloaded the trial and gave it a shot on my Windows 7 system. Installation was successful and it installed .NET 6 desktop runtime as a prerequisite. When starting the trial version an error popped up about a missing file (api-ms-win-core-libraryloader-l1-2-0.dll) but TAW 7 continued to run and I could use it without problems.

    But the missing dll file bothered me, so I looked it up and found that this is a very common error, especially among gamers. So I followed some instructions I found and added the missing file to my system. After restarting TAW 7, another missing file error appeared (api-ms-win-security-systemfunctions-l1-1-0.dll). I added this one too and hoped it would be the last error.

    I restarted TAW 7 after adding the above two mentioned files and lo and behold, TAW 7 started without any error messages. I tested the program by creating a BD with menu and chapter pages for a 120min video. So far I had no issues with TAW 7 running on Windows 7. Everything worked very smoothly.

    I'm really excited about this and thought I should share this experience as it might be helpful to those in doubt about TAW 7 system requirements.

    Update 16-12-2023: After installing TAW 7 and adding the two dll files in system32, at some point I found that some apps, including some installer files refused to start. It took me a while to figure out that api-ms-win-security-systemfunctions-l1-1-0.dll was the culprit. So I moved both dll files, which are not native to Windows 7, to the TAW program folder. I now have a stable system with all software running smoothly.
    Last edited by munair; 16th Dec 2023 at 14:48. Reason: addressing an issue
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!