VideoHelp Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. I have an OLD system with Windows XP on it. MIDI playback used to work fine. If I double-clicked a .MID file, it would play in MPC-HC, DOSBox would play the MIDI music in DOS games, and any native Windows programs that used MIDI would just play the music.

    Now, I can no longer select a default MIDI device. Going to the audio devices control panel, I see the "Microsoft GS Wavetable SW Synth" listed in the dropdown box and I can click on it, but as soon as I click "OK" or "Apply", it clears the box.

    Thinking that device was the problem, I installed an alternate software MIDI device, it was listed in the dropdown box, but that one wouldn't stay selected either.

    By editing the DOSBox config file to include "midiconfig=0", music started working in DOS games again.

    Trying to Google the problem lead me to some web page that inspired me to look in the registry key;

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]

    Which has eight MIDI entries, and all but the first (the one with no number) were set to "wmdaud.drv". I changed that entry to match the others and now MIDI files play in MPC-HC again, but Windows still won't let me select a default MIDI device and MIDI playback doesn't work in other programs.

    DXDiag says everything is working fine, and the music plays without issues.

    I have tried uninstalling and reinstalling the drivers for the onboard Realtek audio, but that didn't help. This system also has an Nvidia graphics card that has audio hardware on it, but it's not being used. Why? Because the card only outputs sound to the HDMI port, which negates the use of dedicated speakers or the front-panel headphone jack. I am positive that MIDI was working with the card installed (I installed the card very shortly after I got the system), and in any case, I've tried uninstalling the entire Nvidia drivers package but that didn't make a difference.

    Does anyone have any idea what would cause Windows to be unable to select a default MIDI device?
    Quote Quote  
  2. Nevermind. After some more Googling, I stumbled across the answer. The "Drivers32" registry key was missing an entry for "midimapper". Once I added that, everything now works.
    Quote Quote  

Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!