VideoHelp Forum
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Hi

    Anytime I check someone's ffmpeg log file there's an element called "no-temporal-layers".
    The thing is, no matter my parameters, even if i literally copy/paste their parameters to test (or even with any default preset with no customization), my log file always return "temproal-layers=0" and not "no-temporal-layers" unlike on their log file.

    Why is that? And is "temproal-layers=0" the same as "no-temporal-layers" knowing that there's litterally "no-temporal-layers" as parameters in the x265 doc?
    https://x265.readthedocs.io/en/master/cli.html?highlight=temporal-layers#cmdoption-tem...emporal-layers

    What I tried to have that "no-temporal-layers" like everybody else, and what it returns:
    default (not adding anything) >>> temporal-layers=0
    temporal-layers=0 >>> temporal-layers=0 (obviously
    no-temporal-layers=1 >>> temporal-layers=0
    no-temporal-layers=0 >>> temporal-layers=0 ...

    I'm using the latest ffmpeg version to date, 7950 CPU, 96Gb ram. My preset is "Slower" with CRF 16,15 or 14 (doesn't matter anyway I guess) and some tweaking from "veryslow"and "placebo", but as explained above, even a default preset with no customization, always returns "temporal-layers=0" and not "no-temporal-layers" like everybody else

    Thanks
    Last edited by Awman; 15th Sep 2023 at 07:58.
    Quote Quote  
  2. Yes, ffmpegs with:
    Code:
    -x265-params: "temporal-layers=0"
    has the same effect as using x265 command line encoder with:
    Code:
    --no-temporal-layers
    or
    Code:
    --temporal-layers 0
    (the x265 command line encoder accepts both)

    I assume you read https://x265.readthedocs.io/en/latest/cli.html?#cmdoption-temporal-layers-no-temporal-layerss and thus understand what that option is for and what it's effects are,..

    For those interested in what x265 will change in the source code, see:
    https://bitbucket.org/multicoreware/x265_git/src/343ac2692c771b4539fe41d12408fd75b4289...cpp#lines-2312
    https://bitbucket.org/multicoreware/x265_git/src/343ac2692c771b4539fe41d12408fd75b4289...cpp#lines-3903
    https://bitbucket.org/multicoreware/x265_git/src/343ac2692c771b4539fe41d12408fd75b4289...cpp#lines-4233

    Can't comment on what you see in your or other people's ffmpeg log files without seeing them.
    I suspect that you are not looking at the ffmpeg log output, but rather at the SEI message that contains the encoding settings, but can't tell for sure.
    I don't see "temporal-layers=.." in my ffmpeg logs at all,...

    I'm using the latest ffmpeg version to date...
    the libx265 version used is probably the important thing, not the ffmpeg version itself.
    (Any output regarding 'temporal-layer' I know of, is created by libx265.)

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  3. I use the program "ffmpeg batch converter" with "-x265-params:" like in your first exemple. Maybe the "no-temporal-layers" (sometimes they also have "temporal-layers=0" in the log on top of it) that they have is due to the fact that they use something like vapoursynth? I tried also directly with ffmpeg command line, and still don't have the "no-temporal-layers" just the "temporal-layers=0"

    Anyway, what matters is that it has the same effect as "no-temporal-layers" even if i'm confused about why every single mediainfo log file I see from other users, contains the "no-temporal-layers" sometimes even on top of "temporal-layers=0", but not mine.

    Thanks for help!
    Quote Quote  
  4. Vapoursynth has nothing to do with the encoder settings or output.
    The x265 encoding settings, shown by MediaInfo, depend on the x265 version.
    The names and values in that string did change over time.

    If you want to know what changed over time, you need to look at the history of https://bitbucket.org/multicoreware/x265_git/src/master/source/common/param.cpp the x265_param2string function is what creates that string.

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  



Similar Threads

Visit our sponsor! Try DVDFab and backup Blu-rays!