VideoHelp Forum

+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 31 to 42 of 42
Thread
  1. Originally Posted by Johnnysh View Post
    someone asked about my screen settings,.....
    I have been asking for the monitor's refresh rate which is 60Hz in your case. As 60Hz is not an integer multiple of 25fps you would always get a little judder on PC (if this judder is what you are wondering about when others say your files play smooth).
    Last edited by Sharc; 26th Jan 2023 at 14:20.
    Quote Quote  
  2. Originally Posted by poisondeathray View Post
    Originally Posted by Sharc View Post
    How would I see that the video is encoded with field structure? From the header? MediaInfo reports "fields", but ffprobe reports 'interlaced_frame=true'.
    gspot and dgindex can also report frame structure

    The value is reported under the picture_coding_extension , picture_structure will report "3" for frame picture, such as in Skiller's re-encode . Those 2 samples report "2" which is bottom field

    Table 6-14 in the ITU Rec. h.262 document lists the values
    Thank you. So I can't detect it with 'ffprobe -show_frames', it seems.
    Quote Quote  
  3. Originally Posted by Johnnysh View Post
    yes could be my premium Zidoo UHD3000 £1000 media player, but don't think so.....
    There obviously is a problem with your player. All the m2v files you've uploaded are DVD compliant and should play properly in any player, especially a premium player. Complain to Zidoo. Send them a sample.

    Kodi on my Google TV plays them properly. The Google TV version of VLC does not -- probably the same jerkiness you're seeing. The Google TV version of VLC is very crippled compared to the Window version.

    Kodi on my US$20 Android TV plays the videos properly. VLC plays them with a black screen.
    Last edited by jagabo; 26th Jan 2023 at 22:01.
    Quote Quote  
  4. @Johnnysh: Did you ever try skiller's variant of post#18 and report back? That would clarify a lot regarding your playback sceanrios and the Zidoo.
    Quote Quote  
  5. Member
    Join Date
    Apr 2010
    Location
    London
    Search PM
    Hi All

    Well just set VLC player to "on" (not automatic) and "Yadif (2x)".

    and these files do not play silky smooth!! the play same as before blury non fluid ??


    This interlacing of TV show is a real pain in the .....

    Guess i will strip chapter and get rid of the interlacing once and for all with QTGMC


    Regards
    Quote Quote  
  6. Member
    Join Date
    Apr 2010
    Location
    London
    Search PM
    thanks
    Image Attached Thumbnails Click image for larger version

Name:	1.JPG
Views:	11
Size:	161.9 KB
ID:	68910  

    Click image for larger version

Name:	2.JPG
Views:	9
Size:	154.9 KB
ID:	68911  

    Quote Quote  
  7. Member
    Join Date
    Apr 2010
    Location
    London
    Search PM
    Hello Guys

    well time to QTGMC


    could someone please advice the best LOSSESS QTGMC settings to convert MAKEMKV chapter rip to mov / mkv etc


    Code:
    SetFilterMTMode("QTGMC",2)
    FFMPEGSource2("LB1_t00.mkv",atrack=1)       # make -1 if no audio ???
    ConvertToYV12(interlaced=true)
                                                                        #ConvertToYUV422(interlaced=true)
    AssumeTFF()                                                 # Assume Top Fild First
    #crop(5, 2, -5, -2)
                                                                           #Crop(0,0,704,576)
    QTGMC(preset="Slower", EdiThreads=6, Sharpness=0.5)
                                                                           #QTGMC(Preset="slow", EdiThreads=3, SourceMatch=3, Sharpness=0.5, TR2=2, Lossless=2)
    #BilinearResize(720,576)
                                                                           #''BilinearResize(640,480)
                                                                           #LanczosResize(720,540)
                                                                           #Spline64Resize(720,540)
                                                                           #LanczosResize(696,520)
    
    Prefetch(10)



    im guessing DVD is 4:2:0 8bit ??? so is this part right

    ConvertToYV12(interlaced=true) ?



    then in virtual dub 2 what do I output to for 100% lossless QTGMC from the original MKV file

    the quality is so bad any way from the original DVD rip after the de interlacing I don't want to lose any further quality

    any advice much appreciated
    Last edited by Johnnysh; 30th Jan 2023 at 17:35.
    Quote Quote  
  8. the quality is so bad any way from the original DVD rip after the de interlacing
    The quality is probably bad before deinterlacing and has little to to with QTGMC(), but anyway:
    Code:
    QTGMC(Preset="Fast",lossless=1)
    It keeps the field untouched which is however not the "best" for the deinterlaced quality.

    If you want to re-interlace for your player:
    Code:
    QTGMC("Preset="Fast",lossless=1)
    separatefields().selectevery(4,0,3).weave()
    Last edited by Sharc; 30th Jan 2023 at 18:01.
    Quote Quote  
  9. Member
    Join Date
    Apr 2010
    Location
    London
    Search PM
    thank you for your reply


    so I now notice on the top line a flicker ?? its almost as though i need to crop the 1st line to get rid of the flicker, but the crop command gives an error

    and yes your right the quality is low grade BBC TV DVDs made by EUREKA, that company is a Total Disgrace converting quality TV series to ultra low grade DVD

    SHAME ON EUREKA, what a tin pot outfit, shame a professional company never was involved


    so is below the very best quality for de interlacing hours of DVDs

    I have played around with so many setting tonight, Im totally lost now

    I have even converted to 422 but can't see the point as its low grade dvd

    what compression settings should I choose







    SetFilterMTMode("QTGMC",2)
    FFMPEGSource2("LB1_t00.mkv",atrack=1) # make -1 if no audio ???
    ConvertToYV12(interlaced=true)
    #ConvertToYUV422(interlaced=true)
    AssumeTFF() # Assume Top Fild First
    #crop(5, 2, 5, 2)
    # Crop(0,0,704,576)
    #QTGMC(preset="Slower", EdiThreads=6, Sharpness=0.5)
    QTGMC(Preset="Fast",lossless=1)

    #QTGMC(Preset="slow", EdiThreads=3, SourceMatch=3, Sharpness=0.5, TR2=2, Lossless=2)
    #BilinearResize(720,576)
    #''BilinearResize(640,480)
    #LanczosResize(720,540)
    #Spline64Resize(720,540)
    #LanczosResize(696,520)

    Prefetch(10)


    https://files.videohelp.com/u/186491/Capture.PNG

    thanks in advance
    Last edited by Johnnysh; 30th Jan 2023 at 18:38.
    Quote Quote  
  10. Member
    Join Date
    Apr 2010
    Location
    London
    Search PM
    when I add this

    separatefields().selectevery(4,0,3).weave()


    I get an error ??


    not sure why but it does not like this command
    Quote Quote  
  11. Note that the lossless modes of QTGMC keep the original scanlines of a field and fill in only the in-between lines (the other field). That leaves the original lines intact but limits the ability of QTGMC to remove aliasing/buzzing artifacts. So the visual quality is generally lower with the lossless modes.

    The output of ffmpegsource2 is probably already interlaced YV12 (you can use Info() to find out for sure) so you don't need to ConvertToYV12(interlaced=true).

    YV12 video cannot be cropped by odd values. All values must be mod 2 or more. I recommend you keep to a final mod 4 frame size. If you plan on re-interlacing YV12 video you must keep a mod 4 frame height. Keeping small black borders is no big deal. Since your DVDs are obviously ITU caps I recommend cropping a total of 16 columns off the left/right edges, leaving a 704 pixel wide frame. Then encode with a sampling aspect ratio (SAR) of 12:11 for 4:3 material, 16:11 for 16:9 material.

    The faster presets in QTGMC deliver worse quality than the slower ones. If speed isn't an issue consider using slower presets.
    Quote Quote  
  12. Originally Posted by Johnnysh View Post
    when I add this

    separatefields().selectevery(4,0,3).weave()


    I get an error ??


    not sure why but it does not like this command
    What error? When you seek at random along the timeline using the slider in VirtualDub2?
    Maybe remove from your script:
    SetFilterMTMode("QTGMC",2)
    Prefetch(10)

    But anyway, you would need the separatefields().selectevery(4,0,3).weave() only for re-interlacing when your player requires interlaced video.
    Last edited by Sharc; 31st Jan 2023 at 06:49.
    Quote Quote  



Similar Threads