VideoHelp Forum

+ Reply to Thread
Results 1 to 8 of 8
  1. When playing 1 specific file, at some position the sound is broken, always, I had this problem with other files before.

    To reproduce:
    - use PotPlayer v221102 64-bit, tested also with default settings
    - download this file from tv-archive, 1080p version:
    - you can use Video DownloadHelper extension for Firefox or Chrome
    - same file uploaded, 735MB:
    - open the file in PotPlayer
    - move position few seconds before position 07:34

    Sound is broken from this position, also after seek anywhere, it sounds a bit like dial-up sound, after PotPlayer restart it's OK, also after moving position after 07:35, sound is OK.

    I tested also in v221117 Beta 64-bit, it's broken in this version too.

    I tested in MPC-BE and VLC and it works good, also in older PotPlayer 210729 32-bit it's OK, so the problem started probably in some newer PotPlayer version.

    EDIT: I tried to record the video, but there is no sound for the broken part.

    PotPlayer v221102 64-bit, v221117 Beta 64-bit, Windows 10 64-bit, X-Fi Titanium PCI-E, latest drivers.
    Last edited by Dreamer; 19th Nov 2022 at 14:54.
    Quote Quote  
  2. Ahoj!

    I downloaded the video using jDownloader (just be careful and find the clean online installer if you want to use it). I found it with addon/extension called The Stream Detector (file playlist.m3u8 and at the moment of detection:
    Video DownloadHelper finds separate streams.
    I checked PotPlayer v221102 64-bit and v221117 Beta 64-bit. I always use a website of Polish authorised translator of PotPlayer:
    The sound seems to be OK for the whole video (lip-synch adds up). The time you give they start to talk about Valentina Tereškovová.

    The problem might be the program you use to download the video. Video DownloadHelper was very good in the past. Now it is still good to sniff/detect streams sometimes.
    I personally use jDownloader and FireDM (I mentioned it in this thread: )

    Small instruction, because this program isn't developed anymore ("thanks" Google!):
    After downloading and unziping FireDM, start it and go to Updates. Click "Check for updates". Components will get updated (you need new versions of yt_dlp or youtube_dl). Close FireDM, go to its folder and in subfolder lib delete the “firedm” folder and rename “firedm_bkup” to just “firedm”. And then start it. Do it always after updating the libraries, because the last version 2022.4.14 was made to block the program. Last working version is 2022.2.5. Don't forget to set "Select video extractor" to yt_dlp (because at the moment it gets actively mantained) and put ffmpeg.exe in main folder and set its path in Settings.

    P.S. 1: Did you let PotPlayer download additional codecs during its installation?

    P.S. 2: Do you use MediaInfo to check audio/video files?
    Last edited by AllisOne; 19th Nov 2022 at 16:37.
    Quote Quote  
  3. Thanks for testing, could you download the file from the link I provided, please?

    I always download additional codecs during installation.

    Regarding PotPlayer, you can use the first link in the first post, source is videohelp - this site, or the official homepage: .

    As I said, it's broken only in the new PotPlayer versions, it works good in older PotPlayer version and also in MPC-BE and VLC, so if the problem would be bad downloaded video file, it would be broken in other players too.

    Perhaps the problem is in the audio card HW or SW, so if anyone have any X-Fi, or any Creative sound card, you could test too.

    Another way, could you try it with default settings? You can use the portable version, unpack to another folder, your main installation will be preserved.

    EDIT: I tried to copy the link from the video and play it live in PotPlayer without downloading the file, it works OK this way, using this link, just copy to clipboard and press Ctrl+V in PotPlayer:

    EDIT2: I re-downloaded the file using Video DownloadHelper (can't use jDownloader 2), still the same - again, if it would be bad download, why is it broken in the new PotPlayer versions only - and OK in old PotPlayer and in MPC-BE and VLC?

    BTW If it's the bad download, then the file size is important, my size is 735 MB (770*806*581 bytes) - both files, is your file size the same?
    Last edited by Dreamer; 19th Nov 2022 at 17:14.
    Quote Quote  
  4. I checked your file from with PotPlayer 221102 Portable x86 and 64-bit from videohelp (all default). The sound after 07:34 is broken/"chopped".
    The file I downloaded using jDownloader is OK.
    Quote Quote  
  5. Thanks for testing.

    Finally I downloaded the same file using jDownloader2 (latest dowloaded version) - I had to use the link from the Video DownloadHelper, the size is different 734 MB (770*497*251 bytes) and this file is OK here too, even in the newest PotPlayer version.

    How come that the 100% same file is broken in the new PotPlayer versions - and the same file is OK in old PotPlayer, MPC-BE and VLC? (BTW can you confirm, that the broken file is OK in MPC-BE or/and VLC?)

    So where is the problem - is it the Video DownlodHelper bug, or PotPlayer bug?
    Last edited by Dreamer; 19th Nov 2022 at 17:40.
    Quote Quote  
  6. I checked your file with MPC-BE x64 dev and VLC 3.0.18 x64.
    MPC-BE plays it OK.
    VLC - the sound is more or less OK, but audible clipping.

    As I said Video DownloadHelper isn't the best audio/video downloader. The streams this times are "chopped" into pieces when streamed (DASH, HLS itp). So it could be an VDH error at that time. Or PotPlayer bug (too sensitive to errors?). Etc. If such error appears I just try to download video with a different program.
    Quote Quote  
  7. OK, thanks, I just want to know, where to report this bug - Video DownloadHelper, or PotPlayer?

    If I'd report it in Video DownloadHelper, author may say - it's OK in MPC-BE and and VLC, not a bug.

    If I'd report it in PotPlayer, author may say - it's OK if the file is downloaded using jDownloader, not a bug.

    BTW The file size when using Video DownloadHelper is 735MB, when using jDownloader, file size is 734 MB, so the first program add something to the file - that could be a problem, but what is it?

    EDIT: I tried to download the same file using Chrome and Video DownloadHelper, video file is broken, same as in Firefox, file size is the same as in Firefox.
    Last edited by Dreamer; 19th Nov 2022 at 18:48.
    Quote Quote  
  8. I'm downloading video from that site each week, using Video DownloadHelper, because it's easier and every time I have the same problem, broken sound from some position and when I close PotPlayer, re-open and play, it's OK, then it's broken after few minutes again, possibly 2x the same position.

    Is it a PotPlayer bug, or Video DownloadHelper bug? Where should I report it?
    Quote Quote  

Similar Threads