VideoHelp Forum

+ Reply to Thread
Results 1 to 13 of 13
  1. I've used Toolnix for many years. But on one PC (not my second one on a homenet ethernet) a DLL error has appeared.
    It is not solved with first deleting the old with RevoUninstaller and then getting the new download at Moritz's site.
    Information from Moritz on this is from 2012 or something.

    The error is on dxgi.dll. The info on that said it's related to direct x.

    Can my DirectX be updated? Is it on the motherboard setup disk? I have no ability to run command line
    software patches or installs since I don't know how.

    From seeing google entries, this dxgi.dll and some other dll errors have cropped up with users going back
    years. Is there a solution aside from reinstalling my Win7 and losing current jobs and data? Does the
    Win7 Repair disk fix any of this?

    Last thing: SFC /SCANNOW does report 'one or more errors' in it's message. It says that scannow
    cannot fix it.

    Worst case is I can transfer my work files (for subtitles and such) to a backup HD. But that is a
    process where I can miss things.
    Quote Quote  
  2. I'm a Super Moderator johns0's Avatar
    Join Date
    Jun 2002
    Search Comp PM
    Just install directx.
    I think,therefore i am a hamster.
    Quote Quote  
  3. Thanks. I'll report any progress.
    Quote Quote  
  4. I got the auto installer package from Microsoft, ran that and did a fresh restart. Unfortunately the error is still
    there. Other help sites say getting dll's from the net is taking chances. Is it possible to get the dll from my backup HD
    and put that in the proper directory? Any other suggests appreciated.
    Quote Quote  
    Join Date
    Jun 2009
    Search Comp PM
    Last edited by El Heggunte; 26th Sep 2022 at 14:33. Reason: .
    "Programmers are human-shaped machines that transform alcohol into bugs."
    Quote Quote  
  6. Originally Posted by Quint View Post
    Yes that was the first thing I did-- it was just at the top of a Google search. It ran fine. But after it
    failed, I didn't know if it was just a program extension needing the root DirectX.
    Quote Quote  
  7. Originally Posted by El Heggunte View Post
    Yes I also saw that note before making my inquiry here. It's from 5 years ago and there have been lots of Toolnix
    updates since then.

    But in that note it refers to Windows Media Framework which I know nothing about. That's not Net Framework or it would
    be called Net Framework. Toolnix works on my backup PC, a mirror system of most programs I use. That has loaded fine.
    Quote Quote  
  8. I'm going to see if I can tease out the DLL and copy it to my mirror system for any errors.
    If crosstalk is an issue, here is a screen shot I made yesterday from the Everything directory search tool-- which looks at everything.

    You can see where the dll is installed a number of places. I don't know what various installers do, so it is all news to me.
    Image Attached Thumbnails Click image for larger version

Name:	dxgidll.png
Views:	23
Size:	84.5 KB
ID:	66995  

    Quote Quote  
  9. I ran the dll diagnostic program in System32 and no errors were reported that I could see. I don't know what the
    digital 'signing' is for so I don't know if that is related to the failure to load error.
    Quote Quote  
  10. I will look at the non official builds link above.

    However I'm calling the problem solved with this solution:

    I checked my mirror PC where there were fewer updates and rolled back to old version called v60gui....whatevs.
    The program loads fine now on the problem PC. My OS is old. I haven't seen any features changes in MKVToolnix
    so this brings the functioning program back.

    Thanks to all who've answered on it and I'll report back if, after a restart etc., the problem comes back.
    Quote Quote  
  11. The non official MKVtoolnix thread was interesting. The short answer is without all the stress of subscripts on v. 67, the user is safe getting up to version 66. I didn't know about the incompatibility issue until seeing the thread so I won't bother with any upgrade notifications.
    Quote Quote  

Similar Threads