VideoHelp Forum

+ Reply to Thread
Results 1 to 22 of 22
Thread
  1. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    Hello,

    First of all, I apologize for disturbing you.

    I made videos using an "Honor 10" smartphone and a DJI Osmo 2 stabilizer.

    It turns out that all mp4 files are unreadable when they are launched on any local player from my PC (VLC, Windows media Player, Premiere Pro...)
    [Image 1] Image
    [Attachment 66262 - Click to enlarge]


    while they have no defects from any other device or even from an online reader (Google Drive, Youtube...)
    [Image 2] Image
    [Attachment 66263 - Click to enlarge]
    .

    I have already reinstalled some codecs using "K-lite Codecs" but without success.

    I have been looking for a solution to this problem for several months without an answer... I hope you can help me!

    Thanks,
    Docavem
    Image Attached Files
    Quote Quote  
  2. 1. accoding to mediainfo that is no .mp4 file but a wrongly names .avi file
    2. looking at the file with an hex editor is was created with "VLC Media Player - 3.0.16 Vetinari" since according to mediainfo it's using:
    Format : MPEG-4 Visual
    Codec ID : DIV3
    Codec ID/Hint : DivX 3 Low
    which isn't MPEG-4 compatible,... my guess is that whoever used VLC to repackage this messed up and used some wrong headers, since I highly doubt that any application that creates DivX3.11 would was developed in the last 10+ years.

    At least for that file google drive doesn't properly playback that file as you claimed.
    -> share a proper file

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  3. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    I see, tanh you for your response ! Unfortunately, I don't know enough about it and if I change the extension to .avi, the video shows the same faults when viewed!

    Here is the link of the video on the Google Drive (https://drive.google.com/file/d/1oLpPHxJNB8UJFn6lacHOwXvIGpCiWmUC/view?usp=sharing) which is visible on the player and can be seen when downloaded on any device except mine...

    I really don't know how to repair this problem...
    Quote Quote  
  4. You used some browser plugin to download the file. -> check your browser addons and disable them especially anything related to vlc, than try downloading the file again.
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  5. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    I couldn't find any VLC plugin and I even uninstalled VLC as well as all preferences and caches to check, the problem still persists.

    Even if I download the video on another PC, the video is clearly visible without defects, and even if I send it to myself via a USB key, it becomes instantly unplayable as soon as I try to play it on my PC...
    Quote Quote  
  6. Are you using a proxy or something similar, could be that there is an issue with the cache,... attached the file I got from GoogleDrive.
    Image Attached Files
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  7. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    No, I don't use any of that!

    I am sending you back the file you just sent me and when I tried to play the file you just sent me, it showed the same faults as usual!
    Image Attached Files
    Quote Quote  
  8. That file plays fine through MPC-HC for me,.. (no codec packs or similar trash installed here)
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  9. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    That file plays fine through MPC-HC for me,.. (no codec packs or similar trash installed here)

    Yes, that's exactly my problem, all the friends I sent these files to could read it without any problems, but as soon as I try to read it on my PC, it gives the artifacts that I put in picture.
    Quote Quote  
  10. Did you try portable version of MPC-HC? If not what player are you using.
    Also how come you upload a totally different file?
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  11. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    No, I haven't tried MPC-HC but I have tried different players such as: VLC, Windows Media Player, Windows Photo, Premiere Pro, After Effect and Media Encoder.
    With all that, I always had the same problem!

    I don't think I'm downloading a different file since each time I send it back, the person who receives it has no problem reading it.
    I think it's a reading problem on my PC but I don't understand which one...
    Quote Quote  
  12. Then how about trying MPC-HC it by default uses the hardware decoder of your graphic card, but you can en- and disable the Support for different formats through the graphic card under Options..->Internal Filters->Internal LAV Filters settings->Video decoder.

    Also you sill have not explained hot that .avi which was renamed to .mp4 came to existens.

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  13. Member
    Join Date
    Aug 2022
    Location
    France
    Search Comp PM
    The problem is that I'm supposed to use these shots to edit in Adobe Premiere Pro, and I'd like that to be where the videos become usable again.

    For the .avi, I don't know where it comes from because the videos were shot in .mp4 and there was never any use of .avi
    Quote Quote  
  14. I have not downloaded to file yet.
    Have you thought about using a converter ?
    Like the Clever GUI for ffmpeg.
    I believe Selur is the creator of Hybrid another conversion software.
    Quote Quote  
  15. It's probably some addon or something he did with his graphic drivers or some capturing software.
    -> I'm off this thread doesn't lead any where since without the thread user copoerating there's no way to get to the bottom of whats happening.

    Wish you the best luck figuring out how you messed up your system.

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  16. Member
    Join Date
    Jul 2009
    Location
    United States
    Search Comp PM
    The original file does not play properly on an android tablet with vlc, a xp pc with mpc-hc, nor on a win 7 pc with mpc-hc. The google drive video has been converted to a 4k avc and plays ok everywhere.
    Quote Quote  
  17. There is some kind of corruption of this file.

    I tried working on it with ffmpeg,Clever, & also mkvtoolnix.
    None of these created a file that works on my players correctly.
    Those are VLC,MPCV-HC,MPC-BE,& Zoom.

    The audio track was also very low & barely audible.
    Quote Quote  
  18. Member darkknight145's Avatar
    Join Date
    Feb 2007
    Location
    Australia
    Search Comp PM
    The first (Bad) file you posted only has a resolution of 720x576 and is 2.7mb in size.
    The second file (google drive) you posted has a resolution of 3840x2160 and is 29mb in size.
    The files have completely different specs.
    I'd say you grabbed the wrong version of the file from somewhere or something has wrongly converted it in your system.
    Quote Quote  
  19. DJI_20210716_172417.mp4 from Post #1 is corrupt and cannot be restored.
    FromGoogleDrive_DJI_20210716_172417.mp4 works, but has a very hight resolution your computer maybe isn't able to play properly.
    Try if this one is playable on your computer
    Image Attached Files
    Last edited by ProWo; 12th Aug 2022 at 14:03. Reason: muxed audio to video
    Quote Quote  
  20. @ ProWo,
    I used your Clever for most of this but used Audacity for the Audio track.
    It still has a few
    "Pops" at the end but at least it can be heard.
    Just music anyway.

    The problem I had with Clever is the video file kept changing back to High@L5.1.
    Doing this conversion last worked.
    Also on the conversion it would only do .MKV.
    I was able to change to .MP4 when I Multiplexed it.

    VLC now plays the .mp4 I did.
    MPC-HC & BE play the video OK but have a couple of pauses with the Audio.
    Zoom player plays it OK.

    Funny the .M4A i used for the Audio track plays OK by itself.
    Also while I have your attention a Log file option for Clever would be nice.

    Take a look at the files I did if you want to.

    I believe the OP left & doesn't look like he is returning.
    Image Attached Files
    Quote Quote  
  21. Originally Posted by cholla View Post
    @ ProWo,
    I used your Clever for most of this but used Audacity for the Audio track.
    It still has a few
    "Pops" at the end but at least it can be heard.
    Just music anyway.
    You can use clever FFmpeg-GUI for this too.
    Convert Audio Stream, Volume detection, encode with the found value.

    Originally Posted by cholla View Post
    The problem I had with Clever is the video file kept changing back to High@L5.1.
    High@L3.1 for me.

    Originally Posted by cholla View Post
    Also on the conversion it would only do .MKV.
    I was able to change to .MP4 when I Multiplexed it.
    The Video conversions is only an intermediate step. It ouputs a mkv, because this container can hold most video codecs.
    The final video output is created during muxing, and there you can choose the container.

    Originally Posted by cholla View Post
    Funny the .M4A i used for the Audio track plays OK by itself.
    This is normal

    Originally Posted by cholla View Post
    Also while I have your attention a Log file option for Clever would be nice.
    Will see what I can do
    Quote Quote  
  22. Originally Posted by ProWo View Post
    You can use clever FFmpeg-GUI for this too.
    Convert Audio Stream, Volume detection, encode with the found value.
    I had seen the Audio Stream & Volume Detection in Clever but I hadn't used it.
    I was already familiar with using Audacity & knew what it could do.
    I could have even did a better job with Audacity but for this is wasn't worth the effort.
    I just wanted to see what the Audio track had on it.

    I did have some time to test Clever for the Audio this afternoon.
    It would have done a good enough job for this file.
    Probably for others also.

    Originally Posted by ProWo View Post
    High@L3.1 for me.
    That is what I was going for & got it in the end.

    Originally Posted by cholla View Post
    The Video conversions is only an intermediate step. It ouputs a mkv, because this container can hold most video codecs.
    The final video output is created during muxing, and there you can choose the container.
    Using the .mkv format does make sense as it is more universal.

    Originally Posted by cholla View Post
    Also while I have your attention a Log file option for Clever would be nice.

    Originally Posted by ProWo View Post
    Will see what I can do
    Thanks.
    Quote Quote  



Similar Threads