VideoHelp Forum

+ Reply to Thread
Results 1 to 28 of 28
Thread
  1. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I trie to rip a dvd with Tencoder. It works fine but I have no sound.
    Please help.
    Quote Quote  
  2. It's not a ripper but an encoder. First, did you decrypt (rip) the DVD to the hard drive, as you should have? You didn't say what the final format was to be, but you might try VidCoder.
    Quote Quote  
  3. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    Sorry but I think Tencoder has 3 options:
    1. Video/audio Converter
    2. Video Downloader
    3. DVD Ripper.
    I used the option DVD Ripper and it works fine. I got an acceptable avi file, even with subtitles, but unfortunately without sound.
    That's my problem.
    Quote Quote  
  4. I'm a Super Moderator johns0's Avatar
    Join Date
    Jun 2002
    Location
    canada
    Search Comp PM
    Post a text output of a mediainfo result.
    I think,therefore i am a hamster.
    Quote Quote  
  5. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    Hierbij de Mediainfo.Image
    [Attachment 63898 - Click to enlarge]
    Image Attached Files
    Quote Quote  
  6. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    The mediainfo appears to show that the file has ac3 audio, 1 hour 29 minutes, asme as the video

    Have you attempted to play it back in VLC or mpc-hc?
    Quote Quote  
  7. I'm a Super Moderator johns0's Avatar
    Join Date
    Jun 2002
    Location
    canada
    Search Comp PM
    If you tried to play it on an older tv/media player then it won't have sound due to the device not equipped to play ac3 sound.
    I think,therefore i am a hamster.
    Quote Quote  
  8. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Yes, on top of that, this program seems buggy to me
    Try choosing mp3 as your audio
    Quote Quote  
  9. I'm a Super Moderator johns0's Avatar
    Join Date
    Jun 2002
    Location
    canada
    Search Comp PM
    Aac would be a better choice for audio.
    I think,therefore i am a hamster.
    Quote Quote  
  10. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I've tried to play it with VLC en mpc-hc. No sound. I play it on my PC windows 11.
    I have already ripped de DVD with Vidcoder. That works fine and no sound problems.
    But It is ripped to mp4. So I tried to convert it to avi with Tencoder and it works, but again "without" sound.
    Now, it's not a big problem. I can rip with many other programs. I only tried for the first time to do it with Tencoder.
    I only was curious to the results and now I have an answer: it doen's works perfect! The movie is ok but the sound not.
    Thanks for your support.
    Quote Quote  
  11. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    The included mediainfo info report seemed to be xvid/Avi which is why I suggested mp3.
    I'm not sure what the OP is expecting to be honest, he mentions mp4 right above.
    Is he choosing xvid/Avi intentionally?

    Too much ambiguity, a screen print of of the Tencoder main screen would have helped
    Last edited by davexnet; 19th Mar 2022 at 16:22.
    Quote Quote  
  12. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I tried again (see MediaInfo) now with Video Codec H264, Audio Codec AAC and Encoder FFmpeg and it works fine. Acceptable compression and Sound!!!
    Thanks to you all.
    John
    Image Attached Files
    Quote Quote  
  13. Originally Posted by JEG41 View Post
    3. DVD Ripper.
    I used the option DVD Ripper and it works fine. I got an acceptable avi file, even with subtitles, but unfortunately without sound.
    That's my problem.
    Then both it and you are using the term incorrectly. Get as far away from that program as you can. I guess you proved that for yourself already as using 2 other programs produced both playable video and audio.

    And as davexnet already mentioned, it really had audio. For future cases you might install the AC3Filter.
    Quote Quote  
  14. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I have no more problems with TEncoder. The ripping works fine.
    Thks.
    Quote Quote  
  15. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Yes, I tried it myself on an old region 2 DVD "Thunderbirds" (1960's Supermarionation),
    this program can rip protected DVDs. I'd looked at it once or twice in the past but never
    noticed it before.
    My xvid/mp3 Avi came out fine. One thing I did notice, once you pick the title,
    It allows you to select the chapters, but I could not get this functionally to work
    the program rendered the full title and ignored my setting for chapters
    1-2 only
    Quote Quote  
  16. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    Indeed, the combination Xvid with mp3 works also fine. However combinations Xvid or H264 with AC3 give no sound.
    Quote Quote  
  17. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Going back in time to about 2005, xvid/mp3 was the usual combination for 700mb CD movie AVI rips.
    AC3 should work fine in avi, this must be a bug in the program

    For H264/aac stick to MP4 or MKV containers
    Quote Quote  
  18. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    Trying again to rip with Xvid and AC3 after I had installed "ac3filter_1_62b_lite" it gave No Sound. So I give up with trying AC3 and keep the fine working combinations higher mentioned.
    Quote Quote  
  19. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    The issue appears to be MEncoder.

    Change to ffmpeg and you should have sound even with ac3/xVId avi
    Quote Quote  
  20. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    Thks but I'using TEncoder.
    Quote Quote  
  21. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    TEncoder is the program.

    There are two encoding choices - MEncoder and ffmpeg. Look at the lower part of the encoding window. MEncoder is the default.
    Quote Quote  
  22. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I saw the difference. But I already used the option ffmpeg ac3/xVid Avi and so Sound!
    But no problem. I use the combination that works.
    Quote Quote  
  23. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    I accept you now have a working solution. But there still has to be a reason why audio when reported does not play.

    Consider these two encodes from the same source. Both claim to have audio yet only the 2nd one, with a larger file size (which I assume is the actual audio track) plays sound
    Image Attached Files
    Quote Quote  
  24. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    That's right. Only the 2nd has sound. Why?
    Quote Quote  
  25. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    I inferred to that above.

    The video header, which mediainfo reads, claims an audio track as prepared by Mencoder (the actual encoder). Yet, for whatever reason (someone with more knowledge of how encoders work might have some ideas) it has not been written in to the actual avi stream.


    Whereas when the same source was written to with ffmpeg the audio track was written in to the stream.


    It's probably a 'bug' within Mencoder itself or that ac3 is not actually implemeneted at that time. Tencoder is not the most uptodate program and the encoder versions are also quite old - ffmpeg from 2015 amd mencoder even older.
    Quote Quote  
  26. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I thank you for your interest and trying to help me. Against a bug in the program is no help possible. So, as I told before I keep my working combinations.
    Quote Quote  
  27. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    Since today I had no problems by ripping with TEncoder. Now it works no longer. Convertion options still works. I've tried several times, but no result by ripping. I gave permission on my spam scanner for TEncoder en FFMPEG but no use. I've tried in mencoder and in ffmpeg position but no result. Every time I tried to rip, after the input of the to do file, immediately I hear the bell ringing, but without a result. What is happening?
    Quote Quote  
  28. Member JEG41's Avatar
    Join Date
    Sep 2018
    Location
    BelgiŽ
    Search Comp PM
    I have tried again and got again the message from windows spam scanner that mencoder was blokked. Again I gave permission and ... now TEncoder ripper works fine.
    Sorry for bothering.
    Quote Quote  



Similar Threads