VideoHelp Forum

+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. I have this issue randomly at least 2 years, it's very hard to reproduce.

    To reproduce try this:
    - use LAV splitter (for subtitles only) *
    - use MKV videos for testing *
    - use the Configuration presets, create one test preset and second preset with the Auto-Preset - File name [mkv avi mp4 ts mpg] conditions, so it will be used for any video *
    - open PotPlayer in window mode, always on top
    - drag&drop folder with videos or few videos to PotPlayer window
    - start any 3D game in window or borderless mode *
    - play the game while watching the first video file *
    - wait untill the first video ends
    = video playback is frozen, for few seconds, few minutes, even 5 and more

    * These steps are probably not needed, I just want to use the same conditions.

    Last video parameters: MKV, AVC1(12 bits), 1920x1080, FPS 24, Renderer: Enhanced Video Renderer - but it's probably not so important.

    With some videos I have the same problem after each playlist item, but when I drag&drop the videos to PotPlayer window again, I have absolutely no delay, this is strange.

    Anyone has the same problem?
    Any idea how to find the reason of the problem?

    PotPlayer v220106 64-bit and any older from 2022, 2021, Windows 10 21H1 64-bit and older Windows 10.

    EDIT: It happened again, here is the screenshot from Task Manager.
    Image Attached Thumbnails Click image for larger version

Name:	PotPlayer strange playlist delay issue.png
Views:	11
Size:	19.2 KB
ID:	63448  

    Last edited by Dreamer; 1st Mar 2022 at 17:15.
    Quote Quote  
  2. your GPU might be busy processing the video game instead of playing the video files.
    Quote Quote  
  3. Thanks for the reply, but why it works, if I double click the next file manually?

    I have another similar issue, when I start any video in PotPlayer after PC start, not immediately, even after 30 minutes, it's not responding, completely frozen, but when I open the same video again, it works good - no other programs or games are opened, just file manager and Thunderbird. I have this issue few weeks only.
    Quote Quote  
  4. Originally Posted by malboro View Post
    your GPU might be busy processing the video game instead of playing the video files.
    It happened again, even if no game or video program is running, so it must be PotPlayer issue.
    Quote Quote  
  5. OK, so it must be a bug, definitely, not easy to reproduce, but CPU/RAM/GPU usage is still low, no game running, no other video program running.

    Today, after the problem - freeze, the same file started to play instead of next playlist file, BUT only audio, video had just frozen last frame (or frame near the last frame).

    Probably the file is not completed successfully. Perhaps it could be some audio option, any idea which?

    If anyone would like to try to reproduce it, here are the steps, EDIT I can reproduce it quite often now:
    - assign the keyboard shortcut Ctrl+Shift+Right for Playback -> Jump (to) ->1 Min. Forward, as a "Global hotkey"
    - for audio use recommended options, just set "speakers" to "3/0/2+ LFE - 5.1" and for Mixer Settings use all 3 options, normalize, expand, expand
    - for Normalizer use "Enable", Method "Tomsteady 32-bit...", "Boost audio"
    - for Language use Selected method "Prefer specidied languages" and type your language code, e.g. "en"
    - for Playback - Audio speed control use option "Use FFmpeg audio..."
    - drag&drop multiple video files, ideally mkv with 5.1 audio, multi-audio streams, to PotPlayer window
    - right click playlist area and select option "Detect file duration"
    - play the first file in window mode
    - use playing speed 1.5x
    - make the PotPlayer window inactive
    - wait for the file end or seek to last minutes
    - wait for the file end or use the shortcut Ctrl+Shift+Right multiple times or hold this shortcut to go to file end
    - if you can't reproduce it, try it again with the next file
    Image Attached Thumbnails Click image for larger version

Name:	PotPlayer strange playlist delay issue.png
Views:	5
Size:	35.4 KB
ID:	65660  

    Last edited by Dreamer; 30th Jun 2022 at 10:27. Reason: updated steps to reproduce the issue
    Quote Quote  
  6. Indeed it is difficult to reproduce, I do not manage to do it.
    Quote Quote  
  7. Are you trying to play a big number of files within many subfolders? if that's the case, the delay comes from potplayer crawling into the folders, reading the contents and adding them to the playlist. It happens to me too, I have a 5 - 9 seconds delay when trying to play folders that have many subfolders and files in them.

    I wish they add some kind of progressive scanning when playing a folder with many subfolders, so the player starts playback inmediately while adding the files to the playlist silently on background.
    Quote Quote  
  8. Usually it's less than 20, or even less than 10 files, when I drag&drop the files to PotPlayer, it's OK, first file is playing without a problem, just later there is some strange delay - and it's sometimes few seconds, sometimes few minutes, but most of the time it's no delay.

    BTW Regarding your problem, I think the program is loading file information, sometime it's automatically, but sometime it's not loaded, in such cases I'm using the option "Detect file durations" in playlist panel, perhaps this can be that delay.

    When I drag&drop files to the main program windows, file durations are not leaded for all files, but if I drag&drop files to playlist panel, they are loaded. I found, that loading this information is slower for some file types, the same number.

    I'm not using the thumnails in playlist, but this can cause some delay too.

    You can try to disable these options in the Playlist settings - thumbnails, durations, icons.
    Quote Quote  



Similar Threads