VideoHelp Forum

+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Hi.

    I am editing a file with Videopad. It will only re-encode sections I edit, and copy all other frames. This gives the best colorspace and size results. The resulting file is .mp4 and I am satisfied with it.

    However, Videopad is not able to resize the video, and I want it resized. VirtualDub2 is what I use. Only problem is it randomly decided to desync audio on this imported file. The audio is re-encoded to AAC, I can't change that unfortunately. I can delay audio to align to a point but as my title implies that just desynchronizes other parts of the file, like the start. I would use the native input codec (non caching) with this .MP4 but that is not an option. And Videopad on the other hand refuses to do the "lossless encoding" in an AVI which might just solve this problem (and create others).

    If I want I can re-encode the whole video with x264 and give a resultant AVI to VirtualDub2 which dutifully will work as expected. But this damages the colorspace, turns reds to oranges and generally mucks up things.

    I don't really understand what's happening, what program is responsible, and why.

    I'm so frustrated. I am so close and this kind of thing keeps messing up my videos.
    Quote Quote  
  2. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    The audio is re-encoded to AAC, I can't change that unfortunately.


    So you're using VirtualDub2 but cannot make it use the "Direct stream copy" feature
    "Like this facility, I don't exist."
    Quote Quote  
  3. Originally Posted by Hunterh View Post
    give a resultant AVI to VirtualDub2 which dutifully will work as expected. But this damages the colorspace, turns reds to oranges
    That sounds like a rec.601 vs rec.709 problem. You can specify the color matrix in the x264 options. Enter "--colormatrix bt709" or "--colormatrix smpte170m" in the Extra Command Line options box.

    Your sync problems in VirtualDub2 may be because your source is variable frame rate.
    Quote Quote  
  4. Member
    Join Date
    Apr 2007
    Location
    Australia
    Search Comp PM
    Hi all.

    @Hunterh
    You'll need to work out which filters are x32 and x64.
    Some trial and error will be involved.

    This is a Virtualdub filter pack. (There's a LOT of filters.)
    It includes a resize filter. Read the 'Resize.html' doc next to the plugin.
    https://www.majorgeeks.com/files/details/virtualdub_filter_pack.html

    This explains how to use the filters in Videopad.
    https://www.nchsoftware.com/videopad/free-plugins.html

    Have at it.

    Cheers.

    EDIT: I noticed, there's a second resize filter in that collection. VDMod_Resize.vdf
    Last edited by pcspeak; 13th Jan 2022 at 17:02.
    Quote Quote  
  5. If it was me, I would first verify my hardware (ie computer) to make sure that it is not an issue with the hardware graphics acceleration when the editing program is decoding video in playback mode.

    Some GPUs lack certain extensions which allow for fast decoding so, typically, the audio will play normally while the video will lag behind.

    My advice is to export the video to a file and then play it with sofware (ie CPU) processing only in order to double-check.
    Quote Quote  
  6. Originally Posted by El Heggunte View Post
    The audio is re-encoded to AAC, I can't change that unfortunately.


    So you're using VirtualDub2 but cannot make it use the "Direct stream copy" feature
    1. Videopad requires AAC to copy frames.
    2. I don't re-encode the audio. The thing is, it's all messed up before VirtualDub ever renders anything. The preview's sound alignment is broken.

    Originally Posted by jagabo View Post
    Originally Posted by Hunterh View Post
    give a resultant AVI to VirtualDub2 which dutifully will work as expected. But this damages the colorspace, turns reds to oranges
    That sounds like a rec.601 vs rec.709 problem. You can specify the color matrix in the x264 options. Enter "--colormatrix bt709" or "--colormatrix smpte170m" in the Extra Command Line options box.

    Your sync problems in VirtualDub2 may be because your source is variable frame rate.
    Yeah ok. So I have been working on this, I rendered a sample in RGB32 and it looked right. So I rendered the video in RGB32 and it looked bad again.

    Went back to YV12, made a sample and this time it turned out. I do not know what I did. I use a profile for VirtualDub2 so I don't have to figure it out again every few weeks.

    Frame rate is a good idea. It isn't *supposed* to have a variable frame rate, and I don't recall that I allowed it, but I might have and I shouldn't have. Videopad is a little odd, it suggests things like "Variable frame rate [60fps]" which I have no business selecting.

    Originally Posted by sageone View Post

    My advice is to export the video to a file and then play it with sofware (ie CPU) processing only in order to double-check.
    I turned off VLC's hardware acceleration and it (lossless copy) still seems normal.

    Anyway, thanks for the suggestions, could help.
    Quote Quote  
  7. Originally Posted by Hunterh View Post
    I rendered a sample in RGB32 and it looked right. So I rendered the video in RGB32 and it looked bad again.
    By default, VirtualDub converts YUV to RGB using a rec.601 matrix. If your source is rec.601 you'll get the right RGB colors. If your source is rec.709 you'll get wrong RGB colors. This can depend on the video decoder too. If the decoder handles the conversion from YUV to RGB before the video is given to VirtualDub the colors you get will depend on the decoder.
    Quote Quote