VideoHelp Forum

+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. hi, I've recorded a ts stream with an usb dvb-t device.
    I'd like to post it as an mkv without re-encode it and doing as few steps as possible.

    So I first load the ts file into avidemux and after cutting some minutes at the beginning and at the end,
    in correspondence with two keyframes, then I save it using the "Mpeg TS Muxer (ff)" Output Format.

    Then I load the cutted ts file into mkvtoolnix and I mux it.
    The resulting mkv file, for some reason that I can't get, is now 2.68GB instead of like the ts file that is 2.98GB.
    Apart that, the problem is now when i play it in MPC-HC all the frames are doubled, the lenght is ok,
    and when I load it into vdub2, the frames and the lenght are doubled.

    I just would like to "fix it" in some way in order to play it with MPC-HC with no doubled frames.
    I read something around about using the "Default duration/FPS" option
    or "video interlaced flag" and "video field order" in the mkvtoolnix header editor,
    but I really can't figure out which ones to use and how to use them.

    including ts sample: https://www.dropbox.com/s/0bix5rkqwiikj2g/iss%20sample.ts?dl=0

    help pls.
    Last edited by maudit; 26th Dec 2021 at 07:47.
    Quote Quote  
  2. Try muxing from ts to mkv with ffmpeg:

    Code:
    ffmpeg -fflags +genpts -i %1 -c  copy -map 0 "%~dpn1.mkv"
    The "-fflags +genpts" may not be necessary.
    Image Attached Files
    Quote Quote  
  3. It's simple: import ts to mkvtoolnix-gui, then click on video, and in the "Default duration/FPS" type 25i, like in th screenshot. MKV file is always smaller than TS, so don't worry that something is missing - just no needed data.
    Image
    [Attachment 62578 - Click to enlarge]
    Quote Quote  
  4. Originally Posted by jagabo View Post
    Try muxing from ts to mkv with ffmpeg:

    Code:
    ffmpeg -fflags +genpts -i %1 -c  copy -map 0 "%~dpn1.mkv"
    The "-fflags +genpts" may not be necessary.
    when I load this file into vdub2 it is good, it has no doubled frames,
    while when I load it into mpc-hc, all frames are doubled.
    Quote Quote  
  5. Originally Posted by noemi7 View Post
    It's simple: import ts to mkvtoolnix-gui, then click on video, and in the "Default duration/FPS" type 25i, like in th screenshot. MKV file is always smaller than TS, so don't worry that something is missing - just no needed data.
    Image
    [Attachment 62578 - Click to enlarge]
    I had already tried that "25i" option previously.
    the result is like the file above, good in vdub2 but bad in mpc-hc.
    thanks for clarification about the different files size.
    Quote Quote  
  6. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    The file is marked as interlaced but there really isn't a unique field so you get a duplicate.
    In mpc-hc you can set
    filters/LAV video decoding/software deinterlacing/Yadif/25p/30p

    The file should really be progrssive, but I'm not sure how to change it without a re-encode
    Quote Quote  
  7. Originally Posted by maudit View Post
    when I load it into mpc-hc, all frames are doubled.
    Yes, of course. The source frames are progressive but encoded interlaced. So when it's deinterlaced the player displays each frame twice. It does that with the original video too.
    Quote Quote  



Similar Threads