VideoHelp Forum

+ Reply to Thread
Results 1 to 16 of 16
Thread
  1. HI all. I have a .ts mpeg2 file from a japanese tv show from 2011.
    when playing with windows movies and tv looks great (no comb effect at all just like viewing a 1080p60 video) and in 60fps at full 1080. However when playing with VLC it only shows at 29.97/s with or without deinterlaced turned on and tried all the different deinterlaced options. Importing to hitfilm also detecting it as 29.97fps. The file size is 630mb for a 307 seconds video at 1440 by 1080. The audio was slightly off sync so was trying to shift it with hitfilm and but the video frame rate only at 29.97 so it is disappointing.

    So how can i convert it into p60 and what software should i used? Windows movies and tv is better at showing deinterlaced 60i than VLC is that true?
    Quote Quote  
  2. VLC should adequately deinterlace to 60p with the Yadif (2x) deinterlacer (this is similar to how most TVs deinterlace). You may have to change the setting (Tools -> Preferences -> Video...), save the settings, exit and restart VLC for the change to take effect.

    To make a 60p video the best quality is with AviSynth and the QTGMC filter.
    Quote Quote  
  3. VLC however only showing it at half the frame rate at 29.97fps (with or without deinterlaced turn on) vs 59.94fps by windows movies and tv.

    Hitfilm also detected the video 29.97fps.

    when i have VLC and windows 10 movies tv side by side it is very obvious windows Movies is showing it at 60P.

    uploading the raw .ts to youtube also showing it at 1080 29.97fps deinterlaced
    Last edited by patrick1; 25th Nov 2021 at 10:50.
    Quote Quote  
  4. Could you provide an mediainfo report (text mode) from your .ts here?
    Quote Quote  
  5. Member Skiller's Avatar
    Join Date
    Oct 2013
    Location
    Germany
    Search PM
    Originally Posted by patrick1 View Post
    VLC however only showing it at half the frame rate at 29.97fps (with or without deinterlaced turn on)
    Easy fix, set "Deinterlace mode" to "Yadif (x2)" in VLC.

    Edit: Just realized jagabo suggested this already.^^
    Quote Quote  
  6. Originally Posted by patrick1 View Post
    VLC however only showing it at half the frame rate at 29.97fps (with or without deinterlaced turn on) vs 59.94fps by windows movies and tv.
    No. The Yadif (2x) will display the video at 59.94 fps. That's what the 2x is about.
    Quote Quote  
  7. General
    ID : 32706 (0x7FC2)
    Complete name : C:\Users\pat\OneDrive\Desktop\ts\aiko - Kira Kira.ts
    Format : MPEG-TS
    File size : 631 MiB
    Duration : 5 min 7 s
    Start time : UTC 2011-03-27 20:20:41
    End time : UTC 2011-03-27 20:25:41
    Overall bit rate mode : Variable
    Overall bit rate : 17.2 Mb/s
    Network name : Cf5~9-0h~

    Video #1
    ID : 273 (0x111)
    Menu ID : 3088 (0xC10) / 3089 (0xC11) / 3090 (0xC12)
    Format : MPEG Video
    Format version : Version 2
    Format profile : Main@High
    Format settings : CustomMatrix / BVOP
    Format settings, BVOP : Yes
    Format settings, Matrix : Custom
    Format settings, GOP : M=3, N=15
    Format settings, picture structure : Frame
    Codec ID : 2
    Duration : 5 min 6 s
    Bit rate mode : Variable
    Maximum bit rate : 20.0 Mb/s
    Width : 1 440 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate : 29.970 (30000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Interlaced
    Scan order : Top Field First
    Compression mode : Lossy
    Time code of first frame : 12:44:34:11
    Time code source : Group of pictures header
    GOP, Open/Closed : Open
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    Video #2
    ID : 337 (0x151)
    Menu ID : 3472 (0xD90)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Baseline@L1.2
    Format settings : 3 Ref Frames
    Format settings, CABAC : No
    Format settings, Reference frames : 3 frames
    Format settings, GOP : M=1, N=30
    Codec ID : 27
    Duration : 5 min 6 s
    Bit rate mode : Constant
    Nominal bit rate : 232 kb/s
    Width : 320 pixels
    Height : 180 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Variable
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive

    Audio #1
    ID : 274 (0x112)
    Menu ID : 3088 (0xC10) / 3089 (0xC11) / 3090 (0xC12)
    Format : AAC LC
    Format/Info : Advanced Audio Codec Low Complexity
    Format version : Version 2
    Muxing mode : ADTS
    Codec ID : 15-2
    Duration : 5 min 7 s
    Bit rate mode : Variable
    Channel(s) : 2 channels
    Channel layout : L R
    Sampling rate : 48.0 kHz
    Frame rate : 46.875 FPS (1024 SPF)
    Compression mode : Lossy
    Delay relative to video : -185 ms

    Audio #2
    ID : 338 (0x152)
    Menu ID : 3472 (0xD90)
    Format : AAC LC SBR
    Format/Info : Advanced Audio Codec Low Complexity with Spectral Band Replication
    Commercial name : HE-AAC
    Format version : Version 2
    Format settings : Implicit
    Muxing mode : ADTS
    Codec ID : 15-2
    Duration : 5 min 6 s
    Bit rate mode : Variable
    Channel(s) : 2 channels
    Channel layout : L R
    Sampling rate : 48.0 kHz
    Frame rate : 23.438 FPS (2048 SPF)
    Compression mode : Lossy
    Delay relative to video : -102 ms

    Menu #1
    Quote Quote  
  8. Originally Posted by jagabo View Post
    Originally Posted by patrick1 View Post
    VLC however only showing it at half the frame rate at 29.97fps (with or without deinterlaced turn on) vs 59.94fps by windows movies and tv.
    No. The Yadif (2x) will display the video at 59.94 fps. That's what the 2x is about.
    I tried again and again VLC with Yadif 2x is still at 29.97fps. Side by side with windows 10 movies tv makes it very obvious VLC has only half the frame rate.
    Quote Quote  
  9. As you see in post #7 the video IS 29.97fps, so you could consider IVTC.
    Quote Quote  
  10. Originally Posted by patrick1 View Post
    Originally Posted by jagabo View Post
    Originally Posted by patrick1 View Post
    VLC however only showing it at half the frame rate at 29.97fps (with or without deinterlaced turn on) vs 59.94fps by windows movies and tv.
    No. The Yadif (2x) will display the video at 59.94 fps. That's what the 2x is about.
    I tried again and again VLC with Yadif 2x is still at 29.97fps. Side by side with windows 10 movies tv makes it very obvious VLC has only half the frame rate.
    Try changing the output device to "Direct3D11 video output". At least some of the others don't support 2x deinterlacing. Tools -> Preferences -> Video -> Output -> pulldown...

    This may also be dependent on graphics card settings.
    Quote Quote  
  11. Originally Posted by jagabo View Post
    Try changing the output device to "Direct3D11 video output". At least some of the others don't support 2x deinterlacing. Tools -> Preferences -> Video -> Output -> pulldown...

    This may also be dependent on graphics card settings.
    Tried every setting, even tried a different laptop. It still behaves the same. Windows movies tv is at 60p and VLC still at 30p.
    Quote Quote  
  12. Originally Posted by patrick1 View Post
    Originally Posted by jagabo View Post
    Try changing the output device to "Direct3D11 video output". At least some of the others don't support 2x deinterlacing. Tools -> Preferences -> Video -> Output -> pulldown...

    This may also be dependent on graphics card settings.
    Tried every setting, even tried a different laptop. It still behaves the same. Windows movies tv is at 60p and VLC still at 30p.
    It works fine here and every computer I've tried. I get smooth motion at 60 fps with no comb artifacts. Some older versions of VLC got the field order wrong at times. I'm using 3.0.8 now.
    Last edited by jagabo; 25th Nov 2021 at 12:57.
    Quote Quote  
  13. Member Skiller's Avatar
    Join Date
    Oct 2013
    Location
    Germany
    Search PM
    Just to make sure, Deinterlace is set to on (not automatic), right?

    Image
    [Attachment 62009 - Click to enlarge]
    Quote Quote  
  14. Originally Posted by Skiller View Post
    Just to make sure, Deinterlace is set to on (not automatic), right?

    Image
    [Attachment 62009 - Click to enlarge]
    Yes. All the possible combinations have been tried, I think.

    Originally Posted by jagabo View Post
    Originally Posted by patrick1 View Post
    Originally Posted by jagabo View Post
    Try changing the output device to "Direct3D11 video output". At least some of the others don't support 2x deinterlacing. Tools -> Preferences -> Video -> Output -> pulldown...

    This may also be dependent on graphics card settings.
    Tried every setting, even tried a different laptop. It still behaves the same. Windows movies tv is at 60p and VLC still at 30p.
    It works fine here and every computer I've tried. I get smooth motion at 60 fps with no comb artifacts. Some older versions of VLC got the field order wrong at times. I'm using 3.0.8 now.
    I just tried it on another literally brand new asus laptop (just received yesterday) with a fresh new download VLC 3.0.16. No change.
    Quote Quote  
  15. Deinterlacing in ffmpeg and re-encoding might be a solution if you must play it in VLC and it's not deinterlacing correctly for some reason?

    It would require a re-encode - but then you'd have a p59.94 file to replay and no need to deinterlace on playback?
    Last edited by nogginvid; 27th Nov 2021 at 11:18.
    Quote Quote  
  16. My final solution is using Hitfilm express built in deinterlace effect with field separate method and field option set to alternate (upper first). Any other settings can't do it properly. Now I get a properly deinterlaced p60 mp4 file.

    I could not get VLC to deinterlace the original .ts file after all.
    Quote Quote