VideoHelp Forum

+ Reply to Thread
Results 1 to 5 of 5
  1. Current workflow is to export an non-multiplexed MPEG-2 file from Adobe Premiere Pro, then use this command with FFMpeg

    ffmpeg -i movie.m2v -i movie.wav -vcodec copy -acodec ac3 -f dvd movie.mpg
    Using this, then importing to AVStoDVD gives me this error:

    Audio Track #1 is DVD compliant but has a delay of -37ms. Resulting DVD will be very likely out-of-sync, unless audio will be re-encoded.
    How can I, using FFMpeg or something else, mux a file that doesn't have this delay? I've noticed that files ripped from commercial DVDs do not throw this error. Thanks.

    PS - for my specific use case, simply letting AVStoDVD re-encode the audio is not an option.
    Quote Quote  
  2. Try adding "-itsoffset 0.037" after importing the video but before importing the audio.
    Last edited by jagabo; 11th Oct 2021 at 00:49.
    Quote Quote  
  3. Well, I tried this code:

    ffmpeg -i movie.m2v -itsoffset 0.038 -i movie.wav -vcodec copy -acodec ac3 -f dvd movie3.mpg
    And it worked! AVStoDVD is now reporting a 0ms delay.

    ...but, I still have some questions. Why did this delay exist in the first place? I just tried exporting a different clip and muxing without the -itsoffset flag, and the delay reported by AVStoDVD was -5ms. Is there a way to check this beforehand, so I don't have to do trial and error? Where does the delay itself come from?
    Quote Quote  
  4. I believe it has to do with the audio having to be pre-loaded when muxing. But I don't know the exact details.
    Quote Quote  
  5. Member Skiller's Avatar
    Join Date
    Oct 2013
    Search PM

    In a nutshell: there won't be any delay during playback, even if there is a delay reported.
    That's because the delay is taken into consideration upon playback.
    Quote Quote  

Similar Threads