VideoHelp Forum

+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. I'm using "Subtitle Edit" to create an srt for use with a movie in a VIDEO_TS folder on a mounted iso (Codec Details attached). I aim to share it with the community when I'm done. I'm having trouble syncing.

    The problem:
    From Subtitle Edit I click Video>Open Video File and select VTS_01_1.VOB Image
    [Attachment 60817 - Click to enlarge]

    I make some subtitles, timed perfectly if played from the beginning and if tested in VLC.
    However, if I click on a line within Subtitle Edit, the sync is way off, and unpredictably so, making it impossible to work.

    What am I doing wrong?

    I also had (different) trouble trying with Aegisub. I'm guessing that they don't like VOB files and that I should use Handbrake to convert them to something. If that's right, what settings should I use for the conversion to something quick and disposable but accurate? MPEG2? MPEG4? 29.970030 fps? I'd like an efficient way that ensures a good sync between the final srt and the VOBs.

    Thanks!Image
    [Attachment 60816 - Click to enlarge]
    Last edited by Lostdog; 19th Sep 2021 at 19:15.
    Quote Quote  
  2. Member Skiller's Avatar
    Join Date
    Oct 2013
    Location
    Germany
    Search PM
    If you didn't know, DVD uses bitmap based subtitles. That means the actual characters are stored as graphic overlays, not text.
    So when converting DVD subtitles, after demuxing (de-multiplexing) the subtitle stream from the VOB files (using PgcDemux for example), a process called OCR (Optical Character Recognition) is needed which translates the graphics into text + timestamps.

    The result can then be used for translation or viewing.


    Now Subtitle Edit tries to do all of that in situ, but breaking the process up into it's traditional steps as described might fix the problem.


    1) Demux subtitle and video and audio streams with PgcDemux.
    2) OCR the SUP file with Subtitle Edit (or anything else that can do it) and save as a SRT file.
    3) Use Aegisub to translate and touch up the SRT. You can load the demuxed video and audio into Aegisub for previewing (elementary streams should work fine, they do for me). No need for converting to an intermediate format.
    Last edited by Skiller; 19th Sep 2021 at 19:50.
    Quote Quote  
  3. I use SubRip to extract DVD subtitles from the VOBs (or the IFO) and perform the OCR to SRT or other subtitle formats.
    Quote Quote  
  4. Member Skiller's Avatar
    Join Date
    Oct 2013
    Location
    Germany
    Search PM
    SubRip's OCR is pretty sophisticated, I would recommend it as well.
    However, you should still demux the video and one audio stream for later use in Aegisub.
    Quote Quote  
  5. Thanks to you all. There are no subtitles that come with the video (no sup files, etc). I downloaded some subtitles, but they're very, very bad quality and the timing is off. That's the srt I'm starting with. I'll mess around with PgcDemux and see how it goes.
    Last edited by Lostdog; 20th Sep 2021 at 23:09.
    Quote Quote  
  6. Member Ennio's Avatar
    Join Date
    May 2005
    Location
    Netherlands
    Search Comp PM
    As for the sync problem, instead of opening VOBs directly in SE, try File --> Import --> Subtitle from VOB/IFO (DVD) and browse to the proper IFO file. Timings can be more accurate.
    Quote Quote  
  7. I'm extremely confused.

    Originally Posted by Ennio View Post
    As for the sync problem, instead of opening VOBs directly in SE, try File --> Import --> Subtitle from VOB/IFO (DVD) and browse to the proper IFO file. Timings can be more accurate.
    I tried this. SE attempted to rip subtitles from the NTSC VOBs. As I said, there are no subtitles on the VOBs. The subtitles are not in the VIDEO_TS file. They are a deeply flawed srt file I downloaded from Subscene and am trying to overhaul.

    I also used PgcDemux. The result was splitting the video into its audio and video tracks (ac3 and m2v). I tried using this with SE, but it played video without audio, so that wasn't helpful. I used PgcDemux to create a single VOB. It didn't help the problem.

    What's more confusing is that the timecode when I play the video in VLC is completely different than the timecode in SE. It's off by about 30 seconds, audio and video. That goes for playing the VIDEO_TS folder or the PgcDemuxed mega-VOB.

    Editing in SE is impossible because the timecodes keep drifting around. It's maddening.
    Last edited by Lostdog; 23rd Sep 2021 at 21:31.
    Quote Quote  
  8. Member Ennio's Avatar
    Join Date
    May 2005
    Location
    Netherlands
    Search Comp PM
    Originally Posted by Lostdog View Post
    I'm extremely confused.
    I can imagine. I totally didn't read your initial post well enough. Please accept my apologies.

    As I understand you want to create a srt for the whole movie, I'd suggest you work with one file that is created out of the VOBs that contain it. Such as a mkv. MKVToolnix can do that for you. No re-encoding needed, just a remux of VOBs into one mkv.

    Looking at your source, you need to import the "VTS_01_0.VOB". MKVToolnix will then auto-load and append the proper VOBs into the source window.

    Your dvd containing a movie, chances are that the frames are stored as 23.976 progressive. In which case, you have to set "Default duration/FPS" to 24000/1001p (this could be a reason why you're having sync issues, btw). Now you'll have one file to work with in SE.

    If you're having trouble with MKVToolnix, please let know.
    Quote Quote  
  9. Originally Posted by Ennio View Post
    Your dvd containing a movie, chances are that the frames are stored as 23.976 progressive. In which case, you have to set "Default duration/FPS" to 24000/1001p (this could be a reason why you're having sync issues, btw).
    Thanks! I'll do as you say. This video I'm working with is a bit unusual. According to "codec details" in VLC (see screenshot in OP), the framerate is 29.970030 fps (NTSC, I believe). How does that impact my MKVToolnix settings?

    EDIT: Actually, all the "Properties" in the "Input" tab of MKVToolNix are greyed out (including "Default duration/FPS"). I'm just going to "start multiplexing" and keep my fingers crossed...
    Last edited by Lostdog; 26th Sep 2021 at 19:52.
    Quote Quote  
  10. I think I may have gotten some insight:

    I loaded "VTS_01_0.VOB" into MKVNix and it spit out the mkv. When played, the mkv starts with the dvd menu for ~34 seconds before launching into the feature. That may have contributed to the timing problem?
    Last edited by Lostdog; 26th Sep 2021 at 21:45.
    Quote Quote  
  11. Originally Posted by Lostdog View Post
    I loaded "VTS_01_0.VOB" into MKVNix and it spit out the mkv. When played, the mkv starts with the dvd menu for ~34 seconds before launching into the feature. That may have contributed to the timing problem?
    Even if you didn't know it going in, you could have just played the VTS_01_0.VOB and learned it wasn't part of the movie. So, the answer to your question is "yes". And if it's really a movie, you might want to IVTC it back to its original 23.976fps.
    Quote Quote  
  12. Yes, I tried again with "VTS_01_1.VOB". I didn't change any settings in MKVNix. The result was an MKV which had the whole movie. I opened it with SE, ran a few tests, and everything seems to be working perfectly. No more weird timing issues!

    As far as I can tell from VLC, the framerate seems to be (see screenshot in OP) 29.970030 fps (NTSC, I believe).

    Thanks for the help!

    SOLVED.
    Quote Quote  
  13. Originally Posted by Lostdog View Post
    As far as I can tell from VLC, the framerate seems to be (see screenshot in OP) 29.970030 fps (NTSC, I believe).
    All NTSC DVDs output 29.97fps (really 59.94 fields per second). But the content might have a different framerate and be padded to output 29.97fps.
    Originally Posted by manono View Post
    And if it's really a movie, you might want to IVTC it back to its original 23.976fps.
    You should read up on 3:2 pulldown and telecine. Unless you're going to keep it as a DVD, maybe.
    Quote Quote  
  14. Originally Posted by manono View Post
    Originally Posted by Lostdog View Post
    As far as I can tell from VLC, the framerate seems to be (see screenshot in OP) 29.970030 fps (NTSC, I believe).
    All NTSC DVDs output 29.97fps (really 59.94 fields per second). But the content might have a different framerate and be padded to output 29.97fps.
    Originally Posted by manono View Post
    And if it's really a movie, you might want to IVTC it back to its original 23.976fps.
    You should read up on 3:2 pulldown and telecine. Unless you're going to keep it as a DVD, maybe.
    What I did was play the Video_TS in the iso with VLC, clicked "Play" in the dvd menu, and then opened Tools/Media Information after it was already playing. The result is the screenshot. Am I making the wrong assumption?

    Right now, I'm happy with the MKV spit out by MKVToolNix (which plays nicely with with my HTPC Kodi setup), unless there's a good reason to do more research into some sort of Handbrake conversion (IVTC) you suggested. I don't know why I'd want to do that.
    Last edited by Lostdog; 30th Sep 2021 at 19:25.
    Quote Quote