VideoHelp Forum

+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. I had a request from my in-laws to get a file that I'm almost certain can only be acquired from My5.tv - https://www.my5.tv/all-creatures-great-and-small/season-2/episode-1

    I managed to acquire a few file addresses

    https://hwdash.channel5.com/cenc/C5344020001/C5344020001A/20210917131714/C5344020001A-tt.mpd
    https://c5apps.channel5.com/wv/c5-wv-app-cert-20170524.bin
    https://hwdash.channel5.com/cenc/C5344020001/C5344020001A/20210917131714/C5344020001A_...ASH_1500_a.mp4
    https://hwdash.channel5.com/cenc/C5344020001/C5344020001A/20210917131714/C5344020001A_...ASH_1500_v.mp4

    yt-dlp pulled the files I needed and I even got mp4 and m4a files using another app. 500mb video and 32mb audio so the correct size. However the DRM is stopping me doing anything with these files.

    I also tried Camtasia and the screen is blank as expected - I even tried Bluestacks/MEMU/NOX and installed the my5.tv app and couldn't get the videos to play.

    Hoping someone can give me that last piece of info on how to unencrypt these files - I'm assuming widevine L3?!

    Thanks in advance
    Quote Quote  
  2. Got the keys

    KID: fd6914e7910440f8884864004f5e6f51
    HEX: caef3ee0679cc302147870d6dfd976bb

    KID: 92837c4756ab1e322d4707c34dd35028
    HEX: caef3ee0679cc302147870d6dfd976bb

    and successfully decrpyted the files. Merge seemed to go ok, but no sound.

    So close!
    Quote Quote  
  3. I have no idea why you have no sound, your keys are correct. You messed up something.
    Here's the audio, try merging the video with this one.
    https://we.tl/t-I0znvDrLFF
    Quote Quote  
  4. Must be a codec thing as I have no sound on that file also - weird.

    I'll try the merge and see if Plex can figure it out.
    Quote Quote  
  5. >mp4decrypt.exe --key fd6914e7910440f8884864004f5e6f51:caef3ee0679cc3021 47870d6dfd976bb "C5344020001A_MPEGDASH_1500_a.mp4" test_a.mp4
    >mp4decrypt.exe --key 92837c4756ab1e322d4707c34dd35028:caef3ee0679cc3021 47870d6dfd976bb "C5344020001A_MPEGDASH_1500_a.mp4" test_a.mp4

    I tried both and both commands ran but there was no audio - yours did work so thank you!
    Quote Quote  



Similar Threads