VideoHelp Forum

+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Member
    Join Date
    Dec 2008
    Location
    United Kingdom
    Search Comp PM
    Hello! I'm in the process of capturing a 3 hour VHS tape in approx 32 min chunks. I started appending the sections together but I noticed that despite appending each section accurately using the frames as a reference, the audio was jumping slightly (I can provide a clip if necessary).

    I checked the File Information of each video I captured and noticed a few have different video/audio lengths. Below is one of the problematic videos:

    Video
    ID : 0
    Format : Lagarith
    Codec ID : LAGS
    Duration : 32 min 18 s
    Bit rate : 59.3 Mb/s
    Width : 720 pixels
    Height : 576 pixels
    Display aspect ratio : 5:4
    Frame rate : 25.000 FPS
    Standard : PAL
    Bits/(Pixel*Frame) : 5.715
    Stream size : 13.4 GiB (94%)

    Audio
    ID : 1
    Format : PCM
    Format settings : Little / Signed
    Codec ID : 1
    Duration : 32 min 18 s
    Bit rate mode : Constant
    Bit rate : 1 536 kb/s
    Channel(s) : 2 channels
    Sampling rate : 48.0 kHz
    Bit depth : 16 bits
    Stream size : 355 MiB (2%)
    Alignment : Aligned on interleaves
    VirtualDub gives me the following File Information:
    Video length: 32:18:12
    Audio length: 32:18:20


    My theory is the audio "jump" effect is happening because some of the 32min chunks of video have audio which is out of sync (in the case above the audio is longer by 8 ms). Therefore, I want to re-sync the video and audio.

    What's the least invasive/destructive way to sync the audio/video? I've read about the following options
    A) Selecting "Change so video and audio duration match"
    B) Applying "time stretch" filter.

    When I tried option A), it said the audio/video would need to be changed to 24.999fps. When I exported it, the problem of audio "jumping" when appended was solved - hooray! However, I'm a bit concerned about changing the frame rate - I read that's a "quick and dirty" way to fix problems and I'm wondering whether appending 24.999 fps and 25fps video will cause compatibility issues later down the line (I intend on archiving the Lagarith AVI and also exporting the project to MP4 for streaming). Additionally, the playback within VDub looks a bit choppy, although it seems fine when I play the exported video in VLC.

    When I tried option B), I used the time stretch filter (input> time stretch (0.6) > output), full process mode but the video had no audio! Mediainfo claims the file has PCM audio but when I load it into Audacity there is no waveform. Perhaps my maths is wrong - I divided 12ms by 20ms = 0.6.

    What is the best option for solving this problem? Many thanks!
    Last edited by dave_van_damme; 11th Sep 2021 at 23:59. Reason: clarity
    Quote Quote  
  2. Originally Posted by dave_van_damme View Post
    (in the case above the audio is longer by 8 ms)
    That difference is 8 hundredths, not 8 thousandths. (80ms, not 8ms). Even 80ms is so small a difference you might not even be able to tell they were out of synch.
    I don't resynch my captures in VDub, so I can't help there. Nor do I cap 32 minutes at a time.
    Quote Quote  
  3. Member
    Join Date
    Dec 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by manono View Post
    Originally Posted by dave_van_damme View Post
    (in the case above the audio is longer by 8 ms)
    That difference is 8 hundredths, not 8 thousandths. (80ms, not 8ms). Even 80ms is so small a difference you might not even be able to tell they were out of synch.
    I don't resynch my captures in VDub, so I can't help there. Nor do I cap 32 minutes at a time.
    Here's an example of the problem I'm facing. I joined two videos together. The first video is Madonna facing the crowd with her back to the camera ("....now I...."). The second video begins with the close up ("...know you're mine"). You can hear the audio jump between "now I" and "know you're mine". I appended the videos carefully without deleting or duplicating any frames, but you can still hear the audio jump.

    I assume the audio had drifted slightly while capturing the first clip, hence the different in length between the video and audio stream in that file. Or maybe there's a different explanation?

    What's the best way to go about fixing this? Matching the video/audio frame rate seems the easiest but are there any disadvantages of this method?
    Image Attached Files
    Quote Quote  
  4. Member
    Join Date
    Dec 2008
    Location
    United Kingdom
    Search Comp PM
    Any advice?
    Quote Quote  
  5. Try demuxing the audio and video to elementary streams. Then appending the audio and video separately. Check the appended audio. Assuming it's OK, mux the appended video and appended audio together.
    Quote Quote  
  6. Is the beginning of the second appended chunk at the very beginning of the second capture ? Perhaps it takes a few split seconds for the audio capture to “hit its stride” and get in sync with the video (as it seems to be past that point) ; right at the joining point there seems to be a slight distorsion, as if the tape was still speeding up. If you overlapped the end of the first capture and the beginning of the second, you could try to join them a bit further. Also, rather than sticking with an arbitrary duration of 32 minutes, if it is not possible to capture the whole thing at once, you may want to match the duration of the captures with silences, or applause, or at least something more forgiving than a close-up of the singer singing at the top of her lungs in in the middle of a line.
    Quote Quote  
  7. Member
    Join Date
    Dec 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by abolibibelot View Post
    Is the beginning of the second appended chunk at the very beginning of the second capture ? Perhaps it takes a few split seconds for the audio capture to “hit its stride” and get in sync with the video (as it seems to be past that point) ; right at the joining point there seems to be a slight distorsion, as if the tape was still speeding up. If you overlapped the end of the first capture and the beginning of the second, you could try to join them a bit further. Also, rather than sticking with an arbitrary duration of 32 minutes, if it is not possible to capture the whole thing at once, you may want to match the duration of the captures with silences, or applause, or at least something more forgiving than a close-up of the singer singing at the top of her lungs in in the middle of a line.
    Good suggestions re: the crowd. Yeah, I can't capture for much longer than 30 mins on my ancient setup without frames being inserted so I tend to keep the captures around 30 mins. I appended the second clip about 10 seconds into the capture so I think it should have "hit its stride" by then.

    Having messed around with it, I think I've found a solution. I opened up the video in Audacity and time stretched the audio so that it matches the video length. I then remuxed the new audio to the video in VDub with the following settings:
    Video > direct stream copy
    Compression: Lagarith

    Audio > Full processing mode
    Audio from other file
    Compression>PCM

    Having done that, it seems to avoid the "jumping" audio effect. Thanks for the replies!
    Quote Quote  



Similar Threads