VideoHelp Forum

+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    Apr 2010
    Location
    London
    Search PM
    Hello Guys

    I capture previously via my AJA Capture card some video tapes, but foolishly I set the audio to 24bit for best quality

    This now seems to play havoc with Virtual Dub2 when trying to do a QTGMC ??

    After creating my QTGMC script and dragging into Virtual Dub 2, the video plays fine with audio in virtual dub 2

    but when I create audio compression settings and video settings and then save video (Render)

    the audio on the exported MP4 file is all static noise


    I feel its because the source .mov has 24bit audio ?


    is there any way round this ?? for virual dub to render 24bit audio to 16bit audio when QTGMC the render file

    Thanks in advance for any help
    Last edited by Johnnysh; 9th Sep 2021 at 17:26.
    Quote Quote  
  2. Originally Posted by Johnnysh View Post
    is there any way round this ??
    Remove the audio from the script, process it separately, and add it back in later.
    Quote Quote  
  3. If VirtualDub2 can't handle 24 bit audio use ConvertAutioTo16bit() http://avisynth.nl/index.php/ConvertAudioTo16bit
    Last edited by jagabo; 10th Sep 2021 at 07:29.
    Quote Quote  
  4. Member
    Join Date
    Aug 2013
    Location
    Central Germany
    Search PM
    ConvertAudioToFloat() may work as well.

    I already discussed 24 bit integer audio issues in VirtualDub2 with its author in the doom9 forum, but he was not able to fix it yet. It may be related to using an older ffmpeg interface.
    Quote Quote  
  5. Capturing Memories dellsam34's Avatar
    Join Date
    Jan 2016
    Location
    Member Since 2005, Re-joined in 2016
    Search PM
    Vdub, Vdub2, QTGMC all handle 24bit fine, That's how all my captures are, I don't downconvert to 16bit until the final encode. This could be a problem with your system.
    Quote Quote  



Similar Threads