Once again legacy issues strike again.

Regarding the hardware bit I am OK:
I am using a firewire cable (not sure if its 400 or 800 to be hinesT) into a PCI card I have installed on my Dell XPS 8900 PC - and it has worked fine till now. As I describe my issues below I think I have no issues woith the cable or the card themselves. They did work in the past.

My issue is the software to capture the video.

1. Trying to use PlayMemories Home
I have a Sony HDR-HC9 - miniDV camcorder using those tapes. I used to be able to transfer these using PlayMemories Home , the proprietary software by Sony until it hit version 6 and the transfer of videos became defunct.
When I attempt to install older versions of this software - like PlayMemories Home v. 5.5.00 - the installer tells me:
"A newer installer is available. Click OK to cancel this installation and launch the new installer".
This will result with the version 6 of the PlayMemories Home which had removed the ability to transfer videos from tapes, or as the version history notes:
Please note that the following functions will not be available anymore:
Importing videos from Handycam camcorders that use tapes (Videos that have already been imported can be played back)

2. Using Windows Live Photo Gallery
On the Sony's website among the multiple pages that related to this issue of transferring files from miniDV tapes to PC they also state on this page:
that we can do this also using Windows Live Photo Gallery. Cue the next mess.
So I manage to find the *full* offline installation file Windows Live Essentials which includes the Windows Live Photo Gallery (as Microsoft has stopped supporting it).
When I installed it - I got the setup error 0x800c0006.
I found this guy explaining that despite this error the software actually installs.
I went to the installation folder -
C:\Program Files (x86)\Windows Live\Photo Gallery
And ran the executable WLXVideoAcquireWizard.exe (similar result if I try WLXPhotoAcquireWizard.exe).
Once it gets to the window where the transfer would begin the process I get an error message "Error: An undetermined error occurred".

[Attachment 60394 - Click to enlarge]

3. Am I using the right Firewire driver...?
I believe I am using the right Firewire driver:
Under the Device Manager it is showing as "VIA 1394 OHCI Compliant Host Controller"
The Provider is Microsoft and the version is 10.0.19041.1 (Win build 160101.0800)

If I swap this driver for the "1394 OHCI Compliant Host Controller (Legacy" - this one is again a Microsoft driver, this time file version 6.1.7601.22699 (win7sp 1_ldr 140522-2236) I get another error message:
"The video device is currently in use. Close any other program that is using the device and try again. If you need to start Import Video again, turn off import device and then turn it on again".

And so I am stuck...

4. Using SceanalyzerLive
I have tried using SceanalyzerLive 4.0 as well.
While the software can access the camcorder and control its functions (like Play and rewind) the application doesn't seem to get a video signal - as it says:
"SCLive has not recei9ved any video from the driver. Close any other program that uses this capturing-device, or doisconnect and reconnect the firewire connection."

I am very aware of the thread:

But I can't with all this mess think that the recent Windows 10 updates have messed up the drivers or the functionality that I had before that allowed me to transfer these videos to my PC.

I am aware that there are other options: I can try and do the transfer over an Hyper-V - a virtual machine set to Windows 7 - however was I unsuccessful in installing it and so abandoned the idea. I assume I can also buy a Pinnacle Dazzle DVD Recorder HD - but that would mean I would need to recode a digital source into analogue into order to digitise it (using the RCA connections) - which would be awful.

And so - what am I doing wrong - an d can someone PLEASE assist in how I fix this?
I would be very thankful for your help.
I would appreciate help on verifying that I am using the right Firewire driver (NOT the legacy version) and to be given advice as to which software can do this properly.

Your help would be very much appreciated!