VideoHelp Forum

+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 46
Thread
  1. I'm running into problems rendering some video.

    Backstory here - was recently watching some Jackass episodes, and lamented the fact that the episode captures are of low quality, although much of the material is available in DVD quality from various DVDs issued which I own, but never issued in the format of the original episodes. Plus - much of the material has changes to background music on the DVD issues. So I ripped my DVDs to .mpg, fired up Sony Vegas Pro 13.0, and started laying things out to restore some episodes using DVD sources, and using DVD or TV audio depending on whether the soundtrack had been changed, and using the crappy TV capture in spots where there is no DVD source available.

    Well, after hours of work, I rendered it - and I noticed some awful looking stuff in a section. Much of it seems fine, but clips sourced from the "lost tapes" DVD seems to render awfully in my session.

    However, doing a test render of just the source clip that I noticed the problem with, by itself, with the same settings, doesn't have the issue.

    What the heck is happening?

    I love the way Sony Vegas lets me lay out things and edit - but it is so problematic.

    I have 3 short samples I can share so you can see what's happening, and maybe help me find the source.

    https://www.dropbox.com/s/hiy3vyotj9ek6pt/samples.zip?dl=0

    Original source.mpg
    a clip of the source material - this was created from the .mpg I extracted from the DVD, using mpg2cut2 to isolate the section. As I understand it, mpg2cut2 should just cut, not edit, so this should be the same data as in the direct .mpg rip. Of course, this file looks fine when playing it.

    test render of clip by itself.mpg
    Took the original source .mpg clip, and did a render of just that, using the same settings as I use when rendering the full episodes. This looks fine.

    clip of episode render that looks awful.MPG
    Used mpg2cut2 to isolate this segment from my full episode rendering. Although the same source material was used, and was rendered with the same settings that the test render used, it looks awful. I don't understand why - the same source, rendered with the same settings, it should like exactly the same as the test render. But, as you can clearly see, it doesn't.




    Any ideas?
    Quote Quote  
  2. This gets even weirder. I put the clip from the source material, and the poorly looking rendered version, next to one another on tracks in a new session, so I could compare frame by frame.

    The source and renders are 29.970 fps.

    The session is 29.970 fps.

    This means, when I zoom in, I should see each and every individual frame, and be able to go through frame by frame, and see them all one at a time.


    What I see is that, when I alternate between the 2 sources, the frames look different.

    And I don't mean like one is blurred, or combing frames....I mean, 2 frames that show the person's leg in a slightly different position, unique in each rendering.



    How in the world could that have happened? It's as if I have 2 30fps files rendered from a 60fps source, one having the evens the other the odds.

    But, source was 29.970. Rendered to 29.970. Both laid out in a 29.970 session. And the frames don't match, one showing leg positioning that exists between the frames of the original source.


    How in the world could new frames that never existed in the source be invented?



    Something screwy is going on - I blame Sony Vegas. I love the way it lays out - but it's always monkeying with my frames and making problems. And it's completely unstable.
    Quote Quote  
  3. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    That poor encode is due to the wrong field order interpreted when the clip was encoded,
    leading to the typical back and forth motion.
    Somewhere in the setting of the clip properties should a place to choose top or bottom field first
    Quote Quote  
  4. aBigMeanie aedipuss's Avatar
    Join Date
    Oct 2005
    Location
    666th portal
    Search Comp PM
    you don't have any 60fps source. you have 60 fields per second interlaced source. 30i. interlaced. how they have been treated in the past and how they are de-interlaced can lead to many mistakes and weird video problems.
    --
    "a lot of people are better dead" - prisoner KSC2-303
    Quote Quote  
  5. Ok - now we have something.

    I did find a setting I overlooked - sure enough, if I pull in one source first, it sets the project properties to lower field first. Another - upper field first.

    I assume this setting of upper field and lower field was set in the DVD creation, and not from my DVD extraction? I believe I extracted mpg as it existed on the DVD.

    In which case.....how do I convert one of my sources to match the settings of the other, so they can be combined and rendered into a final product?
    Quote Quote  
  6. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by armyofquad View Post
    Ok - now we have something.

    I did find a setting I overlooked - sure enough, if I pull in one source first, it sets the project properties to lower field first. Another - upper field first.

    I assume this setting of upper field and lower field was set in the DVD creation, and not from my DVD extraction? I believe I extracted mpg as it existed on the DVD.

    In which case.....how do I convert one of my sources to match the settings of the other, so they can be combined and rendered into a final product?
    I'm not sure the answer to this because I'm not familiar with Vegas, perhaps somebody who knows will respond.
    But it seems like you should able to set it on the individual clips and the program will take it into account
    when the thing is rendered.
    The clip you posted was bottom field first but marked as top
    Quote Quote  
  7. Do you mean it's possible to create a single mpg to have sections that play bottom field first and sections that play top field first? I wouldn't think so - but I'm not a video editing expert.

    As far as I can see, it's a setting on the project, or a setting on the rendering, which implies I can only render a file to be one or the other.

    I suppose it would be possible to render separate mpgs, and join them into a container - but that seems a bit extreme.

    Is it possible to use conversion tools to get all my sources in the same formatting - convert one of them to be upper field first instead of lower field first?
    Quote Quote  
  8. Little more searching - I suppose the best option is set it for progressive interpolate. Sure - converting interlace to progressive will mean some level of degradation - but for the quality of the original source material, I think it's a good enough compromise to get a better version of these episodes created that requires combining multiple interlaced sources that were interlaced differently.

    Would be nice if the video industry could actually try to agree on some standards, though......
    Quote Quote  
  9. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    If you want to keep it interlaced, Vegas will honor the setting in the source clips and take it into account
    when it renders. If you want to make a DVD this is certainly the best option, since it is within the DVD spec.
    Interpolate will rob you of the motion fluidity, since you're halving the field rate.
    Quote Quote  
  10. No it will not. If it did that, it would have done that with my example. As you can see from the sample, it did not.

    As far as I can tell, it is not possible to render a single .mpg that does upper frame first for some portions and lower frame first from others, and until I see evidence to the contrary, this is what I will believe.

    By all means, if I have this incorrect (which I very well may), please prove me wrong. But I'll need to see proof, or specific instructions on how to accomplish that.
    Quote Quote  
  11. aBigMeanie aedipuss's Avatar
    Join Date
    Oct 2005
    Location
    666th portal
    Search Comp PM
    most dvd was tff. dv was bff. in vegas if you click file/properties you can disable resampling and adjusting source to match project settings.
    --
    "a lot of people are better dead" - prisoner KSC2-303
    Quote Quote  
  12. In Vegas - going into file - properties, lets me set the properties of the project. Which will let me select top field first. Or bottom field first. Or progressive.

    But the issue still stands - as far as I can see, it is not possible to render a single .mpg that combines sources that are top field first and bottom field first, and have it switch between those settings within the same file.

    I've searched high and low, and I've found nothing that suggests any such thing is possible. And while people keep responding in this thread suggesting I may want to check settings here, or don't want to do progressive scan, no one has flat out stated that it is possible to create a single .mpg that does top field first for some sections, and bottom field first for others, or come up with a process to do exactly that.


    I understand this is volunteer stuff to post here, but I know when I post in areas about things I'm an expert on, I'm very specific and detailed. Getting specific details on this forum has been like pulling teeth. I appreciate the response and the help, but please.....post specifics.

    For starters, answer 2 simple questions.

    IS it possible to render a single .mpg that uses multiple sources, some of which are top field first, some of which are bottom field first, to switch between those 2 modes within the same file?

    If so, HOW? Post details.
    Quote Quote  
  13. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    do you mean like this?
    Image Attached Thumbnails Click image for larger version

Name:	vg1.png
Views:	10
Size:	196.3 KB
ID:	59978  

    Click image for larger version

Name:	vg2.png
Views:	7
Size:	135.3 KB
ID:	59979  

    Image Attached Files
    Quote Quote  
  14. While I appreciate the response, that is not an answer to my question, or a set of instructions how to accomplish what I'm asking.

    Why is it damn near impossible to actually get a useful response on this forum?
    Quote Quote  
  15. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Why don't you call Vegas support and
    Pay them for their expert advice? Then you'll have some credibility when you start whining
    Quote Quote  
  16. Ok - I may have filled in blanks here and come up with something, but I'll need people to check my work.

    Mind you, having a setting on the project level, and on the render level, that can be completely ignored by having it go by the clips level, is completely illogical and non-intuitive. But very little in the world of video editing makes any logical sense to me....it all defies logic.

    On the one hand, I had everything I was seeing, and the results of what I was seeing, telling me that a rendered .mpg had to be either interlaced top first, interlaced bottom first, or progressive, with some method of deinterlacing if the source is interlaced.

    On the other, while no one here could be bothered to write a simple "yes, it's possible to render an .mpg that switches between those modes", everyone's passive aggressive posts of incomplete suggestions without context suggested you were trying to suggest something that would do that. But....despite multiple times flat out asking for a yes or no, no one could do that, and instead responded in cryptic out of context suggestions without much clue as to how that helps me.

    So, I checked the properties on individual clips in my session. They were already set correctly - top field first or bottom field first depending on source. Yet - they rendered into top field first across the board, making the bottom field first materials look like crap. Which makes sense, since the only place I could set a setting was on the project and rendering, of which both were set to top field first.

    aedipuss made reference to disabling resampling and adjusting source to match settings. But didn't go into any detail. No "yes, it's possible". No "what you want to do is go into file - properties, and uncheck the box called "adjust source....", that will cause the rendering to stick to the source's properties instead of rendering everything to the project setting".

    While it's very unintuitive to have a project setting that has to be one or the other, I can understand unchecking a box meaning that the project setting won't have impact on the rendering process. Unintuitive - but I can wrap my head around that. What I can't wrap my head around, is that when I go to render, the rendering settings itself has the drop down where I have to select top field first or bottom field first. There's no "go with the source material's settings". Which - is what LOGICALLY EVERY RENDERING SHOULD DO, UNLESS YOU'RE DE-INTERLACING!!!! In what universe does it make any sense to have a rendering render something that is top field first as bottom field first, or vica versa? Shouldn't the setting in rendering be interlaced - same as source, or something like that? Rather than, selecting interlaced, top field first - but have that setting not mean anything, because of a checkbox I unchecked in the project properties?

    I work helpdesk tech support, I use a lot of software, I help and educate end users on using software.......but this - this makes absolutely no sense. So much so, that I'm still not sure I have this right. But, based on the small bits of info posted here, and my further testing, this seems to be what the reality is of interlaced video rendering.



    I'd ask for confirmation that I got this right, or explanation......but given the level of expert instruction I've received to this point, it seems rather pointless.
    Quote Quote  
  17. Originally Posted by armyofquad View Post

    IS it possible to render a single .mpg that uses multiple sources, some of which are top field first, some of which are bottom field first, to switch between those 2 modes within the same file?

    If so, HOW? Post details.
    Yes, vegas should do this automatically


    Internally in vegas all assets conform to the timeline project settings, and those get converted to the render settings.

    So if you have mixed TFF, BFF, progressive - they all become converted to whatever the timeline is set to, and then later changed to whatever the export settings are is set to.

    Normally everything just works "out of the box". User doesn' t have to do anything. If you want a simple demonstration or proof let me know. I'm 100% certain.





    If a clip is interpreted incorrectly, you get exactly what you see in the problem clip. It's classic wrong field order. For example, if the clip has flagged metadata that is incorrect (it might have been flagged BFF, but content TFF) - vegas might get the auto interpretation incorrect

    But your source clip is TFF... and flagged TFF - So there is something else going on with your project, either some edit or some decoding error, or some other issue. It doesn't entirely make sense because the single clip rendered out ok ...

    Double check the properties of the individual clip (right click on the timeline, or click the clip in the clip bin) , the project settings, and export settings

    Sometimes HW acceleration can cause glitches - you might try disabling

    Sometimes just rebooting helps (damn windoze)
    Quote Quote  
  18. It has been confirmed that the problem lies in the .mpg extracted from the jackass lost tapes DVD is lower field first, and Vegas out of the box absolutely is not set it and forget it.

    I've unchecked the box in the project properties to "adjust source media to better match...", but still, ANYTHING I RENDER COMES UP UPPER FIELD FIRST, which is in line with the render settings.

    I've seen ZERO evidence that it is possible to render an .mpg that alternates between upper field first and lower field first, I've seen ZERO evidence that there are any settings in Vegas for it to go with the setting of the source material rather than selecting interlaced upper first, interlaced lower first, or progressive.

    So far, I've received a lot of responses, very little useful information.

    If this damn Jackass DVD was actually rendered to the standard that DVD typically uses of upper field first, I wouldn't be having any problems.


    So, for the love of god, could SOMEONE out there actually help me, please?

    Not that I don't appreciate the efforts or responses - but I would hope any sane logical person would read this thread, and see I'm giving clear examples and details, providing samples of what I'm seeing, providing details of what I'm experiencing and what I'm trying, and asking very clear, direct, straightforward questions. And all responses are vague, incomplete, and completely lack a direct answer to specific questions.


    If no one can come up with a specific and exact process that needs to be followed in Sony Vegas Pro 13 to render an interlaced .mpg that follows the settings of the source .mpgs and alternates between upper first and lower first depending on the source, then perhaps it may be time to ask, is there a process I could run the problem file through to get it to the same standard as all my other sources, upper first?

    I mean, in theory, if you take a lower field first .mpg, and remove the bottom line, and put a blank line on the top - doesn't that make it upper first with loss of 1 line? At this point, the sacrifice of a line would be an acceptable sacrifice to do away with all this bullshit. Is there something that will do that for me, if no one is willing to properly instruct me on how to render things in Vegas?
    Quote Quote  
  19. I am thoroughly confused - with that box unchecked, all videos I render say they're upper first, but sometimes the lower first material looks fine, sometimes it doesn't.

    As a test - I took the sample I uploaded here that looks jagged - it's clearly marked upper first, it's playing upper first, it looks awful, the source is lower first.

    I pulled that clip into Vegas, set the properties on the clip to lower first, unchecked the "adjust source media" checkbox in the project properties, but left the project properties and render properties to upper first.

    What I end up with is a rendering that looks fine, but when I check the clip properties it is upper first.

    It looks fine - so that led me to believe that unchecking the box fixes the problem, despite the other settings being upper first and the rendered product saying it's upper first.

    But then I rendered another project, and got the jitters on the portions that used the problem video. checkbox was unchecked, clip properties were lower first....but it rendered broken.

    So my results are inconsistent. And no one here seems to be able to clear any of this up.


    Is the way that Vegas deals with this is, when rendering to .mpg with upper field first, and source materials are lower field first and properly set to that, and the projects checkbox for "adjust media source" is unchecked - it should still render an upper first, by converting lower first material to upper first? Or, should the file play lower first, but the settings show it as upper first, because it was set to render upper first?


    Nothing makes any sense here - if only someone was here that understands all of this and would give this the time needed - this could be such a helpful thread if someone would just clear it all up and answer all the unanswered questions that lie in here.
    Quote Quote  
  20. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    The render does not alternate between upper and lower fields. It's fixed as per the project. But it doesn't matter,
    as long as the assets are interpreted properly (via the field order on the individual clips)

    Didn't you look at the clip I posted? Doesn't it play smoothly all the way through?

    Come on man; first you said you were an expert then you derided the "volunteers" on here.
    You better give it a rethink
    Quote Quote  
  21. Originally Posted by armyofquad View Post
    It has been confirmed that the problem lies in the .mpg extracted from the jackass lost tapes DVD is lower field first, and Vegas out of the box absolutely is not set it and forget it.

    NO...

    The original sample you uploaded "Original source.mpg" content is TFF, also flagged TFF.

    It does work out of the box, your test render by itself "test render of clip by itself.mpg" content is TFF, also flagged TFF. This clip is ok


    "clip of episode render that looks awful.MPG" is BFF content, but flagged TFF. That is the problem . Field order is reversed


    Something is up with your project config, settings or something else you did is messing it up (or maybe something up with your vegas locally), or you missed posting some critical information


    I've seen ZERO evidence that it is possible to render an .mpg that alternates between upper field first and lower field first, I've seen ZERO evidence that there are any settings in Vegas for it to go with the setting of the source material rather than selecting interlaced upper first, interlaced lower first, or progressive.
    That's not what you asked originally - Your question was answered above. Notice the difference. Your original question was about different sources. That was answered. If need proof or demonstration, just ask. This last statement is about output renders

    It is possible to have alternating field order output, but not in vegas. If you were paying attention, all assets conform to the timeline settings in vegas. Ideally if you were doing this, you'd use a transport stream, which is designed to handle swapping formats




    If no one can come up with a specific and exact process that needs to be followed in Sony Vegas Pro 13 to render an interlaced .mpg that follows the settings of the source .mpgs and alternates between upper first and lower first depending on the source, then perhaps it may be time to ask, is there a process I could run the problem file through to get it to the same standard as all my other sources, upper first?
    Provide a sample of your source that "alternates" . All you've provided is a TFF source , correctly flagged TFF
    Quote Quote  
  22. I have never said I'm an expert at video editing. Quite often I've stated where I'm making possible assumptions, and continue to defer to experts to explain any incorrect assumptions or suggestions I've made.

    I'm still not understanding what the final result should be - if you have a lower field first source, set as lower field, in an upper field first project, rendered upper field, that plays properly, but says it's upper field - does that mean the rendering did some sort of conversion to convert the lower field first material to upper field first?

    My biggest problem though is that, it seems my renders sometimes work, and sometimes don't. I'm fairly certain I'm being consistent in my settings based on the bits of guidance I've received here - but then again I did overlook the whole field order setting to start with. I can't figure out why my results continue to be inconsistent.


    At this point, I'm under the assumption that, all things working as it should, if I pull a lower field first source by itself into a project, uncheck the box, verify clip properties is lower first, project and render settings to upper first, and render - I should end up with a new version of that file that is upper first and works fine. Which, if I can get that to work, gives me a path to re-render my "lost tapes" source to upper first, and have my projects all use consistent source material, which should give me better luck in my renderings.
    Quote Quote  
  23. poisondeathray - ok, love the username, like your detail in response - we're too completely out of sync right now though that I"m not sure how to respond to your responses.

    Gonna play around with a few more things.
    Quote Quote  
  24. Originally Posted by poisondeathray View Post

    NO...

    The original sample you uploaded "Original source.mpg" content is TFF, also flagged TFF.

    It does work out of the box, your test render by itself "test render of clip by itself.mpg" content is TFF, also flagged TFF. This clip is ok


    "clip of episode render that looks awful.MPG" is BFF content, but flagged TFF. That is the problem . Field order is reversed


    Something is up with your project config, settings or something else you did is messing it up (or maybe something up with your vegas locally), or you missed posting some critical information
    Ok - you are correct that the "original source" file is flagged TFF, and plays TFF.
    However - the file that the "original source" file was extracted from, is BFF.

    As stated in the initial post - I used Mpg2Cut2 to extract that portion of "original source". My thought being that Mpg2Cut2 would simply cut a portion, leaving everything else intact. Otherwise, in order to provide a source material for analysis, I'd have to upload the entire DVD extraction - which would be problematic for size and copyright issues. I did state the use of Mpg2Cut2 in case I had overlooked a possible change this process could cause. It appears that using Mpg2Cut2 to extract a sample of a larger file can change it from BFF to TFF, as I can assure you the original extraction is BFF and plays fine BFF and renders fine if rendered to BFF - but yes, that original source file is TFF.

    It is possible to have alternating field order output, but not in vegas. If you were paying attention, all assets conform to the timeline settings in vegas. Ideally if you were doing this, you'd use a transport stream, which is designed to handle swapping formats
    Ok - losing me a little here. So to answer my question, it is possible to have alternating field order - but that result is not possible in Vegas. Got it.

    So then I'm not fully understanding what the end result you all are going for here - but my current line of thought is that rendering BFF sources to a TFF output is possible, and the result we are going for - that by having the project settings set to not change the clip settings, the clip settings set properly, and the render settings set to TFF - it will render TFF to TFF, and BFF will be converted to TFF so that it will be TFF and play properly.

    While I have seen results that support this current possible understanding, I have also seen results that don't, and I'm still unsure of those inconsistent results.

    Not sure what "using a transport stream" is, and also not sure if that's something worth going into, since the whole "swapping formats" question was based on what I was understanding the implied goal to be - but I suppose the question that needs to be asked now - what is the goal here when rendering a project that includes TFF and BFF sources - for the BFF material to be converted to TFF properly as part of the rendering process?


    Provide a sample of your source that "alternates" . All you've provided is a TFF source , correctly flagged TFF
    I can't provide that - I've not successfully completed something that accomplishes that - and it seems my questions were based on a lack of fully understanding what we're trying to do, but I'll be happy to provide anything I can. Best I can provide you with at the moment is the updates above - that the original source file doesn't accurately reflect the original source, and that I'm currently operating on an understanding that the goal is to accomplish a TFF rendering that properly handles BFF material and renders it to TFF without making it jittery. But being that my results are mixed, I'm still not clear on how specifically to do that, or just what in the heck Vegas is doing.
    Quote Quote  
  25. My attempt to drag in the BFF source into a new project, uncheck the box, verify the properties on the clip is BFF, and set the rendering to TFF with the project properties set to TFF, resulted in a TFF rendering that is jittery.

    Out of box - doesn't work.

    Following suggestions - doesn't work.


    So far nothing has worked.


    Someone, please make sense of all of this. I'm really trying to follow this all here, but somehow we keep dancing around whatever it is that someone needs to explain.
    Quote Quote  
  26. What if.....the problem is that this source DVD is authored in some funky ass way that it alternates between BFF and TFF, and Vegas is treating the whole thing as BFF, but the portion that I used as an example happens to really be TFF, and when using Mpg2Cut2 to extract that portion by itself, it is TFF and looks right TFF, but my initial rendering that I snipped the bad example is, treated that segment as BFF, since it imported the whole source as BFF.

    Which would mean, the TFF material, was treated as BFF material, rendered into TFF - which resulted in a TFF rendering that looks wrong?

    That's my latest theory.



    I will say, this DVD was authored really screwy. I normally extract everything with makemkv - but makemkv didn't find the main program when extracting. So I had to use DVDFabPass and DVDVob2Mpg to extract that material from the original DVD - which resulted in a soundtrack that doesn't align properly. But as long as I have my frames, and my audio, I can line that up as it needs to be in my projects. But I also noticed, what I extract, doesn't align to the material as it plays in the DVD. That is - if I play the DVD in VLC, go to the menu - the first chapter is "cannonball". I select it, and it starts playing the entire content from the beginning - cannonball - opening credits - self defense......and I can see the layout and chapters, and skip around. However - what I exactracted doing DVDVob2Mpg - which is essentially just a file joining/copying process - starts with self defense, then cannonball and credits. So - the actual mpg data on the disc is in one order, but it's programmed to play in another order. But not through DVD authoring navigation - it still shows up as one long timeline of content with chapters, but the content is ordered differently from the order it is in the actual data. Absolutely bizarre, and not something I ever knew was possible. Which has me completely questioning - just what is this?

    But - my current theory - this is a funky ass .mpg that alternates between TFF and BFF, and this is a format Vegas isn't suited to deal with - which would explain why it imports into Vegas as BFF, why that segment by itself when extracted out using a process that shouldn't modify data loads in as TFF and plays fine TFF - and this explains why I can't find consistency as I play around with different methods that sometimes renders things based on one setting, and sometimes based on another.

    But I'm not the video editing expert. But I am a troubleshooting expert.



    Feel free to apply video editing expertise to my troubleshooting findings and observations - hopefully we can get to the bottom of this - but with my current theory, I"m looking at using Mpg2Cut2 to chop up the source into separate clips, that should work by themselves - just means a lot of extra work in this project. But whatever gets me a perfect final product.
    Quote Quote  
  27. Originally Posted by armyofquad View Post
    Originally Posted by poisondeathray View Post

    NO...

    The original sample you uploaded "Original source.mpg" content is TFF, also flagged TFF.
    Ok - you are correct that the "original source" file is flagged TFF, and plays TFF.
    However - the file that the "original source" file was extracted from, is BFF.

    As stated in the initial post - I used Mpg2Cut2 to extract that portion of "original source". My thought being that Mpg2Cut2 would simply cut a portion, leaving everything else intact. Otherwise, in order to provide a source material for analysis, I'd have to upload the entire DVD extraction - which would be problematic for size and copyright issues. I did state the use of Mpg2Cut2 in case I had overlooked a possible change this process could cause. It appears that using Mpg2Cut2 to extract a sample of a larger file can change it from BFF to TFF, as I can assure you the original extraction is BFF and plays fine BFF and renders fine if rendered to BFF - but yes, that original source file is TFF.
    So the sample you provided is not helpful and some issue with mpg2cut2 ? That answers why that clip rendered by itself works ok

    What is your actual source that you are using? You claim that it's BFF but how are you determining that ? What is the content field order, and flagging ? That is what is important





    It is possible to have alternating field order output, but not in vegas. If you were paying attention, all assets conform to the timeline settings in vegas. Ideally if you were doing this, you'd use a transport stream, which is designed to handle swapping formats
    Ok - losing me a little here. So to answer my question, it is possible to have alternating field order - but that result is not possible in Vegas. Got it.

    So then I'm not fully understanding what the end result you all are going for here - but my current line of thought is that rendering BFF sources to a TFF output is possible, and the result we are going for - that by having the project settings set to not change the clip settings, the clip settings set properly, and the render settings set to TFF - it will render TFF to TFF, and BFF will be converted to TFF so that it will be TFF and play properly.

    While I have seen results that support this current possible understanding, I have also seen results that don't, and I'm still unsure of those inconsistent results.

    Not sure what "using a transport stream" is, and also not sure if that's something worth going into, since the whole "swapping formats" question was based on what I was understanding the implied goal to be - but I suppose the question that needs to be asked now - what is the goal here when rendering a project that includes TFF and BFF sources - for the BFF material to be converted to TFF properly as part of the rendering process?
    This might be all irrelevant. Go back to your original source first if mpeg2cut2 is messing things up. Go back to step 1. What do you actually have ?



    My biggest problem though is that, it seems my renders sometimes work, and sometimes don't. I'm fairly certain I'm being consistent in my settings based on the bits of guidance I've received here - but then again I did overlook the whole field order setting to start with. I can't figure out why my results continue to be inconsistent.
    Right. So is this a source problem ? Is source decrypted properly ? Maybe problem with that source ?

    Is something else going on like HW problem (overheating, ram issue, GPU failure, PSU flaking out) . Flaky inconsistent behaviour is often HW related...


    Provide more information on your project and edits. Are all your clips TFF ? Do you have any source clips that were BFF content ? What is the flagging ? How are you determining this ?



    Originally Posted by armyofquad View Post
    My attempt to drag in the BFF source into a new project, uncheck the box, verify the properties on the clip is BFF, and set the rendering to TFF with the project properties set to TFF, resulted in a TFF rendering that is jittery.

    Out of box - doesn't work.

    Following suggestions - doesn't work.


    So far nothing has worked.


    Someone, please make sense of all of this. I'm really trying to follow this all here, but somehow we keep dancing around whatever it is that someone needs to explain.

    It works just fine on a real BFF clip, flagged BFF. It's easy to prove and demonstrate. If you want a sample project that mixes BFF, TFF, 23.976p, 29.97p, it's easy to demonstrate it works fine "out of the box" , whether or not "adjust" is checkmarked

    How are you determining your source is BFF ? Is actual field order BFF, and is it flagged BFF ?

    Provide a sample of the source. You can try avidemux if mpg2cut2 is giving your problems
    Quote Quote  
  28. Originally Posted by armyofquad View Post
    What if.....the problem is that this source DVD is authored in some funky ass way that it alternates between BFF and TFF, and Vegas is treating the whole thing as BFF, but the portion that I used as an example happens to really be TFF, and when using Mpg2Cut2 to extract that portion by itself, it is TFF and looks right TFF, but my initial rendering that I snipped the bad example is, treated that segment as BFF, since it imported the whole source as BFF.

    Which would mean, the TFF material, was treated as BFF material, rendered into TFF - which resulted in a TFF rendering that looks wrong?

    That's my latest theory.
    It's possible...

    Perhaps try another way of decrypting it first

    Can't help more unless you provide more information such as a sample
    Quote Quote  
  29. Working on a solution to that. I figured, maybe if I use mpg2cut2 to cut a larger segment, the start up to the problematic portion in our example, that should work. But - that clip came out all TFF as well. I had figured Vegas would go with what it saw at the start if there was a multiple format thing going on. But that seems to not be so.

    Perhaps the whole thing is TFF, with something screwy.

    Either way - I think we've identified it's a problem with this source.


    I'm not sure of what other method of extraction I can use. I figured copying the VOBs to a mpg is about as pure as it gets.

    New theory - everything is TFF - something screwy triggers Vegas into identifying this source as BFF - if I set the source as TFF, everything should render fine. Now to test that.


    Otherwise - only option I have to provide a source for analysis is to zip up the entire rip.
    Quote Quote  
  30. Ok - that theory has not panned out. If I set the source to TFF - the fast food football spike clip looks fine, but self defense looks jittery. And to confirm that's the setting that changes it, I set the source to BFF, self defense renders fine, other things including the fast food spike renders jittery. Which seems to confirm, this extraction is mixed source - turns out my question was relevant, I just didn't know why, lol.

    What threw me off was grabbing a sample of the beginning pulled in as TFF, which went against my theory that the source starts BFF and Vegas identifies it as such because it starts that way. I think it does start BFF, as my above testing seems to confirm that self defense plays properly when set as BFF. But, the unknown at this time is, how does Vegas decide what to detect a file as when pulling it in?

    Anyways - here's a sample that I think will help you see something. Here's the mpg2cut2 clipping of the beginning of the source file. Although Vegas identifies it as TFF, I think you'll find the self defense material at the start is actually BFF, but then it switches to TFF. Or maybe you'll find something completely different.

    Which, if this theory is confirmed, leaves me with - is there a way I can convert my original source into something that is all TFF across the board?
    Quote Quote  



Similar Threads