VideoHelp Forum

+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 31 to 46 of 46
Thread
  1. Where is the sample?
    Quote Quote  
  2. Yes, it's not decoded correctly in vegas, and there are field order transitions

    Most people that deal with DVD (on a more than casual level) would use avisynth / DGIndex . DGIndex will automatically give you the option to detect and correct for the field transition(s) during indexing stage

    Vegas can't handle problematic sources like this (avisynth is used all the time for problematic DVD's that are worse than this)


    There is a bit of a learning curve to avisynth. Depending on what your output goal was, you might perform additional processing such as double rate deinterlacing, cleaning up the DVD. Or if you just wanted an interlaced intermediate file to import cut in vegas, you could do that too.
    Quote Quote  
  3. My end product will be MKV files, but since all of my source are DVD, I intend to keep things DVD quality, create .mpg, and create .mkv files from that.

    So, I believe "interlaced intermediate file to import cut in vegas" is exactly what I'm looking to convert the source to.

    Is there a good guide you can point me to, or some instructions you can provide for that?
    Quote Quote  
  4. Is it as simple as demux using DGIndex, click yes when it asks to fix, and use the demuxed m2v file that comes out?
    Quote Quote  
  5. Nope, that didn't do it - the self defense segment still comes out jittery.

    Still need a process to fix this file into an all tff file.
    Quote Quote  
  6. I'm confused here.

    You wrote - "DGIndex will automatically give you the option to detect and correct for the field transition(s) during indexing stage"

    When I demuxed with DGIndex, sure enough it popped up a window that says "A field order transition was detected"...."correct the field order transition?"

    I click yes.

    This seems to be what you were referring to with DGIndex automatically correcting.

    However, the demuxed file I got suffers from the same problem - when I render using that source, some things render fine, some jerky. It didn't correct it.

    What is happening? How can I simply get this stupid field order transitioned .mpg fixed into a consistent file?
    Quote Quote  
  7. To further confirm this - I took the file that DGIndex produced that supposedly "fixed" it, loaded it as a new project, demuxed again, and it once again detects field order transitions.

    So that whole "click yes to fix" thing, doesn't fix it.

    What gives?
    Quote Quote  
  8. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by armyofquad View Post
    To further confirm this - I took the file that DGIndex produced that supposedly "fixed" it, loaded it as a new project, demuxed again, and it once again detects field order transitions.

    So that whole "click yes to fix" thing, doesn't fix it.

    What gives?
    It fixes the d2v. I usually decline the fix option, allow the project save to finish,
    then use tools/fix d2v
    Now when the d2v is opened in Avisynth script via Mpeg2Source, the frames will be served in the proper
    order
    What version of Vegas are you using ?
    Quote Quote  
  9. Vegas Pro 13.0

    Not sure what a d2v file is, how it helps me, or how to use it - I just pull video sources into Vegas and edit.

    Why do you decline the fix option - don't we want this fixed?

    And so - this app, generates a file - with fixed information (that you typically decline) - that is then used in avisynth - to.....create a fixed .mpg?


    Or what?
    Quote Quote  
  10. Ok - I've found a temporary work around that lets me actually get some renderings done - although I do wish to continue pursuing this path, because I would definitely like to know how to take a funky ass mixed settings file like this, and have a process I can run it through that gives me a stable file that I can work with that doesn't require fixing.

    But - for now - a few tips that will get you by in a pinch, if you find yourself in a situation like this in Vegas, where your interlaced mpg source has mixed field order settings, and when you render you get sections that are jittery.

    Project properties - you probably want to set it to Upper field first - most likely most of your interlaced source is like that. (If not - adjust to your needs)
    Also on the project properties - when the checkbox is checked to "adjust source media to better match project or render settings", rendering will follow the setting on the media itself. You want this box checked. It was checked by default, and my "fix" requires it to stay checked.

    If you right click a portion of video in your project, and click properties, and select the media tab, you will find the field order for that file. However - if you change it, it will change it for any segment in the project that uses a portion of that source file. In my case - I had some segments that were lower field first and needed to continue to be set to that, while I needed to set other segments to upper field first.

    If you right click the section of video you wish to modify the field order of in the project, you can select "create subclip". Once that's created, you can then right click, select properties, go into the media tab, and change the field order to what it needs to be, and have it only adjust that on that segment.

    Repeat as necessary.


    Only down side is, previewing doesn't show me how it will render - I have to render and verify the problem areas, tweak, and re-render.

    But - this is a workaround in a pinch if you find yourself in a jam and just need to get a few segments in your vegas project to render to a different field order.
    Quote Quote  
  11. Originally Posted by armyofquad View Post
    I'm confused here.

    You wrote - "DGIndex will automatically give you the option to detect and correct for the field transition(s) during indexing stage"

    When I demuxed with DGIndex, sure enough it popped up a window that says "A field order transition was detected"...."correct the field order transition?"

    I click yes.

    This seems to be what you were referring to with DGIndex automatically correcting.

    However, the demuxed file I got suffers from the same problem - when I render using that source, some things render fine, some jerky. It didn't correct it.

    What is happening? How can I simply get this stupid field order transitioned .mpg fixed into a consistent file?


    No, DGIndex it demuxes the file as-is . Demuxing would only fix DVD problems that resulted from multiplexing, and only if the bitstream was ok in the first place

    But the fixes in your case are for field order transitions, and decoding errors in vegas - demuxing/remuxing and importing into vegas won't fix those sorts of problems

    The decoding and field order transition fixes are specified in the .d2v file, and you need to frame serve - unfortunately this means decoding, thus re-encoding and you have various options (such as lossy, lossless, tradeoffs vs. quality/filesize, compression vs. editing performance).


    1) install avisynth

    2) Normally you open vob/mpg file in dgindex (you can drop and drag) , file=>save project. It will demux the audio (delay written in the name), and a .d2v which is a project file of sorts. I generally say "yes" to the prompts - the fixed version contains the fixed field order transitions, but if there are issues, you can use the other version. The fixed version works for your sample fine

    But in your case, maybe because of the file was prepared (or maybe it was like that on the DVD) , you need to cut some of the black frames to keep sync (it tells you this when you try to index, it mentions black frames). So go to the 1st good frame , then go backwards with the "<" button in the GUI. This advances backward 1 GOP. Push the "[" button to mark in. That is your start point. File=>save project as (give it some descriptive name)

    3) create a script, save it (e.g. script.avs) . You can use notepad, some people use avspmod as the script editor because you can preview. Vdub2 can preview scripts too


    I like include audio in the script, to check for sync and preview to check for issues before encoding. I like mpchc for checking playback, sync of avs scripts.

    My project name was "cut", you need to enter the correct paths and filenames. If a delay was written in the filename, you would use DelayAudio in ms, or you can correct offset delay when muxing. Your example is 0ms or no +/- delay, because the procedure of advancing and cutting the black frames
    Code:
    aud=NICAC3source("PATH\cut T80 2_0ch 192Kbps DELAY 0ms.ac3")
    vid=MPEG2Source("PATH\cut.d2v")
    
    AudioDub(vid,aud)
    #DelayAudio

    Note that the result of the script is BFF (completely) . You can use info() to see information including the current field order in the script. You can swap the field order in avisynth, or just leave it. Vegas has no problems with files when the content field order matches the flagged field order (and there is no switching or other problems)

    If you wanted TFF (completely) you can add to the end of the script
    Code:
    SeparateFields().Trim(1,0).Weave()
    You can use whatever intermediate format you feel comfortable with. There are tradoffs and various issues with compatibility with vegas

    eg. maybe filesizes are too large for you . They are many options. Maybe some loss is ok for you. Maybe high bitrate MPEG2 is "good enough" for you. Maybe you want something less ccompressed, and faster editing. Maybe smaller filesize /more compressed but slower to edit on the timeline. It's up to you

    Here is an example of high bitrate mpeg2 in a transport stream, with stream copied audio, using ffmpeg. The script.avs is the TFF version. If you wanted BFF change -vf setfield=bff, and -top 0, and erase or comment out the SeparateFields().Trim(1,0).Weave() line and save it.

    This works ok in vegas 13 pro
    Code:
    ffmpeg -i script.avs -i "cut T80 2_0ch 192Kbps DELAY 0ms.ac3" -map 0:0 -map 1:0 -vf setfield=tff -c:v mpeg2video -flags +ilme+ildct -alternate_scan 1 -top 1 -bf 0 -q:v 2 -qmin 2 -qmax 2 -c:a copy -aspect 4/3 out_tff.m2ts
    Quote Quote  
  12. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Out of interest, how long is losttapes-sample.mpg supposed to be?
    Quote Quote  
  13. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    So, I believe "interlaced intermediate file to import cut in vegas" is exactly what I'm looking to convert the source to.
    I opened that MPEG in VirtualDubMPEG2 then saved the self-defence section as a Lagarith AVI and PCM audio. It's BFF.

    Then I saved the stunts as a separate file. It's TFF.
    Quote Quote  
  14. Originally Posted by armyofquad View Post
    Only down side is, previewing doesn't show me how it will render - I have to render and verify the problem areas, tweak, and re-render.
    One option instead of rendering is to "nest veggies" .

    Save your current project. Open another vegas instance . Set the project settings the same, except set the properties to progressive, and set frame rate to double (for NTSC it would be 59.94). I like deinterlace set to interpolate instead of blend because it's more clear. Open your main .veg in the 2nd vegas instance. You're just using the 2nd instance of vegas to preview - it's being used to double rate deinterlace, thus showing you all the fields (resized as frames), instead of 1/2 the fields. Wrong field order sections will playback jerky (forward/back/forward/back)
    Quote Quote  
  15. Originally Posted by poisondeathray View Post
    Originally Posted by armyofquad View Post
    Only down side is, previewing doesn't show me how it will render - I have to render and verify the problem areas, tweak, and re-render.
    One option instead of rendering is to "nest veggies" .

    Save your current project. Open another vegas instance . Set the project settings the same, except set the properties to progressive, and set frame rate to double (for NTSC it would be 59.94). I like deinterlace set to interpolate instead of blend because it's more clear. Open your main .veg in the 2nd vegas instance. You're just using the 2nd instance of vegas to preview - it's being used to double rate deinterlace, thus showing you all the fields (resized as frames), instead of 1/2 the fields. Wrong field order sections will playback jerky (forward/back/forward/back)
    Excellent.

    I think for now I'll stick with using this process to verify things - and manually setting the source to top first as necessary. So far, it seems that only the self defense segment is bottom field first, so it seems just manually tweaking a few settings in Vegas, and verifying it looks ok with your suggested method, is a better option than running the source through a bunch of other processing.

    But that process is definitely good info to know in case I run into another complicated DVD that gives me more problems.
    Quote Quote  



Similar Threads