VideoHelp Forum

+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. I have a batch routine to convert .mp4's to .mkv's.

    All I'm basically doing is using this to add a personalized COLORED .srt to existing .mp4, .mkv and .avi files.

    This routine works flawlessly on doing .mkv to .mkv files. Come out just lie ORIG with my mods, non-jerky framerate.

    Routine removes all existing subpics, add NEW colored subpic, adds/modifies, video, audio and subpic Descriptions via a .json config files.

    Tried tweaks in VLC codec section, per https://windowsreport.com/vlc-media-player-lagging-windows-10/#2 ... no help there !!

    VLC is my goto player .. same with MPC-HC

    The jerkiness is slight, but enough to make you not want to watch it !!

    Please assist..... THANKS in Advance @@


    Code:
    set mkvmerge=F:\Media\MKVToolNix\mkvmerge.exe
    set mkvjsons=J:\MKVToolNix\MKVjsons\
    set jsonsext=.json
    set subsave=J:\MKVToolNix\SubPic_Out\
    
    if not exist "mkvmerge_out" (mkdir "mkvmerge_out")
    
    if not exist "moved_mp4s" (mkdir "moved_mp4s")
    
    
    for %%f in (*.mp4) do %mkvmerge% -o "mkvmerge_out/%%~nf.mkv" --no-subtitles "%%f" "%%~nf.srt"    
    
    
    move /y ".\mkvmerge_out\*.mkv" ".\"
    
    
    for %%f in (*.mkv) do %mkvmerge% @%mkvjsons%%jsonname%%jsonsext% -o "mkvmerge_out/%%~nf.mkv" --title "%%~nf" "%%~f"
    
    
    move /y ".\mkvmerge_out\*.mkv" ".\"
    Last edited by sailor420; 12th Jul 2021 at 18:57. Reason: Adding more code and attaching ONE .json file
    Quote Quote  
  2. Attached .json as .txt
    Image Attached Files
    Quote Quote  
  3. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Did you check the mediainfo (text view) for the before and after files to see if anything suspicious stands out ?
    Quote Quote  
  4. Member netmask56's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Search Comp PM
    Are you using the latest version of MKVToolNix (v59) It now supports Dolby Vision..... at last
    SONY 75" Full array 200Hz LED TV, Yamaha A1070 amp, Zidoo UHD3000, BeyonWiz PVR V2 (Enigma2 clone), Chromecast, Windows 7 Ultimate, QNAP NAS TS851
    Quote Quote  
  5. @netmask56 ... My ver is a little out of date .... using v.24 .. lol

    @davexnet ..... about the same ... frame rate same

    Need to do clean up on PC as MEDIA drives are FULL ... then test further

    One good thing is its not my .bat routine ... MKVToolNik does the same thing

    The other good news is it's related to the ORIG encoding as NOT all .mp4 test get the Beef Jerky effect. In fact its a very small percentage, 4 out of 20 to 30 muxed.

    So hopefully by today I'll have an answer after more testing

    PS: Gonna test with ffmpeg too so stay tuned
    Quote Quote  
  6. Embarrassed to say what fixed it ...... the outdated version

    Bartender, get netmask a Golden margarita and a pint .... Cheers Mate !!!
    Quote Quote  
  7. Member netmask56's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Search Comp PM
    My pleasure! I'll settled for a strong black coffee as a morning heart starter !
    SONY 75" Full array 200Hz LED TV, Yamaha A1070 amp, Zidoo UHD3000, BeyonWiz PVR V2 (Enigma2 clone), Chromecast, Windows 7 Ultimate, QNAP NAS TS851
    Quote Quote  



Similar Threads