VideoHelp Forum


Try StreamFab All-in-One and rip streaming video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. Hi all, I'm trying to use Ffmpeg to apply a Lut and re-encode a file at a lower resolution. This is my command line:

    "C:\mabs\local64\bin-video\ffmpeg.exe" -i "F:\Videos\2021_06_03_Swanage\Beach_run_Orig.m ov" -vf "lut3d=F:\Videos\2021_06_03_Swanage\Beach_run_Inst a360_LUT.cube, scale=1920x1080:flags=lanczos" -c:v libx265 -crf 22 -preset slow -an Beach_run.mov

    [Edit: when I view this on my phone, there are line breaks and a space in mov - obviously that's not there in the real thing]

    Sadly, it has a problem applying the LUT. In case it was the LUT, I tried a 3dl (or whatever) and that didn't work. I'm not at home so can't post the error, but thought I'd post now in case there was something wrong with my command line usage that was obvious. I'll post the error in a follow up, but any help please would be most appreciated.

    Edit: here is the error message:

    [lut3d @ 0000024b736613c0] [Eval @ 000000536c1fe140] Undefined constant or missing '(' in 'Videos2021_06_03_SwanageBeach_run_Insta360_LUT.cu be'
    [lut3d @ 0000024b736613c0] Unable to parse option value "Videos2021_06_03_SwanageBeach_run_Insta360_LUT.cu be"
    [lut3d @ 0000024b736613c0] [Eval @ 000000536c1fe060] Undefined constant or missing '(' in 'Videos2021_06_03_SwanageBeach_run_Insta360_LUT.cu be'
    [lut3d @ 0000024b736613c0] Unable to parse option value "Videos2021_06_03_SwanageBeach_run_Insta360_LUT.cu be"
    [lut3d @ 0000024b736613c0] Error setting option interp to value Videos2021_06_03_SwanageBeach_run_Insta360_LUT.cub e.
    [Parsed_lut3d_0 @ 0000024b72f5e180] Error applying options to the filter.
    [AVFilterGraph @ 0000024b73661c00] Error initializing filter 'lut3d' with args 'F:Videos2021_06_03_SwanageBeach_run_Insta360_LUT. cube'
    Error reinitializing filters!
    Failed to inject frame into filter network: Invalid argument
    Error while processing the decoded data for stream #0:0
    Last edited by jonathancolledge; 6th Jun 2021 at 11:40.
    Quote Quote  
  2. Solved! I needed to escape the : and use forward slahes, and use ' when defining the path for the LUT:

    "C:\mabs\local64\bin-video\ffmpeg.exe" -i "F:\Videos\2021_06_03_Swanage\Beach_run_Orig.m ov" -vf "lut3d='F\:/Videos/2021_06_03_Swanage/Beach_run_Insta360_LUT.cube', scale=1920x1080:flags=lanczos" -c:v libx265 -crf 20 -preset medium -an Beach_run_ffmpeg.mov

    I found it here: https://stackoverflow.com/questions/58659222/ffmpeg-filter-complex-lut-file-path-givin...ems-on-windows
    Quote Quote  



Similar Threads