VideoHelp Forum


Try NordVPN to access Netflix or other streaming services from any country and also surf safely!
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. I have been creating mkv output of PAL VHS 720x576 resolution videos.

    These videos then display as 768x576 in a PC media player, and Oppo Blu-ray, due to the 4:3 aspect ratio flag. So all well and good.

    But some editing programs will produce an output that does not display as 4:3 in a media player.
    See here, a 10 second snip created with mkvmerge, displays as 4:3. And another created with AviDemux, this one defaults to it's native display of 5:4 instead of 4:3.

    https://mega.nz/folder/Gc8wSYzD#s5E15B9M44fRiKVt6gs_Mg

    What is the difference that causes this? I cannot see any difference in mediainfo of both these files that would cause both MPC and Oppo Blu-ray to ignore the 4:3 stretch in the AviDemux version?
    Quote Quote  
  2. Originally Posted by agisthos View Post
    I have been creating mkv output of PAL VHS 720x576 resolution videos.

    But some editing programs will produce an output that does not display as 4:3 in a media player.
    See here, a 10 second snip created with mkvmerge, displays as 4:3. And another created with AviDemux, this one defaults to it's native display of 5:4 instead of 4:3.

    What is the difference that causes this? I cannot see any difference in mediainfo of both these files that would cause both MPC and Oppo Blu-ray to ignore the 4:3 stretch in the AviDemux version?
    720/576=1.25

    You need to set the DAR output container flag in Avidemux before saving.

    You will then get the following line in MediaInfo:
    Display aspect ratio : 4:3
    Quote Quote  
  3. Yes, the DAR 4:3 flag seems to be missing in the avidemux container and the SAR signalling (16:15) of the video stream is ignored. Surprisingly though MediaInfo reports it nevertheless as DisplayAspectRation 4:3.
    Easiest way to fix it would be just to remux the avidemux with mkvmerge and set the DAR correctly, or to force the playback manually as 4:3 on the player.
    Quote Quote  



Similar Threads