VideoHelp Forum


Try NordVPN to access Netflix or other streaming services from any country and also surf safely!
+ Reply to Thread
Results 1 to 21 of 21
Thread
  1. I have dither version 1.28.0

    When I use lsb=true in smdegrain, I get the message as posted in my title.

    But when I look through the text in the autoload script, I do see ditherpost in it.

    Please advise.
    Quote Quote  
  2. Then when I tried to use prefilter 2, I got the error "there is no function named medianblur"

    This is exactly what I was talking about previously. Why do we have to go on wild goose chases to find these dependencies that end up not working
    Quote Quote  
  3. I'm surprised that you couldn't find that info using some internet search engine,..

    I hope this helps:
    Assuming you use Avisynth, you are probably missing some dependencies like:
    a. Dither http://avisynth.nl/index.php/Dither_tools
    b. MedianBlur2 http://avisynth.nl/index.php/MedianBlur2

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  4. Selur,
    What makes you assume that I didnt look online?
    If you carefully read my post, you would see that I already tried dither 1.28.0. But you didn't, obviously, which explains why you post a link for me that leads me right back to dither1.28.0

    And what do you mean "assuming I'm using Avisynth"? I'm speaking about smdegrain and dither--- all Avisynth plugins exclusively. What the hell else do you think I'm talking about, Mento's breath mints?
    Last edited by Betelman; 30th May 2021 at 11:49.
    Quote Quote  
  5. okay,.. (Also there is a Vapoursynth version of SMDeGrain for years,...)
    Avisynth,... so which version of Avisynth? (32/64, mt? Avisynth+?)
    If you have multiple versions of Avisynth installed have you checked which is used? (in example using AVSMeter -avsinfo)
    Have you installed Avisynth system wide or do you use a portable version?
    Also which version of SMDeGrain do you use? This (https://github.com/realfinder/AVS-Stuff/blob/Community/avs%202.5%20and%20up/SMDegrain.avsi ) or an older version?
    If your Avisynth autoloading does not work, have you tried loading the plugins directly?

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  6. I have Avisynth 64 wide, not portable. It is the only one I have in my system. Smdegrain automatically loads fine BUT some of the settings, as I mentioned, do not work and give me errors. I don't know which version of smdegrain I have I'll have to check. Thanks for clarifying.
    Quote Quote  
  7. Using lsb should only be necessary on old Avisynth (without the +).
    When using Avisynth+ with the latest SMDegrain, I get an error: "lsb hack is not Compatible with native high bit depth".
    So I assume you are using an older Avisynth version.

    Which Avisynth version? (call a script with just "version()" in it if you are unsure)
    When using 64bit with:
    Code:
    LoadPlugin("PATH to dither.dll")
    LoadPlugin("PATH to RgTools.dll")
    LoadPlugin("PATH to mvtools2.dll")
    LoadPlugin("PATH to masktools2.dll")
    LoadPlugin("PATH to MedianBlur2.dll")
    Import("PATH to SMDegrain.avsi")
    Import("PATH to Zs_RF_Shared.avsi") # only for newer SMDegrain from https://github.com/realfinder/AVS-Stuff
    SMDegrain with prefilter=2 works fine here (32/64bit Avisynth+ 3.61 r3290)
    I guess those should be fine with older Avisynth versions too, so best check whether it works if you load them explicitly.


    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  8. I have the 2015 Avisynth 2.6.0 32-bit version. So I made a mistake yesterday in terms of my information.

    I have smdegrain 3.1.2 2015 version

    It runs by default settings but if for example I type the following:

    smdegrain(prefilter=2) I get the following error:

    removegrain: invalid mode 20.
    Quote Quote  
  9. removegrain: invalid mode 20.
    -> you are probably using an old RemoveGrain version, nowadays rgtools is used.

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  10. I downloaded all the recent versions of these folders. I now have masktools v. 2.2.26 and now I get the following error:

    there is no function named "mt_makediff"

    By the way just to be clear, I did say I have Avisynth 32 bit. I'm getting my dlls from the 64 folder and not the 86. I'm doing the right thing, yes?
    Last edited by Betelman; 1st Jun 2021 at 09:54.
    Quote Quote  
  11. Originally Posted by Betelman View Post
    By the way just to be clear, I did say I have Avisynth 32 bit. I'm getting my dlls from the 64 folder and not the 86. I'm doing the right thing, yes?
    No. 32 bit AviSynth requires 32 (x86) bit dll files, whether you are running Win32 or win64.
    Quote Quote  
  12. Thanks jagabo. So I updated my plugins folder and downloaded the (x86) bit dll files. Now I get an error that says

    "there is no function named medianblur"
    Quote Quote  
  13. It looks like you're missing 32 bit medianblur2.dll.
    Quote Quote  
  14. Ok so that worked. But now when I choose prefilter=3 I get an error stating that I need some libffw3f-3.dll filter. I put that in my avisynth plugins folder and it doesn't work. Does this DLL need to go elewhere ?
    Quote Quote  
  15. Ok, so I learned that this filter needs to go in the System 32 folder in my C drive. I added it there and refreshed the folder. Now it says that it can't load.
    Quote Quote  
  16. Yes, libffw3f-3.dll is a Windows system dll. It's available to all programs running on Windows. AviSynth filters are only available to AviSynth. As with all libraries you need to have 32 bit versions for 32 bit programs. The 32 bit version of libffw3f-3.dll normally goes in C:\Windows\SysWOW64.
    Quote Quote  
  17. For heaven's sake it finally worked.

    I tell you, going on these wild goose chases for updated dependencies and filters is a real doozy but once you have it, it's a relief.

    I'm going to make a backup of my Avisynth plugins folder in an external hard drive so if I ever have to install it in a new computer, I just copy the plugins folder.

    These wild goose chases are NOT something I want to do twice.

    Thanks everyone.
    Quote Quote  
  18. Yes, I am trying to get McTemporalDenoise and, after adding gradfun2db (version 1.0), I get this error. Can someone please help?
    Thank you.
    Image Attached Thumbnails Click image for larger version

Name:	error.jpg
Views:	14
Size:	48.2 KB
ID:	59447  

    Quote Quote  
  19. Do you have a Crop() in your main script? If so, add align=true to its parameters.
    Quote Quote  
  20. No, but I did have Lanczosresize (640,480) to get my video back to the display aspect ratio (to avoid having the encoder doing it, I rather do it here in a script).

    But a simple switch in the script made MCtemporaldenoise work.

    Thanks!!
    Quote Quote  



Similar Threads