VideoHelp Forum


Try NordVPN to access Netflix or other streaming services from any country and also surf safe!
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Hello all, thanks to PM-S, I have been trying out Hybrid, and in particular, QTGMC for deinterlacing my VHS captures. The image is visibly better, even after conversion to MP4.

    But, after processing, I have noticed quite pronounced colour banding. After a bit of experimentation, it seems to occur with whatever deinterlacing I use with one exception: the early Muksun filter (15Nov2008 version) in 32-bit VDub. With that Muksun, it doesn't exist. I'm just using the defaults because the Muksun filter is in Russian (I think).

    I have replicated this on another tape, different VCR, different capture stick, but haven't resolved what is going on or how to fix it.

    It shows up playing in VDub and VLC player.

    The Muksun deinterlace is on the left, the Hybrid/QTGMC MP4 on the right.

    Image
    [Attachment 58796 - Click to enlarge]


    Source video linked below.

    If anybody could point me in the direction of removing the banding I'd appreciate it.
    Image Attached Files
    Last edited by Alwyn; 10th May 2021 at 08:14. Reason: add VLC player ref.
    Quote Quote  
  2. The 'color banding' is already in the .avi source. When you inspect the fields you will see that the the even and odd fields shift the bands up/down.
    I don't know Muksun, but did you apply same rate or bob (double rate) deinterlacing? Did you capture the tape via composite or S-video?

    It is also not recommended to just blindly always use QTGMC with very slow or even placebo settings btw.
    Last edited by Sharc; 10th May 2021 at 10:38.
    Quote Quote  
  3. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Thanks Sharc, I see that now (using Bobdoubler).

    Unfortunately, it is baked in to most of my tapes I have of the era. I must have had a bad VCR way back then when I compiled all my tapes.

    I don't know Muskun, but did you apply base rate or bob (double rate) deinterlacing?
    I have no idea; the whole filter is in Russian.

    It is also not recommended to just blindly always use QTGMC with very slow or even placebo settings btw.
    The Seeing leading the blind! Lots to see in this business. My eyes are gradually opening.
    Quote Quote  
  4. They mostly cancel out if you blend deinterlace, but the "negative" is blend deinterlacing produces blurry results

    You can try it yourself, tdeint has a double rate blend mode

    Code:
    AVISource("710USB Kempsey short.avi")
    assumetff()
    tdeint(mode=1, type=5, mthreshL=2)

    Or you can combine QTGMC for the Y plane, with blend deinterlacing the U,V planes. Some artifacts still remain in top left corner, so ttempsmooth to smooth them over

    Code:
    orig=AVISource("710USB Kempsey short.avi").converttoyv16(interlaced=true)
    
    t=orig.assumetff().tdeint(mode=1, type=5, mthreshL=2)
    
    q=orig.assumetff().qtgmc()
    
    qy=q.converttoy8()
    tu=t.utoy8()
    tv=t.vtoy8()
    
    CombinePlanes(qy, tu, tv, planes="YUV", source_planes="YYY",  sample_clip=q)
    ConvertToYUY2()
    TTempSmooth(maxr=1, lthresh=10)

    The latter will be noticably sharper, because the Y plane is not blended
    Image Attached Files
    Quote Quote  
  5. It's a combination of HanoverBars and some noise in the cap. Try this:

    Code:
    AviSource("710USB Kempsey short.avi") 
    AssumeTFF()
    MergeChroma(last, Blur(0.0,1.0).Sharpen(0.0, 0.7))
    QTGMC()
    It might lead to blended chroma in some high motion shots though.
    Image Attached Files
    Quote Quote  
  6. Originally Posted by Alwyn View Post

    But, after processing, I have noticed quite pronounced colour banding. After a bit of experimentation, it seems to occur with whatever deinterlacing I use with one exception: the early Muksun filter (15Nov2008 version) in 32-bit VDub. With that Muksun, it doesn't exist. I'm just using the defaults because the Muksun filter is in Russian (I think)..
    Do you have a link to this old version ? If you double rate deinterlace with the 3.5.6 version the problem is still there . If you single rate deinterlace, you throw away /12 the information, but it doesn't flicker as badly because you're only looking at even or odd fields, but the underlying problem is still there
    http://acobw.narod.ru/
    Quote Quote  
  7. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Thanks very much for your inputs, everyone. Those results are great. Poison, yes, the second of yours looks better. It's fascinating to me that such different approaches lead to similar excellent results.

    I will just have to get my head into Avisynth and the big bogeyman QTGMC. I used the derainbow/Bifrost filter in Hybrid with some success, but I can't export any format I want to further edit.

    The bullet will just have to be bitten.

    Poison, here's the 2008 version of the Muksun deinterlacer:

    https://drive.google.com/file/d/1mR0nPJ8CK0axn-GWZVsmgC0X0s78hSBX/view?usp=sharing
    Quote Quote  
  8. It looks to me like the Muksin deinterlacer does single rate deinterlacing with some kind of field blending (threshold as parameter). The fields blending would explain why the color bands are less visible.
    Has it possibly been designed to compensate the PAL Hanover effect in mind, e.g. by repeating the chroma information from each previous line, and blending it with the current line?
    Last edited by Sharc; 11th May 2021 at 05:06.
    Quote Quote  
  9. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    I put the last part of Jabago's script into Hybrid to run before QTGMC and got the same great result; I exported to FFV1 for my editor.

    Code:
    MergeChroma(last, Blur(0.0,1.0).Sharpen(0.0, 0.7))
    Thank you all for your input.
    Quote Quote  



Similar Threads