VideoHelp Forum


Try StreamFab All-in-One and rip streaming video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 16 of 16
Thread
  1. Member
    Join Date
    Jan 2021
    Location
    PAL
    Search PM
    QTGMC is best deinterlacing algorithm i know, but not many people know how to use avisynth. that's the reason im making this.

    1. Install Hybrid
    2. Insert your footage into the program (by dragging it to the first textbox or selecting it with the icon next to it)
    2.5. select passthrought all on audio dropdown menu
    3. go to x264 tab. on the bitrate (kbit/s) change it to at least 7000 for standard definition video or 18000 - 20000 for 1080px or 13000 for 720px
    4. go to the filtering tab and "Deinterlace/telecine" sub-tab
    5. be sure "use" is selected and "qtgmc" is chosen
    6. change preset to "very slow" or placebo.
    7. if you want the double framerate (50fps as opposed to 25fps, for example) also check "bob"
    8. go back to the first base tab and after default container choose the output place
    9. click the man with shovel and wait from all green lines to complete
    10. thats it
    Quote Quote  
  2. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    That's a nice qwik-start.
    Please note: on my system Lagareth codec was not being recognized to properly BOB the video from 60i to 60P.
    Please note: I get choppy stuttery video unless I tick LIBAV video source.
    Your results may differ.
    Quote Quote  
  3. Thanks so much for doing this! One question. If I want to double framerate you say about selecting Bob. I assume what you are saying here is to use other software to double the framerate after using Hybrid, or does Hybrid do it too?

    I found the answer and just came across this video which explains how to do it:- https://www.youtube.com/watch?v=-uihfyMxuHs
    Last edited by magnu; 9th May 2021 at 22:07. Reason: Found the answer to my question
    Quote Quote  
  4. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    Hybrid does it all.
    Quote Quote  
  5. The settings in the video would be different obviously when combining those two conversions, or should they be done separately?
    Quote Quote  
  6. Two quick questions:-

    To change the Framerate, etc., I need to change the Support Setting from VapourSynth to AviSynth. When I do this it doesn't do Deinterlacing. Is there any way I can do all in one?

    Does Hybrid have a Save Settings type of option?
    Last edited by magnu; 10th May 2021 at 00:15.
    Quote Quote  
  7. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Using Hybrid version 2021.04.12.1

    My video (a LAGS interlaced AVI from a Vdub VHS capture) is coming out Interlaced. It seems as though QTGMC isn't running, because my processing speed is much faster than I expected. I'm getting around 25fps processing time whereas I was expecting around 5fps at the most.

    Mediainfo is saying my Hybrid output is progressive but opening it in VDub definitely shows it's interlaced, and applying a deinterlace filter removes the jaggies.

    Here are my settings:

    Image
    [Attachment 58789 - Click to enlarge]


    Image
    [Attachment 58790 - Click to enlarge]


    Image
    [Attachment 58791 - Click to enlarge]


    My VHS capture audio is PCM so I had to set the audio to "Custom" on the Base page, then this on the audio tab:
    Image
    [Attachment 58792 - Click to enlarge]


    Output is Interlaced. Any corrections to what I've set would be gratefully accepted.
    Last edited by Alwyn; 10th May 2021 at 01:25. Reason: source AVI info, Hybrid version added
    Quote Quote  
  8. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    I then gave it a progressive AVI (deinterlaced with VDub; definitely no jaggies) and Hybrid says it is Bottom Field First when I click the ? mark next to "QTGMC (Vapoursmith)".
    Quote Quote  
  9. Member
    Join Date
    Jan 2021
    Location
    PAL
    Search PM
    Originally Posted by magnu View Post
    Thanks so much for doing this! One question. If I want to double framerate you say about selecting Bob. I assume what you are saying here is to use other software to double the framerate after using Hybrid, or does Hybrid do it too?

    I found the answer and just came across this video which explains how to do it:- https://www.youtube.com/watch?v=-uihfyMxuHs

    no thats frame intrepolation, and it tries to predict nonexistent frames.

    see, bob uses both fields and gives the footage its original high framerate.
    normal setting deletes every odd (or even) frame.

    this is how the easiest type of bob works https://www.100fps.com/why_bobbing.htm giving 288p50 footage

    QTGMC is way more advanced. what it does is it uses odd fields to predict even ones (or vice versa), and it gives near perfect full resolution output.
    Quote Quote  
  10. Member
    Join Date
    Jan 2021
    Location
    PAL
    Search PM
    Originally Posted by Alwyn View Post
    Using Hybrid version 2021.04.12.1

    My video (a LAGS interlaced AVI from a Vdub VHS capture) is coming out Interlaced. It seems as though QTGMC isn't running, because my processing speed is much faster than I expected. I'm getting around 25fps processing time whereas I was expecting around 5fps at the most.

    Mediainfo is saying my Hybrid output is progressive but opening it in VDub definitely shows it's interlaced, and applying a deinterlace filter removes the jaggies.

    Here are my settings:

    Image
    [Attachment 58789 - Click to enlarge]


    Image
    [Attachment 58790 - Click to enlarge]


    Image
    [Attachment 58791 - Click to enlarge]


    My VHS capture audio is PCM so I had to set the audio to "Custom" on the Base page, then this on the audio tab:
    Image
    [Attachment 58792 - Click to enlarge]


    Output is Interlaced. Any corrections to what I've set would be gratefully accepted.

    probably your capture card problem

    try setting sensitivity to 100 it may help with interlaced videos save progresive
    Quote Quote  
  11. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Originally Posted by PM-S
    try setting sensitivity to 100 it may help with interlaced videos save progresive
    Didn't work, Hybrid is encoding into MP4 but not QTGMCing.

    What codecs (video and audio) are your files that you are using in Hybrid?
    Quote Quote  
  12. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    Originally Posted by PM-S
    5. be sure "use" is selected and "qtgmc" is chosen
    Out of interest, exactly what does your dropdown say here? Mine says "QTGMC (Vapoursynth)".
    Quote Quote  
  13. Member
    Join Date
    Oct 2018
    Location
    Gillette Stadium, United States
    Search Comp PM
    You will see in image 58791 the input and output frame rate is the same. Output should be twice the input for bobbing.
    Quote Quote  
  14. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    probably your capture card problem
    No.

    On the Deinterlacing tab, bottom right, one must set "Avisynth" from the "Support:" dropdown (the defualt is Vapoursynth)

    and then back up to top left, choose "QTGMC (Avisynth)" from the dropdown.

    Then it works.

    Also, I set the field order on the Filtering tab (top right): my VHS AVIs were being analysed as Progressive ("Input scan type:") when in fact they are TFF (I assume everybody else's VHS captures are as well), which I set in the drop-down below.

    Thanks for getting me going with this though; I really struggle with Avisynth. The image quality is great but there is an ugly colourisation which I'll post about in a new thread.

    You will see in image 58791 the input and output frame rate is the same. Output should be twice the input for bobbing.
    That ties in with the scan type issue above; leave it on Progressive and you'll get 25 with bob. Change it to TFF you'll get 50 with Bob.
    Quote Quote  
  15. Mediainfo is saying my Hybrid output is progressive but opening it in VDub definitely shows it's interlaced, and applying a deinterlace filter removes the jaggies.
    Hybrid won't apply deinterlacing/ivtc-filters if the input scan type is progressive.
    If your content isn't properly flagged i.e. when it's flagged as progressive, but really is interlaced you should overwrite the detected scan type (Filtering->(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to') to the proper value.


    Does Hybrid have a Save Settings type of option?
    -> [INFO] About profiles and saving settings,....

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  16. Member
    Join Date
    May 2005
    Location
    Australia
    Search Comp PM
    If your content isn't properly flagged i.e. when it's flagged as progressive, but really is interlaced you should overwrite the detected scan type (Filtering->(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to') to the proper value.
    I then remembered a post where Jagabo explained how to use the Bobdoubler filter in VDub to work out the interlacing. All my Lagarith VHS captures are TFF so I set that.

    Thanks for Hybrid, Selur! I'll make a donation.
    Quote Quote  



Similar Threads