VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 23 of 23
Thread
  1. I originally posted this on the Handbrake Forums, but as yet no one has replied to me at all. I REALLY need help.

    I've been successfully using Handbrake to re-encode MKV source files into MP4 files for playback on my TV, using a WD 2.5" USB drive connected to said TV by a Gen 1 WDTV player for the last 2 years. Itís not the WDTV Live Ė but the original WDTV media player, that just plays files from USB drives. Typically, the source files are TV shows or movie downloads. My output files have never had any playback problems until now. Ever since having a new laptop in January this year (old one died), all my HB output files have very noticeable judder during panning scenes when played back on TV via WDTV Player - but barely noticeable or even no judder when played back on the laptop.

    This week, I played multiple files on the WDTV player that were re-encoded using my old laptop, and those are playing perfectly with no judder. This only seems to be happening on things re-encoded since getting the new laptop, which is odd. Suggests something different about how this laptop handles the encoding software.

    I've also swapped out the USB cable, HDMI cable, 2.5" hard drive and even swapped the WDTV player for my spare WDTV player - the problem is still happening only with the new laptop re-encodes. So, it doesn't appear to be a sudden fault with the WDTV player if it's playing previous re-encodes without a problem, and the same thing is happening on both my primary and my spare WDTV units. If it was a general WDTV problem, Iíd expect it to be juddering on all my previously re-encoded files as well, but itís not.

    My usual Handbrake settings have always been the following, and I've always had smooth playback:

    Filters - Detelecine = Default, Interlace Detection = Default, Deinterlace = Decomb, Preset = Default, Denoise Sharpen & Deblock all off.
    Video - Codec = H.264(x264), Framerate = Same As Source & Variable, CQRF 20, Encoder Preset = Medium, Encode Tune = None, Encode Profile = Main, Encoder Level = 4.0. (The max my WDTV can support is High & Level 4.1).

    Here are the different changes to Handbrake settings I've tried:

    1) Detelecine & Interlace Detection = Off (result worse judder)
    2) Detelecine = Default, Interlace Detection = Off
    3) Detelecine = Off, Interlace Detection = Default, Deinterlace = Decomb, Preset = Default
    4) Detelecine = Default, Interlace detection = Fast, Deinterlace = Decomb, Preset = Default
    5) Detelecine = Default, Interlace detection = Less Sensitive, Deinterlace = Decomb, Preset = Default
    6) Detelecine = Default, Interlace Detection = Default, Deinterlace = Yadif, Preset Bob (Items 2-6 all have the same judder)
    7) Changed Framerate from Variable to Constant as MediaInfo showed the source file was Constant (worse judder)
    8) Changed Framerate from Variable to 23.976 Peak Frame rate as that was listed as the FR of the source file in MediaInfo too. (Same judder). Granted, I don't understand the rest of what I'm looking at in MediaInfo or the activity logs, so I've been unable to use those to help myself further.
    9) Changed Encoder Preset from Medium to Slow (same judder)
    10) Changed Encoder tune from None to Film (very blocky picture and judder)
    11) Changed Encoder Profile from Main to High and Level from 4.0 to 4.01 (same judder).
    12) Used different source files from different TV shows - 911 S04E01 & the Doctor Who New Year Special instead of the whole of Mandalorian season 2. (same judder).
    13) Used the General Preset Fast1080p30 with no modifications instead of my custom preset that always worked before (worse judder).
    14) Changed the Priority level of HB from below normal to low, then to normal, then to above normal. Still same problem.
    15) Uninstalling Handbrake, rebooting and reinstalling Handbrake. Still same.
    16) Tried different Encoders - Any Video Converter with both default settings and my customs & VidCoder Ė with both default settings and my customs. Both are producing the same juddery output files as Handbrake.

    I've not changed any of my other equipment. Still using the same TV and WDTV player I'd used in the last 2 years without incident. The only hardware change is this laptop, which is a Dell Inspiron i5, whereas my other laptop was a Toshiba Dynabook i7.

    Handbrake version: Originally 1.2.2, but updated to 1.3.3 in the last few days. Still having the same problem on HB 1.3.3

    My new laptop is fully up to date with all Windows updates.

    Iíve spent the last month doing Google searches and trying to read and follow any suggestions that look like they might help. Iím not very technical, so some things go way over my head. That said, Iíve been successfully using Handbrake for the last 2 years without issue until I got a new laptop.

    I've attached 2 of the many Handbrake Activity Log files in the hopes they will help.

    PLEASE help me. I've done everything I can think of, short of a full Windows re-install. That's my last option if I can't figure out how to fix this.
    Quote Quote  
  2. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Another thing to try is Avidemux; just remux the streams into mp4 - set the Output Format (lower left) to "mp4 muxer"

    Otherwise post a short clip from your source, up to 30 seconds, something showing steady movement
    Quote Quote  
  3. Originally Posted by davexnet View Post
    Another thing to try is Avidemux; just remux the streams into mp4 - set the Output Format (lower left) to "mp4 muxer"

    Otherwise post a short clip from your source, up to 30 seconds, something showing steady movement
    Thanks for the reply!

    I just installed AVIdemux but unfortunately, that is giving me the same judder. I've attached the 30-second source clip showing no noticeable judder.
    Quote Quote  
  4. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    That source file is 10 bit, Hevc & E-ac/3 audio.

    What is the spec of the files that play successfully in your setup?
    Post the mediainfo (text view) of a good, working file

    Dies this work?
    Image Attached Files
    Last edited by davexnet; 16th Feb 2021 at 21:28.
    Quote Quote  
  5. The source is already 24p. There's no need for any detelecine, deinteralce. The output from Handbrake is no different than the source in terms of judder. You do realize that 24p doesn't give glassy smooth motion in panning shots, right? Handbrake x264 encoding attached.
    Image Attached Files
    Last edited by jagabo; 16th Feb 2021 at 21:46.
    Quote Quote  
  6. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by jagabo View Post
    The source is already 24p. There's no need for any detelecine, deinteralce. The output from Handbrake is no different than the source in terms of judder. You do realize that 24p doesn't give glassy smooth motion in panning shots, right?
    My TV has a setting to turn 24fps into 48 called "real cinema". I always have it turned off, it looks unnatural to me.
    Just watching as it is, with no fancy TV processing looks perfectly acceptable, as did the OP's HEVC source,
    and my TV is over three years old.
    Quote Quote  
  7. I even compared the source video and my handbrake encoding frame by frame (with an AviSynth script) and the two were identical aside from the cropping and compression artifacts.
    Quote Quote  
  8. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Handbrake/vidcoder seems to produce a VBR file when mp4 is selected, even when the source is CBR.
    In practice, it's such a small variation, I've never seen any noticeable judder from it.
    Code:
    Frame rate mode                          : Variable
    Frame rate                               : 23.976 FPS
    Minimum frame rate                       : 23.974 FPS
    Maximum frame rate                       : 23.981 FPS
    Quote Quote  
  9. Originally Posted by davexnet View Post
    That source file is 10 bit, Hevc & E-ac/3 audio.

    What is the spec of the files that play successfully in your setup?
    Post the mediainfo (text view) of a good, working file

    Dies this work?
    The file you sent plays on the WDTV, but it's got the same judder I've been experiencing. I've attached the MediaInfo file for Mandalorian S01E01, which was re-encoded from H.265 to H.264 with Handbrake on my old laptop. This file still plays fine with no judder on the WDTV, I watched season 1 the other day because I was trying to see if the WDTV was also having the judder issue on old re-encodes - it isn't. Only recent ones.

    The WDTV player doesn't play any video that is H.265, so I have to convert any H.265 files to H.264. It does play AVI, DivX, XVID, MPeg 4, MP4. For audio - it plays everything except any kind of Dolby. So, if I want to play a recent H.265 download with Dolby audio, I need to re-encode to H.264 with AAC audio.

    I've had this player for years, used to exclusively play AVI files on it. But decided to start swapping my vast collection over to H.264 MP4 files 2 years ago. Everything I encoded on the Toshiba still plays with no judder on the WDTV.
    Quote Quote  
  10. Originally Posted by jagabo View Post
    The source is already 24p. There's no need for any detelecine, deinteralce. The output from Handbrake is no different than the source in terms of judder. You do realize that 24p doesn't give glassy smooth motion in panning shots, right? Handbrake x264 encoding attached.
    I do know it's not completely smooth, but any minute judder I previously had was barely noticeable, so I was ok with it. This is significantly worse, looking at it makes me feel like I should be swaying on a bar stool somewhere.

    The file you attached plays on my WDTV, but I get the same judder. It's without judder on my laptop. Suggesting a WDTV problem, but what I don't understand - is if it's the WDTV that's the problem, why is it only doing this on files I re-encode on my current laptop and not the files from my old laptop? It's weird, right? I would have thought it would happen on both if it's the WDTV that's knackered.

    At this point I'm wondering if I should just get a new HDMI media player, one that plays both H.264 & H.265, which would then remove the need for me to re-encode and I could just play the files as they are (hopefully without judders). I think I might also just do the Windows reinstall in a day or so, just in case there's something wrong with any windows files that Handbrake relies on to do whatever it does. At least that will rule out a possible Windows corruption issue. I'm just mega-frustrated trying to figure this out.
    Quote Quote  
  11. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    I would suggest looking at mediainfo text report and very carefully compare the good and bad files details
    Quote Quote  
  12. Originally Posted by davexnet View Post
    I would suggest looking at mediainfo text report and very carefully compare the good and bad files details
    The problem there, is that I unfortunately don't understand what I'm looking at in the MediaInfo or Handbrake Activity logs, this is where my significant lack of technical knowhow has stopped me going any further. Can't understand the logs that might have otherwise been able to give me a clue. I wasn't kidding about not being very technical!!

    If anyone would like to compare the MediaInfo details for me (you don't have to if you don't want to, I'm not expecting anything - I'm honestly so grateful that people have tried to help me at all), I've attached the MediaInfo for Mandalorian S02E01, both the original source file and my re-encode that plays with juddery picture on the WDTV.

    In the meantime, I've convinced my mum to let me borrow her desktop PC either today or tomorrow so I can install Handbrake and try another re-encode on it, to see whether the problem might be my laptop. That's another thing I can check off the list then.
    Quote Quote  
  13. Update: The re-encode from my mum's computer plays with the same judder on the WDTV.

    I feel like that rules out my laptop as the cause and puts the suspicion back on the WDTV player - I guess it's had it's day, it is 13 years old after all. A literal fossil by technological standards. I managed to find a HDMI media player on Amazon that other people who've bought it say it plays both H.264 & H.265, and that it does play from a 4TB HDD, which is what my drives are. I've ordered it, hopefully that will play the files I have and mean I won't need to screw around converting files anymore. Fingers crossed it works as advertised, because my luck lately sucks so much lol

    I want to say a big THANK YOU to everyone who weighed in to help, I truly appreciate it regardless of whether or not we solved the problem. It's that you were kind enough to try, that means the world to someone like me, who doesn't receive much kindness from others. So THANK YOU everyone!
    Quote Quote  
  14. You are playing a 24p video on a 50p TV? Depending on how the frame rate conversion is done it will jerk once or twice per second. Maybe all the other conversions you have done have been 25p or 50p sources? A 25p version is attached (PAL speedup, no audio).
    Image Attached Files
    Last edited by jagabo; 17th Feb 2021 at 08:12.
    Quote Quote  
  15. Another possible issue using Handbrake: when saving 23.976 material as MP4 Handbrake always creates a variable frame rate video. This is because it uses a time base of 1/90000 seconds. 24000/1001 can't be perfectly represented as an integer/90000 (it's 3753.75/90000) so Handbrake saves the video as variable frame rate, alternating between one frame at 3753/90000 and three frames at 3754/90000. In the long run it averages out to the correct frame rate. Maybe your player doesn't like that VFR encoding?
    Quote Quote  
  16. Jagabo - I think you cracked it. That 25p file plays with almost zero judder, the tiny little bit of judder that is left is barely noticeable! How on earth did you do it?? And how do I replicate that in future?

    I'm not sure if my TV is 50p or not. I'm a real idiot when it comes to things like that. I dug out the little user manual that came with the TV, and it only gave me very scant info about it's specs: Samsung LE32A456C2D 32" LCD TV 1360 x 768 @ 60 Hz. I did a Google search for the model number and found some more specs, which I've attached along with a pic of the WDTV specs from the side of the box. I understood the bits about the WDTV supported formats at the top, but that smaller print with all the numbers in, I never really understood. All I knew was that the set-up I had worked for years until recently, and I never looked into it further. That's on me.

    I've gone into the settings on the WDTV player itself and fiddled around with the list of Display resolutions I saw this afternoon (never been into the settings menus in all these years!); So far none of them (1080i 50Hz, 1080i 60Hz, 1080p 23.976Hz, 1080p 24Hz, 1080p 50Hz, 1080p 60Hz, 720p 50Hz, 720p 60Hz) have given me a picture anywhere close to yours. I just put it bsck to Auto, which is it's original factory setting. I'm guessing this is something I'd need to do on Handbrake rather than WDTV.

    Out of curiosity, I looked at the MediaInfo for the 25p clip and noticed it says Framerate Mode Constant, Framerate 25.000 FPS. Everything else is over my head. I had tried changing Framerate mode to Constant before, but never tried with 25.000 - FPS, I'd used 23.976 FPS as that was what the source file showed. Looks like I didn't take the thought far enough before moving on to something else. I felt like it might have been Framerate related but I didn't have enough knowledge to follow that to it's resolution.

    Why is 25.000 FPS the magic number for this file? I won't be the slightest bit offended if you explain it like I'm 5, I probably need it!! Thank you for all your help so far by the way, it's very much appreciated.
    Image Attached Thumbnails Click image for larger version

Name:	WDTV Specs.jpg
Views:	8
Size:	2.80 MB
ID:	57430  

    Image Attached Files
    Quote Quote  
  17. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    I'm surprised native 50HZ TV's didn't find a way to better display 24 fps material, after all, it's quite common now.
    I can see some judder if I play 25fps material on my US based TV (60Hz), but it's so minor it doesn't bother me

    The old PAL system 25 fps fit's evenly into 50 fps, the frames are simply doubled - no judder since it's even
    Quote Quote  
  18. Try these two videos. Both are 23.976 fps CRF. "veryfast" is easier to decompress than "slow" -- maybe the WDTV is having problems with the latter.
    Image Attached Files
    Quote Quote  
  19. Originally Posted by jagabo View Post
    Try these two videos. Both are 23.976 fps CRF. "veryfast" is easier to decompress than "slow" -- maybe the WDTV is having problems with the latter.
    Both of those played smoothly, the slow one was ever so slightly smoother, barely noticeable. Armed with this new information, I ran some tests with the same 30 second source file clip I took the other day using these settings:

    "Medium" 1) Constant, Same as Source. 2) Constant, 23.976 FPS. 3) Constant, 24 FPS. 4) Constant, 25 FPS.
    "Fast" - 1) Constant, Same as Source. 2) Constant, 23.976 FPS. 3) Constant, 24 FPS. 4) Constant, 25 FPS.
    "Faster" - 1) Constant, Same as Source. 2) Constant, 23.976 FPS. 3) Constant, 24 FPS. 4) Constant, 25 FPS.
    "Very Fast" - 1) Constant, Same as Source. 2) Constant, 23.976 FPS. 3) Constant, 24 FPS. 4) Constant, 25 FPS.

    MP4 container = every single one had very noticeable judder.

    MKV container = results were much better (below, 'X' means too much judder. ' Y' means no noticeable judder):

    "Medium" - 1) Constant, Same as Source = Very minor. 2) Constant, 23.976 FPS = Very minor. 3) Constant, 24 FPS = Y. 4) Constant, 25 FPS = X.
    "Fast" - 1) Constant, Same as Source = Very minor. 2) Constant, 23.976 FPS = Very minor. 3) Constant, 24 FPS = Y. 4) Constant, 25 FPS = X.
    "Faster" - 1) Constant, Same as Source = Y. 2) Constant, 23.976 FPS = Y. 3) Constant, 24 FPS = Barely noticeable. 4) Constant, 25 FPS = X.
    "Very Fast" - 1) Constant, Same as Source = Y. 2) Constant, 23.976 FPS = Y. 3) Constant, 24 FPS = Barely noticeable. 4) Constant, 25 FPS = X.

    Out of curiosity, I ran MKV > Variable > Same as Source on the source clip at Medium, Fast, Faster & Very Fast as well. There's a barely detectable difference on WDTV between MKV Variable Same as Source & MKV Constant Same as Source; of the two, the Constant gives the better result.

    From the tests, I'm concluding that WDTV prefers 1) MKV to MP4 for smoother playback. 2) "Faster" or "Very Fast" rather than "Medium". I personally find "Slow" too slow for my liking, so I don't use it except with one of my own DVD sources. 3) This source file at either 23.976 or Same as Source (both look the same to me). I only used MP4 so I could play the files on my iPad as it doesn't like MKV - though I could probably get around that if I used VLC player on the iPad so I could play any file format. Note to self: Test that at a later date.

    Questions I now have going forward:
    1) Is it possible to have a standard setting I can use on most files, except maybe ones that don't respond well to it?
    Perhaps - MKV > Fast or Very Fast (either work for me) > Constant Framerate > Same as Source?
    Or could/should I use MKV > Fast or Very Fast > Constant Framerate > FPS 23.976 - since I now know the WDTV likes that FPS? At least on this source file.
    2) Or does the FPS need changing depending on the source file FPS? Like, if a source file has FPS of say 25 - I know from today's tests that WDTV player hates 25 FPS as all the 25 FPS tests I did were juddery regardless of container or Constant/Variable or Medium/Fast/Faster/Very Fast (at least on this source).
    3) Is it stupid to assume WDTV hates 25 FPS on *any* file, based on how it reacted to the multiple 25 FPS tests on this same source clip? Or is it not safe to assume it will handle other source file clips, say - from different tv shows - with a 25 FPS the same way it handled this clip at 25 FPS? I'm trying to get it straight in my head whether this player treats all source files with the same FPS the same way. Or will this player treat different source files with the same FPS differently - is that even a thing?
    4) Can one brand/model of player react badly to a specific FPS, but another brand/model of player have no problems with files at that same FPS? Sorry if these are dumb questions, I want to better understand what the results of my tests might mean for re-encoding & playback of other files on this same player, or on another player entirely in the future, since no player lasts forever. Don't want to be trying to compare apples and oranges and then wondering why things don't make sense to me.

    One good thing has come out of this tech-induced headache; I'm learning some stuff I didn't know before. Like how to cut a sample from a larger source file to make it much easier/faster to run repeated tests like this. And that my fossil-like WDTV player is one ornery MF!! I'm beginning to think it's a good thing I have a new HDMI player on the way, that might hopefully be less fussy about what it will or won't play. Guess we'll see, but at least if I'm gaining a better understanding of the interaction between players and FPS, it might mean I can compensate for similar problems with players in the future.
    Quote Quote  
  20. It's not true that your WDTV hates 25p -- the 25p video (not made by handbrake) in post #4 played smoothly for you. I think you have two issues. First, when encoding 23.976 (or 29.97 or 59.94) fps video with Handbrake it produces variable frame rate MP4 files even if you select constant frame rate. I explained why that is in post #15. Second, when you convert the frame rate from 24 to 25 fps in Handbrake it does so by repeating one frame out of every 24. It then creates a CFR MP4 (because 90000 is evenly divisible by 25) but that extra frame produces a little jerk every second. So your solution is just to keep the original frame rate and use MKV rather than MP4.

    My 25p video was made by speeding up the video and audio in AviSynth. Instead of displaying every frame for 1/24 second every frame is displayed for 1/25 second. That makes the video run about 4 percent faster. So the audio has to be sped up too.

    Regarding the x264 presets: use the slowest preset you can stand -- because image quality is better with the slower presets. There shouldn't be much difference in motion smoothness unless your player is struggling with the more difficult decompression of the slower presets.

    The new Google Chromecast with Google TV is a very good media player (using Kodi) if you can access all your videos via a network share (NAS).
    Last edited by jagabo; 18th Feb 2021 at 08:36.
    Quote Quote  
  21. That explains the judder. The new HDMI player arrived and I've spent the last few hours playing around with it. It's playing all the different files I have with no problem, including the files the WDTV had trouble with. All this time I had been blaming the new laptop, turned out to be a very finicky WDTV player instead. I will have the greatest of pleasure getting rid of it.

    Thank you guys for your assistance in helping me to understand what was happening. It's truly appreciated. You're all amazing. <3
    Quote Quote  
  22. Originally Posted by MoonlightsMuse View Post
    turned out to be a very finicky WDTV player instead. I will have the greatest of pleasure getting rid of it.
    I used a WDTV Live several years ago. It was a pretty good player in its day. I know a few users here still use them. Someone might be willing to take it off you hands...
    Quote Quote  
  23. It's not even a WDTV Live, I kinda wished it had been. It's just the original WDTV Media Player - 1st generation I bought 13 years ago. I have one I bought when I was in the US on vacation, and one UK version I got second-hand from eBay. All they both do is play content from USB drives and nothing else. I can't imagine why someone would want them, especially given how fussy they've both been now about what they will and won't play, video-wise. Plus, I can't really go out to the Post Office to send it anywhere (and I don't have a printer to print labels at home) given the COVID situation, I'm immunocompromised and live with an elderly immunocompromised person on the shielding list. The whole house is effectively shielding, isolating to protect her. The WDTVs will sit in a corner somewhere until I can safely go out to recycle the damn things.
    Quote Quote  



Similar Threads