VideoHelp Forum

Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 5 of 5
  1. I hope someone can help me with this problem:
    I have bought a Supercast X 4K capture card a few month ago and I'm struggling to get a decent picture quality with it.

    Sometimes the card works just fine, but most of the time I am getting a weird "vertical interlace" effect on all my recordings. This can be also be seen live in any capture software.
    I've uploaded a short clip to demonstrate this problem.

    Is there any way to say what is causing this problem? This is what I have done so far. Nothing seems to work:
    • Tried different capture software (Skycap, OBS, Potplayer)
    • Tried different capture settings
    • Reinstalled drivers and software
    • Booted from a freshly installed Windows 10 from another hard disk
    • Tried different devices to capture from (Raspberry Pi, Laptop, camera, PSTV, Switch, FTV etc.)
    • Tried different HDMI cables
    • Added an HD Fury Integral to my setup
    • Changed almost all other hardware in my PC. (Not because of this error, I've built a new gaming rig) = CPU, GPU, mainboard, RAM, power supply
    • Completely turned off all other electronic devices in the same room to get rid of any kind of interferences
    • Restarted PC/connected devices

    I start to believe that the capture card might be defective, but sometimes it works several days in a row for many hours at a time without any problems.

    The Supercast support is either unable or unwilling to help me as all my requests have been ignored since weeks.
    Image Attached Files
    Quote Quote  
  2. I don't know how your video got this way but if you rotate it 90 degrees, swap pairs of scan lines, then rotate it back to normal the video is fixed. In AviSynth:

    LWLibavVideoSource("0118_H17M51_HDMI.mkv", cache=false, prefer_hw=2) 
    src = last
    MergeChroma(last, src)
    [Attachment 57089 - Click to enlarge]

    Swapped fields like that aren't unusual with some video capture devices. Are you running a monitor in portrait mode? Are you using an MJPEG codec anywhere?
    Image Attached Files
    Last edited by jagabo; 31st Jan 2021 at 18:53.
    Quote Quote  
  3. First of all: Thanks for these avisynth commands! Since I'm editing / re-encoding most of my recordings with Staxrip anyways, I can easily use these commands.
    I've tried something similar before, but I wasn't that successful with it.

    Of course, it would be better to fix the problem altogether.

    I am not using a monitor in portrait mode. I have two monitors in landscape mode, one TV (landscape mode) plus a VR headset connected to my PC. I have disconnected my secondary monitor, TV and VR headset from their power supplies and still got that error.

    However, I did not disconnect the corresponding HDMI/DP-cables from my PC yet. I will do so, so I can rule these out, at least.

    No, I am not using an MJPEG codec. On a clean installation of Windows 10, I have only one codec package installed. The one that comes with the software of my capture card. It is called "libde256 Filters 0.2".

    I'm not sure if this can cause this problem somehow.
    Quote Quote  
  4. Yes, it would be best if you could avoid the problem altogether. I mentioned MJPEG codecs because many years ago, when MJPEG was a popular option, there where a few capture cards that stored the fields in the wrong order. So many MJPEG codecs have a "swap field" option. So that could be a cause of the problem (but only if you were rotating the video 90 degrees before encoding with MJPEG). Check the libde265 encoder/decoders settings for a swap fields option. Again that would require that somewhere along the line the video was rotated 90 degrees. If you're encoding progressive video be sure not to enable interlaced encoding in the codec. Does that library use the GPU for encoding? Maybe the problem is in the GPU driver?
    Quote Quote  
  5. The libde256 filters install the LAV Video Decoder 0.65.0. It has a field order option, but is apparently not used by the card for preview/recording. Regarding to the manual of the capture card the live preview is processed as it is without any compression, so it doesn't use any decoder settings. For recordings NVIDIA HEVC Encoder MFT is used as Codec (no setting for field order/swap field).

    The capture card requires an Nvidia GeForce GTX 650 or above to work, so I think it relies on some Nvidia exclusive feature for capturing. The problem could well be caused by the GPU driver.
    However, reinstalling the most recent drivers is of no use. I use an RTX 3070 and previously had a GTX 1070, both with the same problem.

    Since it does work with the same settings sometimes and sometimes it does not, it is probably not caused by a wrong setting. Probably more of an error/bug in the driver of the capture card/GPU.
    Quote Quote  

Similar Threads