VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 31
Thread
  1. Dear Community,


    Thank you for your attention!

    I have been trying to export h264 1920x1080 files muxed with AAC 160bits stereo audio on a .TS encapsulation from Adobe Media Encoder 2020 with no avail.
    I am able to export them separately on the H264 Blu Ray preset, getting audio as AAC and video as M4V.

    However, when I try to mux them on a third party program, such as tsmuxer, the mux rate of 8000kbps doesn't work and it keeps giving me a lot of errors VBV errors:
    VBV buffer overflow at position 115.086 sec

    When I dont specify the 8000 Max Overall Bitrate, it works fine, but the end file gets me a 35.5mb/s max overall bitrate, which my client doesn't accept.

    Can you please help?


    Thanks again!
    Quote Quote  
  2. What's the video bitrate?
    Why 8000 kbps/max? The BR max bitrate for AVC is 100 Mbps.
    Quote Quote  
  3. Thank you for the quick reply!!
    The video bitrate is h264 6000 CBR and the audio is 160kbps AAC.
    Quote Quote  
  4. To answer the second question: this is a format requested by the client.
    They use a VOD platform for TVs and it requires TS files with a total mux bitrate total max of 8000. It is not blu-ray i am afraid
    Quote Quote  
  5. Try to mux them with my clever FFmpeg-GUI to ts.
    Quote Quote  
  6. Dear ProWo, thanks for the quick answer!
    I downloaded the clever prog and the required ffmpeg files.
    I opened my .m4v video file and .aac audio file at the MULTIPLEX option and set a output file.

    Two questions:
    1) Unlike the tsmuxer, there is no option for a max overall bitrate
    2) Whenever I press multiplex, after 2 seconds of processing, it gives me a 2kb .ts file which doesnt play.
    Quote Quote  
  7. Originally Posted by dogmydog View Post
    Dear ProWo, thanks for the quick answer!
    I downloaded the clever prog and the required ffmpeg files.
    I opened my .m4v video file and .aac audio file at the MULTIPLEX option and set a output file.

    Two questions:
    1) Unlike the tsmuxer, there is no option for a max overall bitrate
    2) Whenever I press multiplex, after 2 seconds of processing, it gives me a 2kb .ts file which doesnt play.
    1) That's right, because the muxed bitrate it video bitrate+audio bitrate + overhead; nothing to set.
    2) Rename the .m4v to .mp4 and retry
    Quote Quote  
  8. Thanks for the prompt response!
    I really appreciate this.

    I tried to rename it to mp4 but still didn't work. Processing time instantaneously, a popup named DONE! and 6kb TS file
    Also tried to export to m2ts and got same results.
    Quote Quote  
  9. On start choose your m4v videostream as source, After the analysis the stream is shown properly?
    Quote Quote  
  10. You're right, I guess there is something wrong with the m4v files.


    I tried reencoding as CBR 6,000 and gonna try again!
    Image Attached Thumbnails Click image for larger version

Name:	1.png
Views:	21
Size:	22.8 KB
ID:	56278  

    Quote Quote  
  11. Export to mp4 instead. In your m4v Stream the duration info is missing.
    You can also try to remux the m4v to mkv first with MkvToolNix

    Use the newest beta https://files.videohelp.com/u/292773/clever_ffmpeg_gui_newest_beta.7z
    and load your m4v again. It should be copied automatically into a mp4 container and reloaded.
    The multiplexing should then work flawless.
    Last edited by ProWo; 16th Dec 2020 at 11:14.
    Quote Quote  
  12. Amazing! It works!
    I exported a mp4 .h264 file on AME 2020 (with audio) then re-exported only the AAC audio 160kbps.
    Then I went to Clever FF and import the .mp4 and multiplexed it with the AAC again, and the mp4 muxed file shows on MediaInfo as 6000 bitrate!

    I'm going to send this to my client and check if the platform accepts it.
    Thank you so much for the help!
    Quote Quote  
  13. Originally Posted by dogmydog View Post
    Amazing! It works!
    I exported a mp4 .h264 file on AME 2020 (with audio) then re-exported only the AAC audio 160kbps.
    Glad you got it working but there was no need to output the audio twice.
    Both TSMuxer and ProWo's tool could handle the combined .mp4.
    Quote Quote  
  14. Hey @smrpix, thanks for joining the conversation.
    I had to output with audio because, for some weird reason, I couldn't read the .m4v file that AME 2020 generated.
    Not in Clever, not in VLC, nowhere. It was generating a corrupt file. I used the PRESET Vimeo Full HD and unchecked the audio box, and it still didn't work.

    The Mp4 muxed file, however, worked just fine.

    About the ts_muxer:
    On ts_muxer General Tab, there is an option called Mux VBR.
    In default, the generated ts file gives me a Maximum Overall bit rate of 35.5 Mb/s (according to Media Info).
    This is weird because the video is encoded at 6,000 CBR and the audio is only 160 bits.
    Image
    [Attachment 56282 - Click to enlarge]


    And when I try to limit the bitrate on ts_muxer for whatever value, it starts givin me VBV errors such as:
    VBV buffer overflow at position 115.086 sec
    VBV buffer overflow at position 105.326 sec
    etc

    I'm going to send the generated ts to the client and check if it works.
    Thanks again for the time spent on this matter
    Quote Quote  
  15. Looks like you aren't using AME correctly.

    Under the h.264 presets you can set the bitrate for both video and audio as you wish. The resulting multiplexed .mp4 can be fed directly into either TSMuxer or clever ffmpeg GUI. (M4V is video only -- not sure why you're putting yourself through that step.)
    Quote Quote  
  16. That is a good idea, smrpix. I thought that ts-muxer needed the .m4v and .aac files separate to mux.

    I did, however, just tried exporting the multiplexed mp4 into ts-muxer and exporting a TS.

    Media info still claims the file's Maximum Overall bit rate is 35.5 Mb/s, even though the video is encoded at 6,217kb/s, just as the img I sent previously.
    And when I try to limit the Mux Rate to CBR 8,000 on the General Tab of ts_muxer, or any other value, I get the VBV errors...


    Please see attached SS.
    Image Attached Thumbnails Click image for larger version

Name:	1.png
Views:	16
Size:	34.7 KB
ID:	56284  

    Click image for larger version

Name:	2.PNG
Views:	18
Size:	58.2 KB
ID:	56285  

    Quote Quote  
  17. Hey guys, quick update: the clients platform has rejected my H264 encode with the Clever FF muxing or Ts_muxing.
    I'm not sure if I'm doing something wrong, since I am obeying the h264 encoding limits using the Vimeo Full HD preset and limiting bitrate to 6,000 and audio AAC 160bits.

    Here are the specs they need to ingest the TS files, which i configure in Episode 6 Pro.

    General
    Container MPEG-TS (ts)
    Transport Rate 10,000 kbit/s

    Video
    H264 (Main Concept)
    Constant Bitrate (CBR)
    Bitrate: 6,000 kbit/s
    Natural and Forced Keyframes
    Keyframe Interval: 100 Frames
    Adaptive B-frames (X)
    Number of B-frames: 3 frames
    Number of Reference Frames: 2 frames

    Encoder Profile: High
    Context-Adaptive Binary-Arithmetic Coding (CABAC)
    Color Space: 4:2:0
    Display Aspect Ratio: From Source/Resize Filter
    Two Pass Encoding (X)
    Deblocking Filter (X)

    Number of Slices: 4 Slices
    Initial Buffer Fullness: 100%
    IDR Frames: Every
    Force headers for every GOP (X)
    Signal fixed framerate (X)
    Pulldown: None
    Level Signalling: Level 4.0
    Audio
    AAC Quicktime
    Bit Rate Based
    Bit Rate: 160kbit/s
    Setting Type: Standard Settings

    Any help is much appreciated!
    Thanks
    Quote Quote  
  18. Seems you have to put some more settings into ffmpeg. What does (x) mean? you must include or omit?
    Quote Quote  
  19. The videostream seems fine, maybe the platform doesnt like the aac audio. You could try to load your mp4 video with aac audio into clever Ffmpeg-GUI, converse the aac audiostream to ac3 248 kb/s 48kHz and remux this new audiostream with the videostream to ts container.
    Quote Quote  
  20. Originally Posted by 4kblurayguru View Post
    Seems you have to put some more settings into ffmpeg. What does (x) mean? you must include or omit?
    Thanks for the help!
    X means yes, include. How can I insert these options on FF mpeg?
    Quote Quote  
  21. Originally Posted by ProWo View Post
    The videostream seems fine, maybe the platform doesnt like the aac audio. You could try to load your mp4 video with aac audio into clever Ffmpeg-GUI, converse the aac audiostream to ac3 248 kb/s 48kHz and remux this new audiostream with the videostream to ts container.
    Thanks for the reply!
    I believe the platform accepts AAC audio, since these are the settings I have been using to upload files done with Episode Pro.

    I have uploaded a example file 4000283 to wetransfer so you can check out the differences:
    4000283-original.mov (the original file on 12mbps)
    4000283-episode.ts (the original file converted to TS using the settings listed above on Episode 6 Pro) -- THIS ONE IS ACCEPTED BY THE CLIENT PLATFORM.
    4000283-adobemediaencoder.mp4 (the original file converted to 6,000 CBR using the Vimeo Full HD preset tweeked for lesser bitrate)
    4000283-ts-muxer.ts (the 4000283-adobemediaencoder.mp4 file multiplexed using ts-muxer with Mux VBR)
    4000283-clever.ts (the 4000283-adobemediaencoder.mp4 file multiplexed using Clever FFmpeg Gui with the multiplexing function).

    https://we.tl/t-kdK8PoQArw

    I checked the Media Info on the files and I think maybe it is because the file multiplexed on AME is not interlaced TFF.
    I tried interlacing the file and sent to the client again. Will send you news soon

    Thanks again for the help so far!
    Quote Quote  
  22. Hey guys, another update. The Platform has refused my file again. :'(
    Can you please take a look at the wetransfer files and see if you can help me investigate?

    https://we.tl/t-kdK8PoQArw
    Quote Quote  
  23. 4000283-adobemediaencoder.mp4:
    - is uses Main profile
    - it uses no b-frames at all
    - keyframe interval: 30 frames
    - no slices
    (The "original" also does not have slices nor is its keyframe interval 100 ...)


    P.S.: The AME H.264 encoder does not have very good reputation AFAIK. I would probably export to a lossless or near lossless format and re-encode with x264 cli. Then you also have finer control over settings.
    Quote Quote  
  24. Originally Posted by dogmydog View Post
    Hey guys, another update. The Platform has refused my file again. :'(
    Can you please take a look at the wetransfer files and see if you can help me investigate?
    https://we.tl/t-kdK8PoQArw
    Maybe the Format profile: Main@L4.1;
    change the profile of 4000283-clever.ts from Main@4.1 to Main@4.0 and send it again to the platform for testing.
    https://www.videohelp.com/software/H264-AVC-Level-Editor
    Quote Quote  
  25. Hey @sneaker and @prowo, thanks for the help!

    I'm gonna take a look at x264 cli, thanks for that.

    About the Main Profile, I have thought about that and AME permits me to change from High to Main.
    One other thing that caught my eye is that on the episode.ts file, Media Info states that the Standard is NTSC:

    Video
    ID : 481 (0x1E1)
    Menu ID : 1 (0x1)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L4
    Format settings : CABAC / 2 Ref Frames
    Format settings, CABAC : Yes
    Format settings, Reference frames : 2 frames
    Codec ID : 27
    Duration : 25 s 25 ms
    Bit rate mode : Constant
    Nominal bit rate : 6 000 kb/s
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate : 29.970 (30000/1001) FPS
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : MBAFF
    Scan type, store method : Interleaved fields
    Scan order : Top Field First
    Bits/(Pixel*Frame) : 0.097
    Color range : Limited

    When I encode thru AME, if I choose H264 or H264 (Blu-ray) it does not give me NTSC as a Standard.
    Video
    ID : 256 (0x100)
    Menu ID : 1 (0x1)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L4
    Format settings : CABAC / 4 Ref Frames
    Format settings, CABAC : Yes
    Format settings, Reference frames : 4 frames
    Format settings, GOP : M=1, N=2
    Codec ID : 27
    Duration : 1 h 17 min
    Bit rate mode : Constant
    Nominal bit rate : 6 000 kb/s
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate : 29.970 (30000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Interlaced
    Scan type, store method : Separated fields
    Scan order : Top Field First
    Bits/(Pixel*Frame) : 0.097
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    So I'm definately going to try a different encoding software and get back to you!
    Thank again for the continuing support ^^
    Quote Quote  
  26. It seems that something is wrong with your encoder.
    I have made some attempts; try the following:
    Re-encode your mov original with the following command line:
    ffmpeg -i "4000283-original.mov" -c:v libx264 -crf 21 -r 29.97 -profile:v main -level:v 4.0 -c:a copy "4000283-original.ts"
    Quote Quote  
  27. Originally Posted by ProWo View Post
    It seems that something is wrong with your encoder.
    I have made some attempts; try the following:
    Re-encode your mov original with the following command line:
    ffmpeg -i "4000283-original.mov" -c:v libx264 -crf 21 -r 29.97 -profile:v main -level:v 4.0 -c:a copy "4000283-original.ts"
    Great, it worked, but:
    1) I still don't get interlaced results, nor the NTSC Standard.
    2) The Overall Bitrate is at 4836, can I up it a bit to be at ~6000kbps?
    3) Also, it still states CABAC 4 ref frames and not CABAC / 2 ref frames as the episode 6 pro file (sorry if I'm newbing, I'm very new at this).

    Thanks!
    Quote Quote  
  28. Originally Posted by dogmydog View Post
    Great, it worked, but:
    1) I still don't get interlaced results, nor the NTSC Standard.
    2) The Overall Bitrate is at 4836, can I up it a bit to be at ~6000kbps?
    3) Also, it still states CABAC 4 ref frames and not CABAC / 2 ref frames as the episode 6 pro file (sorry if I'm newbing, I'm very new at this).
    Thanks!
    1) It makes no sense to encode interlaced. But it is possible if you want.
    2) You can vary the crf value (g.e. -crf 19). Smaller value gives better quality and higher bitrate.
    3) You could try add
    -x264opts cabac=1:ref=2
    after libx264. (Not tested).
    Quote Quote  
  29. Forget about "NTSC" flag and interlaced encoding. The culprit is probably your GOP configuration. It clearly states keyframe interval "100" and 3 b-frames in your spec. So modify preset in your application to use those. MediaInfo should show that as M=4, N=100 if it's fixed interval without adaptive b-frames. Next suspect can be number of slices. Also their spec is inconsistent. They ask for constant bitrate (cbr) but also want two pass which is variable bitrate. They need to make up their mind.
    Quote Quote  
  30. Originally Posted by badyu17 View Post
    Forget about "NTSC" flag and interlaced encoding. The culprit is probably your GOP configuration. It clearly states keyframe interval "100" and 3 b-frames in your spec. So modify preset in your application to use those. MediaInfo should show that as M=4, N=100 if it's fixed interval without adaptive b-frames. Next suspect can be number of slices. Also their spec is inconsistent. They ask for constant bitrate (cbr) but also want two pass which is variable bitrate. They need to make up their mind.
    Hey badyu17 thanks for joining the conversation!
    As I stated before, I'm not a engineer, so I'm following your tutorials and trying to get similar results to what the platform accepts.
    Right now I'm trying the ProWo ffmpeg instructions.

    I asked them for more examples and here is what I got (I translated the img for you, it is in pt-br language)

    General: Standard example NOW
    Format: MPEG-TS
    File Size : 5.70GiB
    Duration: 1h 32mn
    Bit Rate (Method): Constant
    Bit Rate (Total): 8000 Kbps

    Video

    ID: 481 (0x1E1)
    Menu ID: 1 (0x1)
    Format: AVC
    Format / lnformation: Advanced Video Codec
    Format Profile: High@L4.0
    CABAC: Yes
    Format, Ref Frames: 3 frames
    Codec ID: 27
    Duration: 1h 32mn
    Bitrate: 8,000 kbps
    Width: 1920 pixels
    Height: 1080 pixels
    Aspect Ratio: 16:9
    Frame rate: 29.970 fps
    ColorSpace: YUV
    Chroma Subsampling 4:2:0
    Bitdepth / String: 8 bits
    Scan type: Progressive
    Bits/(Pixels*Pictures}: 0.129
    File Size: 5.17GiB (91%)
    Used Library: x264 core 148

    Supported Audio Compression is AAC, AC3, MPEG layer 2, None, PCM.

    Image
    [Attachment 56388 - Click to enlarge]
    Quote Quote  



Similar Threads