VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. Member
    Join Date
    Oct 2020
    Location
    Poland
    Search Comp PM
    I have nginx installed with the RTMP module with 2 applications configured: "lang" and "live". When I try to use "-map_channel" to separate audio channels to broadcast several languages, the stream in the "live" application does not start.

    nginx.conf, application "lang":
    Code:
    exec_push ffmpeg -i rtmp://localhost/lang/$name
          -map_channel 0.0.0 -vcodec copy -acodec copy -f flv rtmp://localhost/live/$name_ch1
          -map_channel 0.0.1 -vcodec copy -acodec copy -f flv rtmp://localhost/live/$name_ch2;
    when I remove the "-map_channel" entries from the code I get 2 streams in the "live" application

    None of the options that I found work:
    ffmpeg -i stereo.wav -filter_complex "[0:a]channelsplit=channel_layout=stereo[left][right]" -map "[left]" left.wav -map "[right]" right.wav
    ffmpeg -i stereo.wav -map_channel 0.0.0 left.wav -map_channel 0.0.1 right.wav
    ffmpeg -i stereo.wav -filter_complex "[0:a]pan=1c|c0=c0[left];[0:a]pan=1c|c0=c1[right]" -map "[left]" left.wav -map "[right]" right.wav

    Please help
    Quote Quote  
  2. -map_channel does not work with -acodec copy.
    if you have separate audio tracks in your video, use e.g. -map 0:a:1
    Read also https://trac.ffmpeg.org/wiki/Map
    Quote Quote  



Similar Threads