VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. i suddenly got a error message, idk why. i think ive been using this process for a while, does anyone know how to read error messages?
    Image Attached Thumbnails Click image for larger version

Name:	ffmpeg_error.png
Views:	14
Size:	18.7 KB
ID:	55497  

    Quote Quote  
  2. this is what i entered
    Image Attached Thumbnails Click image for larger version

Name:	ffmpeg_error.png
Views:	12
Size:	20.0 KB
ID:	55498  

    Quote Quote  
  3. You know you can select content from a terminal window and post it in 'code'-tags and thus make the whole thing way better readable, right?

    From the looks of it you should used quotes (ass="...") so that the parser knows this is one value and the backslashes are not there to escape something.
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  4. Code:
    ffmpeg -i C:\Users\User\Videos\Japan_Hour\Its_Lunchtime_1_temp.mp4 -vf ass="C:\Users\User\Videos\Japan_Hour\working\Its_Lunchtime_1_subtitle.ass" C:\Users\User\Videos\Japan_Hour\Its_Lunchtime_1.mp4
    i tried with the quotes, still have the same error.
    Image
    [Attachment 55505 - Click to enlarge]

    Code:
    [Script Info]
    ; Script generated by FFmpeg/Lavc58.82.100
    ScriptType: v4.00+
    PlayResX: 384
    PlayResY: 288
    
    [V4+ Styles]
    Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, OutlineColour, BackColour, Bold, Italic, Underline, StrikeOut, ScaleX, ScaleY, Spacing, Angle, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, Encoding
    Style: Default,Arial,16,&Hffffff,&Hffffff,&H0,&H0,0,0,0,0,100,100,0,0,1,1,0,2,10,10,10,0
    
    [Events]
    Format: Layer, Start, End, Style, Name, MarginL, MarginR, MarginV, Effect, Text
    this is the first few lines of my subtitle .ass file
    Quote Quote  
  5. Okay, problem is that the path of the ass file needs to be properly escaped. (I hoped adding quotes would already help.)
    Try:
    Code:
    ffmpeg -i C:\Users\User\Videos\Japan_Hour\Its_Lunchtime_1_temp.mp4 -vf "ass='C\:/Users/User/Videos/Japan_Hour/working/Its_Lunchtime_1_subtitle.ass'" C:\Users\User\Videos\Japan_Hour\Its_Lunchtime_1.mp4
    what I did is:
    • replace back- (\) with forward- (/) slashes (alternatively each back-slash could be escaped with another back-slash)
    • put the path in ticks (')
    • escape any special characters, here the colon (:), with a back-slash (\)
    • put the ass parameter in quotes (")

    here's another example:
    Code:
    ffmpeg -y -i "f:\TestClips&Co\test.avi" -filter_complex "ass='F\:\\TestClips\&Co\\files\\Subtitles\\test.ass'" e:\Output\test.mkv
    where I escaped the back-slashes with back-slashes.

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  6. thanks man it works!!
    Is there any favor i can do for u in return?
    Quote Quote  
  7. also its a pain to burn the subtitles in for the videos, but windows media player cant seem to play the vtt file alongside the mp4, do u know how to fix that?
    Quote Quote  
  8. Don't use Windows Media Player, use MPC-HC, VLC, MPV, or any other common player.
    No clue whether there is a way to get Windows Media Player to recognize vtt files.
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  9. basic conversion of vtt text to srt is also possible.
    Quote Quote  



Similar Threads