VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Hello everyone. I'm new to ffmpeg and recently tried to encode a video
    Image #1 : this is the source
    Image
    [Attachment 55000 - Click to enlarge]


    Image #2 : this is some else's video using ffmpeg and same source
    Image
    [Attachment 55001 - Click to enlarge]


    Image #3 : this is my video in 480p quality and using ffmpeg without any filter
    Image
    [Attachment 55002 - Click to enlarge]


    As you can see Image #2 color is more like the source. Can anyone suggest any filter in ffmpeg that will do such a thing? I've used sharpen filter but the color was still far from the source.
    Quote Quote  
  2. It's mostly a rec.601 vs. rec709 colormatrix issue. There's also a slight brightness difference. What was your ffmpeg command line? And MediaInfo properties (text mode) of the source video and the video you want to match.
    Last edited by jagabo; 23rd Sep 2020 at 18:19.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    It's mostly a rec.601 vs. rec709 colormatrix issue. There's also a slight brightness difference. What was your ffmpeg command line? And MediaInfo properties (text mode) of the source video and the video you want to match.
    I'm using ffmpeg on centos 7. The version is 3.4.8
    I just attached MediaInfo of input and sample that I want my video to be like.
    Image Attached Files
    Quote Quote  
  4. The source isn't marked as bt.709 (rec.709) but since it's HD the player may be assuming bt.709. The sample you're trying to match is marked as bt.709. My guess is you need to mark your video as bt.709. Add "-colorspace bt709" to your ffmpeg command line.

    The general rule is that HD video uses rec.709 and SD video uses rec.601. The exact behavior of players vary, but in the absence of the flag indicating which to use some players assume rec.709 for HD, rec.601 for SD. Some players ignore the flag and always use the same one.
    Last edited by jagabo; 23rd Sep 2020 at 19:40.
    Quote Quote  
  5. Originally Posted by jagabo View Post
    Add "-colorspace bt709" to your ffmpeg command line.
    I Just tried it and the problem was fixed. thanks for your help
    Quote Quote  



Similar Threads