VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Hi , i am using VDub to take my interlaced (25fps interlaced) avi file and spit out a 50fps de-interlaced avi.

    Im using the Vdub internal de-interlace plugin. Great. Getting a nice 50fps avi that looks great and has perfect audio sync.

    Problem is, Vdub is only rendering half of the original avi file. It seems the "length bar" across the bottom doesnt change/update when you de-interlace and double the frames? its a bug? the file originally had 29000 interlaced frames. And i apply the plugins, and frame rate changes to 50fps, but Vdub is still only de-interlacing to frame 29,000. The bottom drag bar is not doubling to 58,000 frames? so VDub only does half the render and then stops when i hit "render to avi"

    is this a known bug? shame its not fixed its one of the main reasons to use VDub i woulda thought, any workarounds?

    many thanks,
    Blackout
    Quote Quote  
  2. Member
    Join Date
    Aug 2013
    Location
    Central Germany
    Search PM
    VirtualDub 1.10.4 is quite old and probably abandoned. The currently well supported and developed successor is VirtualDub2. If this issue is still there, its developer will surely fix it quickly. I opened a video and added the Deinterlace filter with "Double FR, TFF" option, and the frame counter doubled.

    BTW, which deinterlacing method do you select? There are more and less elaborate methods. But VirtualDub2 has only a few built-in methods, Yadif and ELA probably being the smartest in this selection. The most elaborate filters with motion compensation, though (TDeint and QTGMC) are only available via external AviSynth or VapourSynth scripts and plugins...
    Quote Quote  
  3. Thanks LigH. I use Yadif. Its the only one that doesnt pulse static images such as text on the screen.

    Ill check out Virtualdub2 Cheers!
    Quote Quote  
  4. exactly same bug is in Virtualdub2. Hmmm

    heres how to replicate:
    1:/ Load Virtualdub1 or 2
    2:/ Load avi
    3:/ load "Load processing settings" containing the De-interlace plugin with setting to Yadif and double frame rate, bottom field first
    4:/ scroll bar across bottom...avi ends early when dragged to far right.

    in comparison...it works correctly if you do it in reverse:
    1:/ Load Virtualdub 1 or 2
    2:/ Load "Load processing settings" containing the De-interlace plugin with setting to Yadif and double frame rate, bottom field first
    3:/ Load avi
    4:/ scroll bar across bottom...avi ends correctly..last frame number listed on the slider bar far-right is double the figure from above procedure

    ????
    Last edited by Blackout; 18th Sep 2020 at 05:16. Reason: updated
    Quote Quote  
  5. Member
    Join Date
    Aug 2013
    Location
    Central Germany
    Search PM
    Does it happen only with a specific deinterlacer? I only tried the upper 3, the rest I don't care about...

    Try not to use "Load processing settings", but instead add the deinterlace filter manually to the video filters: Same issue?
    Image Attached Thumbnails Click image for larger version

Name:	VD2Deint.png
Views:	7
Size:	11.8 KB
ID:	54940  

    Quote Quote  
  6. works ok when you load the plugin manually. Seems theres a bug with Load processing settings? i have some other plugins there in my list i like to use (all internal ones) such as Levels and Sharpen....kinda frustrating if i cant load them and their settings properly. Is there a place to report bugs in Virtualdub2?
    Quote Quote  
  7. thanks LigH appreciate your time. Reporting there now. Cheers
    Quote Quote  



Similar Threads