VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. I am not sure whats up with this source, but I do not think I have ever seen a DVD this badly interlaced or blended at the same time.

    No matter how I try using TFM, I cannot get this to decomb/deinterlace properly. There are always leftover combing/interlace artifacts all over the place. Maybe there's a better setting than this?
    tfm(order=-1, slow=2)

    MeGui is suggesting to use Yadif for whatever reason after it analyzes it, so I ended up going with QTGMC to get the rest of them, and it appears to have worked much better.
    QTGMC(preset="slow", matchpreset="slow", matchpreset2="slow", fpsdivisor=2, sourcematch=3, tr1=2, tr2=1, NoiseTR=2, sharpness=0.1)

    This source is also very blended and seems to have multiple blended frames per second. I'm not really reducing them well enough with srestore.

    Any suggestions on how to deinterlace and remove some of the blends in the process?


    Here is an untouched sample video

    https://mega.nz/file/YsYBkKLQ#mclURrnlJMdP0epgiWYYXf-i6fvGRhwLms81DcaUukk
    Quote Quote  
  2. There's too much blending. I think just QTGMC() and encoding at 59.94 fps looks best. But the character animation looks about right at about 11 fps:

    Code:
    Mpeg2Source("VTS_03_1.demuxed.d2v", CPU2="ooooxx", Info=3) 
    nnedi3(field=-2) # or other bob
    SRestore(frate=25)
    SRestore(frate=11)
    I don't know why I had to go as low as 11 fps to get rid of all the duplicates. I didn't count closely but there are a few blended frames left so maybe it should be 12 (11.99). Maybe you can fine tune that and figure something else out for the panning shots.
    Last edited by jagabo; 26th Aug 2020 at 23:14.
    Quote Quote  
  3. Wow, 11 frames? sounds much lower than Id like to go. That sounds like it would jitter really badly if 11-12fps, especially when the whole screen or background is moving.

    I can only call srestore once in a script. Not sure how you managed to get two of them to work.
    Quote Quote  
  4. Like most animated material the character animation is at 12 fps. So you're not losing anything there. Only the panning shots are at 24 fps. But there is too much blending to restore only the original film frames at 24p.

    You probably need a newer version of SRestore to call it more than once. I did two SRestores because a single one doesn't allow decimation from 60p to 11p or 12p. You can try simple decimation instead of the first SRestore. But that may remove some of the clean frames making the overall process less accurate.

    Like I said, I think your best bet is to forget trying to restore the orginal film frames and just encode at 60p.
    Quote Quote  



Similar Threads