VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date
    Aug 2020
    Location
    Thunder Bay, Ontario. Canada.
    Search Comp PM
    Hi

    Wish I'd read earlier about the machine always being on even when shut off. Mine has been sitting unused for years, plugged in. I sometimes had similar issues to what others have mentioned here and elsewhere with ejecting discs, but the real problem came more recently.

    The machine began turning itself on at night. I thought I might have been accidentally backing up into it as I worked at my computer. Then a few times it just seemed to turn itself on in the middle of the night when I was in bed watching tv. When I remembered that the machine puts the word "Hello" on screen when you turn it on I got a little creeped out, wondering if some spirit might have been messing with it as a strange way of "contacting" me. Last time it did this it wouldn't shut off. So I unplugged it.

    Left it unplugged for some time. When I plugged it back in it powered up okay, but instead of Hello I got something like this _ _ _ _ _ _ _ _ - A bunch of spaced dashes where it used to say hello. None of the buttons seem to function. I never tired the remote control.

    I used to use the machine mostly for transferring vinyl to CD, as it's one of the few machines that will burn an actual CD. I also used it for converting video tapes to dvd. It has the vcr in one side and the recorder in the other and you could record from either one to the other. And the nice thing about the built in vcr was that it is one of the few brands which does not display the word "play" on screen when you are trying to make a copy of it.

    Any help with getting this machine operational would be much appreciated. As would any helpful advice or commentary.
    Quote Quote  
  2. Member
    Join Date
    Feb 2006
    Location
    United States
    Search Comp PM
    do you have the original remote ??
    if you can access the settings via the remote
    then you might try and see if you can do a factory reset.
    do you have the instruction booklet ??
    Quote Quote  
  3. Member
    Join Date
    Aug 2020
    Location
    Thunder Bay, Ontario. Canada.
    Search Comp PM
    Hi october262. Yes I have both the original remote control AND the manual for it.
    Quote Quote  
  4. Member
    Join Date
    Aug 2020
    Location
    Thunder Bay, Ontario. Canada.
    Search Comp PM
    Hi

    I tried using the remote. Put brand new batteries in and checked them to make sure they were not low on power. However nothing happened. I think the remote is okay. Worked fine the last time I used the machine. But when I tried right now I did notice that the little light on the front of the remote which usually blinks didn't do so. I don't know if that is because the remote no longer works (which I can't see being the case) - of it it's because it's not connecting with the Liteon itself. Nothing in the manual about troubleshooting this issue.

    Thanks for the idea and help anyway.

    Keep 'em coming if you have others.
    Quote Quote  



Similar Threads