VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Can someone please help me with this command? The audio won't convert to the desired codec nor bitrate. It just creates a copy of the original and changes the output to the desired (.mp4).

    set avidemux="C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe"
    set videocodec=copy
    set audiocodec=AAC
    set audiobitrate=160
    for %%f in (*.mkv) do %avidemux% --video-codec %videocodec% --audio-codec %audiocodec% --audio-bitrate %audiobitrate% --load "%%f" --save "%%f.mp4" --quit
    Quote Quote  
  2. I don't know what the issue is with avidemux, but you could use ffmpeg instead:

    Code:
    set avidemux="ffmpeg.exe"
    set videocodec=copy
    set audiocodec=aac
    set audiobitrate=160k
    
    for %%f in (*.mkv) do %avidemux% -i "%%f" -c:v %videocodec% -c:a %audiocodec% -b:a %audiobitrate% "%%f.mp4"
    Use the full path to ffmpeg.exe if necessary. Codec "aac" must be lower case, not "AAC". Note the "k" for the audio bitrate -- k is not assumed.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    I don't know what the issue is with avidemux, but you could use ffmpeg instead:

    Code:
    set avidemux="ffmpeg.exe"
    set videocodec=copy
    set audiocodec=aac
    set audiobitrate=160k
    
    for %%f in (*.mkv) do %avidemux% -i "%%f" -c:v %videocodec% -c:a %audiocodec% -b:a %audiobitrate% "%%f.mp4"
    Use the full path to ffmpeg.exe if necessary. Codec "aac" must be lower case, not "AAC". Note the "k" for the audio bitrate -- k is not assumed.
    Thank you. The ffmpeg.exe method worked. I just wish avidemux worked because it's an amazing piece of software. Moreover, do you by any chance have the link for all the commands available for ffmpeg?
    Quote Quote  
  4. I noticed recently, while trying to help someone with a similar issue, that many options have been removed from Avidemux 2.7 as compared with earlier versions. No idea why.
    In particular --audio-bitrate is no longer available.
    https://forum.videohelp.com/threads/398292-Help-using-avidemux-command-line
    Learning how to use ffmpeg might be wiser, as it is improving over time, not regressing, but if you absolutely, positively got to use Avidemux CLI, try to get v. 2.6 instead.

    And I don't think that the arguments are case-sensitive, but "AAC" is apparently no longer accepted, it has to be a specific implementation like "FDK_AAC".
    Code:
    --audio-codec, set audio codec (copy|Lame|FDK_AAC|LavAC3|Opus|TwoLame|...)  (one arg )
    But what seems to be the official documentation seemingly hasn't been updated in years.
    http://avidemux.sourceforge.net/doc/en/command.xml.html

    Moreover, do you by any chance have the link for all the commands available for ffmpeg?
    The full integrated help (obtained by typing ffmpeg -h full >"E:\ffmpeg help.txt" ) gets extracted as a whopping 800KB text file (to put this in perspective, that's bigger than Dante Alighieri's Divine Comedy and a tad smaller than Fiodor Dostoyevsky's Crime and punishment) and it only covers the basics of what's available / possible.


    @ jagabo
    set avidemux="ffmpeg.exe"
    Isn't it... unnecessarily convoluted and confusing ? O_o
    Last edited by abolibibelot; 10th Aug 2020 at 03:22.
    Quote Quote  
  5. It makes sense to use the correct tool for the job.

    For command-line use ffmpeg not avidemux.
    Quote Quote  
  6. It makes sense to use the correct tool for the job.
    But Avidemux CLI used to work well for simple tasks like that, do you have any idea why it's no longer the case ?
    Quote Quote  
  7. Originally Posted by chucknolan View Post
    Can someone please help me with this command? The audio won't convert to the desired codec nor bitrate. It just creates a copy of the original and changes the output to the desired (.mp4).

    set avidemux="C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe"
    set videocodec=copy
    set audiocodec=AAC
    set audiobitrate=160
    for %%f in (*.mkv) do %avidemux% --video-codec %videocodec% --audio-codec %audiocodec% --audio-bitrate %audiobitrate% --load "%%f" --save "%%f.mp4" --quit
    Try:
    set avidemux="C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe"
    set videocodec=copy
    set audiocodec=LavAAC
    set audiobitrate=160
    for %%f in (*.mkv) do %avidemux% --video-codec %videocodec% --audio-codec %audiocodec% --audio-bitrate %audiobitrate% --load "%%f" --save "%%f.mp4" --quit
    Quote Quote  



Similar Threads