VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. I am converting to digital old VHS sports tapes from PAL region (Greece)
    Process is
    -JVC HR-S7600EK S-VHS
    -S-Video Cable
    -ATI TV Wonder 600 USB
    -AmaRecTV to HuffYUV 4:2:2 720x576 25 fps PAL, PCM Audio
    -StaxRip:
    x264 4:2:2
    Code:
    --crf 19 --preset veryslow --level 4.1 --vbv-maxrate 62500 --vbv-bufsize 78125 --merange 32 --min-keyint 25 --no-dct-decimate --output-csp i422
    Script
    Code:
    #Load/Import stuff
    FFVideoSource("D:\vhs_captures\amarec(20200806-1406).avi", cachefile="D:\vhs_captures\amarec(20200806-1406)_temp\amarec(20200806-1406).ffindex", fpsnum=25, fpsden=1)
    Crop(12, 2, -14, -12)
    AssumeTFF() #this is used because I get back-and-forth frames if I don't use it
    QTGMC(preset="Medium", sourceMatch=3, tr1=2, tr2=1, NoiseTR=2)
    The result of the sports action is nice, but I get a jumpy/flickering effect on some static content, not all of it but on some

    Sample source
    Code:
    https://mega.nz/file/NuJjEICJ#vvsWK6uiTEN1SkABUChe2U-bNaf24pizuQ16bSs8r6s
    Sample encode
    Code:
    https://mega.nz/file/N3YxASZb#3tWOM84ntff7rEShK0PXAs3bzguJB6XL0COxrKM9Bm0
    What could I do to fix it?

    Samples are trimmed/joined with ffmpeg
    Code:
    ffmpeg -ss "$start_time" -to "$end_time" -i original_file.ext -c copy vid_cut.ext
    ffmpeg -f concat -safe 0 -i ffmpeg_join_filelist.txt -c copy vid_joined.ext
    Quote Quote  
  2. Preset="slower" will flicker less. Removing SourceMatch will help too.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    Preset="slower" will flicker less. Removing SourceMatch will help too.
    Thanks, it seems to do a much better job. What about choosing Placebo or Very Slow, will that do a better job?
    Quote Quote  
  4. I don't know if placebo or very slow will flicker even less.
    Quote Quote  
  5. Flickering is definitely less with just "QTGMC(preset="Slower")" but I notice it a bit, e.g. here (frames 448/449) every other frame a red dot appears/disappears on the red team's logo



    or the letters on the second cut of the sample doesn't flicker that much but still do.
    Is there any way to fix it completely? I don't mind how much time will the encode take
    Last edited by Hackerpcs; 7th Aug 2020 at 13:29.
    Quote Quote  
  6. I don't see any good automated way eliminate that flickering without destroying everything else. If you don't mind putting in the work you can apply a strong filter to just that area with Overlay() and a mask, and apply it to just the frames where that logo appears. Here's an quick dirty example that applies a strong filter to just that area:

    Code:
    function TSmoothBox(clip v, int x, int y, int w, int h)
    {
        area = v.Crop(x,y,w,h).TTempSmoothF(maxr=1, Strength=1, lthresh=255, cthresh=255)
        Overlay(v, area, x, y)
    }
    
    LWLibavVideoSource("amarec(20200806-1406)_sample.avi") 
    AssumeTFF()
    ConvertToYV12(interlaced=true)
    QTGMC(preset="slower", sourceMatch=3, tr1=2, tr2=1, NoiseTR=2)
    ReplaceFramesSimple(last, TSmoothBox(118,456,68,72), mappings="[166 724]")
    You'll have to go through the entire video and fix each section with the problem.
    Last edited by jagabo; 7th Aug 2020 at 21:01.
    Quote Quote  



Similar Threads