VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. I have been recording via streamlink, a few online channels that use HLS and the TS format in 720P. (Not sure if the resolution matters, but oddly the 480P streams don't have this issue).

    Anyway, it seems that the timestamps are messed up on the file.

    In almost any video player, it will think an 1 hr 10 min file is like 4 minutes or some other wrong number.

    Oddly MPC with K-Lite Media Pack can play the video just fine.

    I tried using ffmpeg -c copy which tends to fix many broken timestamp files.

    Oddly, ffmpeg makes the file worse by creating weird jumps in the file by apparently cutting out segments of video.

    Like one area, MPC shows it going from commercial to in the program as normal but ffmpeg will show it commerical then too far in to the episode after the break.

    I also tried a trial with VideoRedo but it crashes half-way through Quick Repair.

    Finally I did also try loading in to VDub2 but it almost freezes up seeking and AVIDemux loads it completely wrong.

    Is there any easy way to fix the video so all programs like it? I am not 100% sure why MPC can play it perfectly but other programs choke on it.
    Quote Quote  
  2. Member netmask56's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Search Comp PM
    Try TS Doctor
    BeyonWiz T3 PVR ~ Popcorn A-500 ~ Samsung ES8000 65" LED TV ~ Windows 7 64bit ~ Yamaha RX-A1070 ~ QnapTS851-4G
    Quote Quote  
  3. Remux it to mkv with MkvToolNix
    Quote Quote  
  4. I tried both of them but so far both no luck and I guess I was wrong about MPC.

    It does do better than other editors but still has seeking issues.

    It seems what throws it off is the looping commericals screen that says "We'll be right back" as I had that issue with other streaming channels.
    Quote Quote  
  5. Most likely the video stream is broken. If the 480p stream is ok and the 720p stream is broken,
    this could be caused by your computer not being able to process the hiher data rate correctly in time.
    Quote Quote  
  6. Originally Posted by ProWo View Post
    Most likely the video stream is broken. If the 480p stream is ok and the 720p stream is broken,
    this could be caused by your computer not being able to process the hiher data rate correctly in time.
    I was actually thinking that. I am going to have one of my faster PCs record the stream instead as I think I had a similar problem a while back.

    I think my older single core PC can really only record 480P and below, so I am going to move the recordings to my quad-core PC for a while and see what happens.
    Quote Quote  



Similar Threads