VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    Sep 2006
    Location
    United States
    Search Comp PM
    Hello everyone! I regularly use Kodi as my media player and have some streams I view from it. I have noticed that especially with 1080p links, I end up with green pixelation and artifacts. When I drop down to 720p this barely happens. I have adjusted the player's acceleration settings and such, but then playback gets choppy. I am curious if the streams weren't properly encoded, so they play back poorly, or is my media player (an android box using KODI) is the issue. Thanks in advance!
    Quote Quote  
  2. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    You're accessing these streams directly from your Android box streamed to the TV?
    You could try accessing the same streams from the PC and check the quality there
    Quote Quote  
  3. Member
    Join Date
    Sep 2006
    Location
    United States
    Search Comp PM
    Good idea. I don't have Kodi on my laptop and have been using Stremio on my laptop. That will definitely answer "is it a quality stream issue or a hardware issue."
    Quote Quote  
  4. Average video editor Sviests's Avatar
    Join Date
    Sep 2018
    Location
    USA,Sweden
    Search Comp PM
    It is also possible that the problem is with streams being too big to handle for the players unless you increases cache (delay).
    Try increasing the "Network Cache" in Kodi options (there's a how to in their wiki). The stream may get a few second delay,but that way you'll avoid all the glitches you're experiencing.
    For example, if the 1080p stream has a bitrate of 10Mbit/s and the network cache set is only 3Mbit (VLC,etc Default) no wonder why you are getting glitches/green pixels/freezes/etc.
    Quote Quote  
  5. Member
    Join Date
    Sep 2006
    Location
    United States
    Search Comp PM
    So I noticed that on my laptop, the video playback is flawless. However on lesser quality streams, regular 1080p, not x264 or x265, the audio gets staticy. Sviests, I will look into your suggestion. With these higher quality links, there could be the issue you mentioned. Thanks for your suggestion!
    Quote Quote  



Similar Threads