VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date
    Sep 2010
    Location
    Australia
    Search PM
    I have a commercial blu-ray disk labelled as 1080i, and MediaInfo says the m2ts files are "Interleaved fields, Scan order: Top Field First". I have encoded the disk using AnyDVD and VidCoder with all video filters set to off (including deinterlace = off). The resultant MKV file is clearly interlaced (with combing), but MediaInfo says it is progressive and tsMuxer says the resolution is 1920:1080p, so my TV does not deinterlace the picture.

    Why is the file labelled progressive after encoding by VidCoder with all filters off? Is there any way to label the MKV file as interlaced?

    I could encode using Vidcoder with deinterlace on, but the result is likely to be inferior to having my TV deinterlace the picture.
    Quote Quote  
  2. Member dellsam34's Avatar
    Join Date
    Jan 2016
    Location
    Paris Ca, 92345 Mexico
    Search PM
    Mediainfo treats fields as frames so don't count on it.
    Quote Quote  
  3. @barmah
    I am not familiar with Vidcoder, but from how you describe it I conclude that Vidcoder encoded your interlaced video source as progressive.
    If so, it is simply wrong and the worst you can do to your interlaced source. Check the settings of Vidcoder, there should be an option to force interlaced encoding and select the field order. If not, you should select a deinterlacer or bobber instead and encode as progressive. Obviously this is not what you want though for the reason you mention.
    Quote Quote  
  4. Member
    Join Date
    Sep 2010
    Location
    Australia
    Search PM
    @Sharc: VidCoder is just a convenient front-end for Handbrake.

    The problem of an interlaced file being incorrectly labelled as progressive is solved by using Handbrake (not VidCoder): in the Filters tab set everything to off; in the Video tab set fps to "Same as source" with "Constant Framerate", and in Advanced Options add :tff or :bff (top or bottom frame first can be obtained from MediaInfo set to View/HTML).
    Quote Quote  



Similar Threads