VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
  1. Hi, i have these old vhs tapes that i want to digitize, hopefully with a lossless codec like huffuyv for good quality in mind. I record with hauppauge usb2 live with the amarec recorder using huffuyv as codec and uncompressed audio. That works very good , so far so good..
    Now the editing part. I think sony vegas 14 is a nice editor. It can use neatvideo and output to mpeg2 among other things. However, the huffyuv file that i recorded cannot be opened in Sony vegas 14. What lossless codec if any does sony vegas 14 input? Should i approach the recording differently?
    Quote Quote  
  2. aBigMeanie aedipuss's Avatar
    Join Date
    Oct 2005
    666th portal
    Search Comp PM
    if you have the correct version of huffyuv it should import into vegas. always has for me. vegas 14 was probably 32bit but i could be wrong. i prefer Ut Video Codec though.
    "a lot of people are better dead" - prisoner KSC2-303
    Quote Quote  
  3. Can you open the HuffYUV-encoded video in VirtualDub? Also, if you have VirtualDub installed, does the HuffYUV codec show up in the list when you select "Compression" (Ctrl-P)? If it doesn't show up in VirtualDub, then you also won't be able to use it in Vegas.

    [edit]I just tried to install HuffYUV on my Windows 7 64-bit system. I used the same HuffYUV that I installed on the XP 32-bit partition. The installation worked, and the HuffYUV uninstall appears in the Windows Programs control panel applet.

    However, it does not show up in either VirtualDub or Vegas 13.

    So, aedipuss is probably correct that you need the "correct version" of HuffYUV. I'll poke around a bit, and if I get it working on Win7 64-bit, I'll post my results.
    Last edited by johnmeyer; 29th May 2020 at 19:45.
    Quote Quote  
  4. OK, I got it to work. To install under Windows 7 64-bit (probably will work with Win10 as well), I download the older 64-bit version from this site: is the file you want. I just copied the files from the Zip into a folder, and right-clicked to install. I then started Vegas and under the AVI template options I found the HuffYUV codec.

    To get the 32-bit version to install in my old version of VirtualDub, I used the 32-bit version.
    Quote Quote  
  5. FWIW: It seems that installing huffyuv32 or huffyuv64 on Windows10 requires manual registration as other methods failed here.
    In this example I extracted the *.zip to the C:\Temp directory.

    Now open a command prompt as Administrator, or open Windows PowerShell in W10. Then run the following commands:

    for 32bit huffyuv:
    rundll32 C:\Windows\SysWOW64\setupapi.dll,InstallHinfSection DefaultInstall 0 C:\Temp\huffyuv-2.1.1\huffyuv.inf

    for 64bit huffyuv:
    rundll32 C:\Windows\System32\setupapi.dll,InstallHinfSection DefaultInstall 0 C:\Temp\huffyuv64\huffyuv.inf
    Last edited by Sharc; 30th May 2020 at 02:12. Reason: Typo
    Quote Quote  
  6. I did that registration during one of my earlier failed attempts to install HuffYUV on Win7 64-bit. Having already done that, perhaps that was how I was able to get it to install by just right-clicking on the INF and selecting install, without doing the registration using the Administrator CMD prompt one more time when I finally found the correct 64-bit version.
    Last edited by johnmeyer; 30th May 2020 at 11:39. Reason: clarity
    Quote Quote  
  7. Installing the old version ( ) on windows 10 did it. The sony vegas 14 i have is 64-bit. Thanks very much help. I will test some more but the import worked perfectly on one file.
    Quote Quote  
  8. Glad it worked. Doing this helped me as well because I've wanted to have HuffYUV installed on my Win7 setup (I still do most AVISynth video editing on XP).
    Quote Quote  
  9. Btw, my new hauppauge live2 is installed on an old pc laptop with win7 64 bit, recording with amarectv. However, in my first capture, the colors were bad (changing, jumping) . I looked at this thread . Maybe there is something electrical causing trouble. After i few minutes of recording, the problem was gone. I used usb2.
    Quote Quote  

Similar Threads