VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. Member 12centuries's Avatar
    Join Date
    May 2020
    Location
    Ohio, USA
    Search PM
    I purchased a Toshiba DVR620 VCR/DVD combo a couple years ago and have finally gotten around to using it. I'm having two problems with it and I hope someone here has some insight.

    Problem 1:

    The VCR will not output to anything other than composite video. HDMI, Component, or S-Video only produce a blank blue screen. The DVD has no problem outputting to anything.

    So if I want to be able to look through old VHS tapes, I need to either swap to composite output or be willing to watch DVD's at 480.

    Is this normal behavior that I somehow overlooked or is this definitely broken? I've tried to follow along in the service manual as best as I can, but I'm a layman.

    Problem 2:

    I think the composite connectors are somewhat faulty. There is a high-pitched whine during playback. I can make it stop if I add some tension to the ports by pulling on the cable a bit. I don't think it's the cables because I'm using component cables that work just fine for the DVD player when connected to the component output.

    I understand I may need a professional to look at this second problem, but where would I find someone who does work like this?

    Thanks for any help.
    Last edited by 12centuries; 25th May 2020 at 16:25. Reason: fixing formatting
    Quote Quote  
  2. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Unless the unit came with one, you require the User Manual. Not a Service Manual.


    https://www.manualslib.com/download/203807/Toshiba-Dvr620ku.html


    And the unit appears to support VHS playback over S-Video, Component and HDMI
    Quote Quote  
  3. Member 12centuries's Avatar
    Join Date
    May 2020
    Location
    Ohio, USA
    Search PM
    Yes, thank you, I do have the user manual as well. As you said, it should support playback over all output interfaces, but it isn't.

    I'm wondering if anyone has seen this before and might have a suggestion about what the problem may be. (And also about the whiny noise).
    Quote Quote  
  4. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    Your problem #1 is only a problem to you in your expectations. IOW, "it's a feature, not a bug". And a very common one at that. That is how many of those combo units are built, and it makes much sense.
    The 2 output pathways are basically (nearly) independent. And basic vcr machines almost never have anything more than composite as an output option. Dvds are component by nature, so allow for high quality output options of more combinations with little extra outlay (whereas good comb filtering would be required for the vcr side, with added cost).

    Re #2, sounds like the composite jack is badly soldered and is allowing for interference unless the connection is made tight. Poor construction. Toshibas like that are some of the worst models, so no surprise. Can be fixed, but might not be worth the repair cost.

    Scott
    Quote Quote  
  5. Member 12centuries's Avatar
    Join Date
    May 2020
    Location
    Ohio, USA
    Search PM
    Originally Posted by Cornucopia View Post
    Your problem #1 is only a problem to you in your expectations. IOW, "it's a feature, not a bug".
    The user manual is pretty clear that the VCR can use all outputs. Mine just doesn't work and I was hoping someone might know why.
    Quote Quote  
  6. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    Well, so it does. And that's a rarity if it worked. But that also sounds like it truly isn't working.

    You do need a repair shop to look at this.

    Scott
    Quote Quote  
  7. 12Centuries, I have exactly the same issue. I have a Toshiba D-VR52 and using PotPlayer Video grabber to capture. Did you resolve the issue?
    Quote Quote  
  8. Often there is a setting in the menu that you have to change. On my LG VCR/DVD I had to enable RGB to get the component output to work.
    Also, you have to use video cables, NOT audio cables for component output. Video has a different Ohm rating.
    Quote Quote  
  9. Thankyou DVD3500, When you refer to the 'Often there is a setting in the menu that you have to change.' I am unsure where the 'menu' is?
    When I play a DVD, I get the DVD, But when I switch over to VCR (via a button on the VCR Panel which illuminates with a VCR indicator, I get the Blue screen as 12Centuries is describing.
    My Video Grabber has an input with Red, White and Yellow phono and an S-Video, Converting this into a USB input into my laptop. I know it is working because I see the DVD content. When outputting VCR, I am thinking that VCR must output to either Composite or Scart and is not compatible with S-Video.
    Kind Regards
    Quote Quote  
  10. I meant the Setup Menu on the VCR/DVD combo. I select either DVD or VCR mode and hit SETUP on the remote and it brings up two different menus depending on which mode I am in..
    Quote Quote  
  11. Member 12centuries's Avatar
    Join Date
    May 2020
    Location
    Ohio, USA
    Search PM
    Originally Posted by PadiRaki View Post
    12Centuries, I have exactly the same issue. I have a Toshiba D-VR52 and using PotPlayer Video grabber to capture. Did you resolve the issue?
    Sorry, PadiRaki, I have not figured out the problem yet. Have you made any progress on figuring this out?
    Quote Quote  



Similar Threads